Skip navigation

iOS 5 - Language change....HELP

10769 Views 21 Replies Latest reply: Mar 12, 2012 2:07 PM by sam.urai RSS
1 2 Previous Next
SuitUP Calculating status...
Currently Being Moderated
Oct 12, 2011 7:45 PM

So, I updated to iOS 5, and for some reason it decided that the App store, iTunes, Reminders, and even the iCloud email confirming I setup my iCloud, is in French??!!!

I live in Quebec, so hopefully it doesn't assume I only speak French......The problem is, everything is in English before the iOS 5 update, is there any way I can get back to normality......I want everything back to English, please help!

iPhone 4, Other OS, iOS 5
  • Ericvmcp Calculating status...
    Currently Being Moderated
    Oct 12, 2011 8:55 PM (in response to SuitUP)

    I have a similar problem, everything is in English except the app store is in French since os 5 upgrade. Grrrr.

  • Ericvmcp Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 12, 2011 9:31 PM (in response to Ericvmcp)

    Clearing safari browser history seems to have fix my French woods...

  • sirmav Calculating status...
    Currently Being Moderated
    Oct 13, 2011 6:00 AM (in response to Ericvmcp)

    Just posted the same issue...wondering now if it is the provider. I am with Telus and a friend of mine has Rogers with everything in English.

  • Cerapus Calculating status...
    Currently Being Moderated
    Oct 13, 2011 7:32 AM (in response to sirmav)

    I'm with Rogers and have the same problem. Clearing the history in Safari fixed the problem with the App Store. My iTunes is still in French.

  • Kary iMac Calculating status...
    Currently Being Moderated
    Oct 13, 2011 9:43 AM (in response to SuitUP)

    I have the same problem, on my ipad, the Appstore and iTunes menus at the bottom of the screen changed from English to Chinese (I am in Hong Kong) and despite setting the language to English and even changing my location to other English speaking cities cannot fix that.  Do I have to wait for future updates that deal with this problem?  It is annoying.

  • akro Calculating status...
    Currently Being Moderated
    Oct 13, 2011 12:46 PM (in response to SuitUP)

    I just had the same issue with the Appstore being in Dutch, while I'd like it in French. I solved it by:

    • opening the appstore on the iphone
    • going to the bottom of the top25 screen
    • clicking the apple account button (with my mac.com address on)
    • selecting the disconnect option
    • clicking the button again and login in (with the same account)
  • sebdub Calculating status...
    Currently Being Moderated
    Oct 13, 2011 11:45 PM (in response to akro)

    Same problem here, I live in Switzerland (french part of the country) and it also change my App Store and iTunes to german language.

     

    I tried to followings:

    - Clear data in Safari --> no effect at all (iTunes or App Store)

    - App Store : Sign Out / Sign In --> it worked

    - iTunes : Sign Out / Sign In --> did not work

     

    Please, find a solution for iTunes, I do not speak german.

  • Liquid07 Calculating status...
    Currently Being Moderated
    Oct 14, 2011 2:21 PM (in response to SuitUP)

    Same here.

    I speak French but prefer English. Please fix.

     

    Thank you

  • gregfromsydenham Calculating status...
    Currently Being Moderated
    Oct 14, 2011 6:51 PM (in response to SuitUP)

    Log into "manage your account" at;

    https://appleid.apple.com/cgi-bin/WebObjects/MyAppleId.woa/

    Select "Language and Contact Preferences"

    Change Preferred Language  to correct language.

    Select "Save Changes"

     

    Connect iPad to Mac and open iTunes, then select iPad device to open Summary page.

    Select "Restore"

    Device will restore (iOS 5) After completion, restore your backed up image.

    Language should now be correct in iTunes and app store.

  • KrisMontreal Calculating status...
    Currently Being Moderated
    Oct 17, 2011 6:38 PM (in response to gregfromsydenham)

    gregfromsydenham... I followed your procedure with my iPhone 4, on a Windows 7 PC with iTunes 10.5... without success... App Store is still in French !!  I hope Apple fixes this quick !

  • Raspberry_Red Calculating status...
    Currently Being Moderated
    Oct 19, 2011 9:52 PM (in response to SuitUP)

    Same here ; iCloud email in french & Appstore bottom is in french ... nothing above worked, xtremely annoyed

  • KrisMontreal Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 20, 2011 4:18 PM (in response to Raspberry_Red)

    I found the fix for this...   at least for the App Store.  I guess it should work for iCloud too!

     

    1. Go to https://appleid.apple.com, then log on, then go in the language settings and check if it says "French".  If so, set it to English, and save your change.

    2. Then on your iPhone, go to Settings->Store->click on your Apple id->Select "Sign Out"

    3. Then I rebooted my iPhone ...it changed the Apps in the App Store to their English version but the options bar was still in French... that was encouraging...

    4. ...so I decided to reset my iPhone and restore from the previous backup.  I did the reset not through iTunes (just in case) but directly on the iPhone through Settings->General->Reset->Erase All Content and Settings.  It took a few seconds, boot back by itself (and after a few setup questions) asked me to plug into my PC and restore through a backup I had in iTunes.

    ...After step 4, the options bar of my iPhone App Store was also in English... Hurray !!!

  • sebdub Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 20, 2011 10:35 PM (in response to sebdub)

    I finally found a solution, follow these steps :

     

    On your iPhone :

    - Go to Settings and Store

    - Click on "Apple ID: ***" --> Sign Out

     

    On your computer :

    - Go to https://appleid.apple.com/

    - Click on "Manage your account"

    - Then to "Language and Contact Preferences"

    - Change the language to what you prefer (English in my case), then "SAVE"

     

    Go back to you iPhone :

    - Run the iTunes app

    - Go to "Ping" and Sign In.

     

    --> tada, it's back to your language.

     

    The problem is the langage preference of your AppleID seems to reset randomly. Apple please fix this!

  • moonsweep Calculating status...
    Currently Being Moderated
    Oct 21, 2011 3:55 PM (in response to KrisMontreal)

    This worked for me.  In the Manage Your Account page, mine was set to French.  I changed it to English then ran the iTunes app on my phone and it was displayed in English again.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.