Previous 1 2 Next 22 Replies Latest reply: May 25, 2012 5:33 PM by AKA Billy Boy
logan118 Level 1 Level 1 (0 points)

Everytime I try to update my iPhone 4 to iOS 5 I this get an error message.

 

"The software for the iPhone "iphone" was corrupted during download.

 

Disconnect and reconnect, then try again. Make sure your network settings are correct and your network connection is active, or try again later."


iPhone 4
  • jongb Level 1 Level 1 (0 points)

    Same here doesnt work for my iphone 3s and ipad 1.

     

    Worked for imac and iphone 4

     

    pain in a*s...any one help?

  • Damon_L Level 1 Level 1 (0 points)

    I had the same issue. I use a PC. I disabled my firewall and virus software, then tried again successfully. I hope this helps you too.

  • Screenpeace Level 1 Level 1 (0 points)

    I'm using an iMac (10.6.8) and had the same issue. Tried everything listed here: 1403 iOS5 error

     

    ... and it was the Firewall (Thompson Wireless Router in my case) settings that fixed it.

  • GLC_Butterfish Level 1 Level 1 (0 points)

    same problem here. Have a Thompson Router, but to my knowledge there isn't any firewall built in. No Antivirussoftware installed, no firewall active. So i keep trying to download always the same answer : corrupted download. Hardware: MacBook Pro early 2011, OSX Lion 10.7.2, IPad2 WIFI/3G, Iphone 4.

    Any good ideas ?

  • grant77 Level 1 Level 1 (0 points)

    I am having the same problem. MacBook Pro, Snow Leopard, no antivirus software or Firewalls. Has anyone found any solutions? Thanks!

  • benthroop Level 1 Level 1 (0 points)

    I'm also having this problem. I have a Time Warner Motorola Surfboard Modem/Router. Maybe that's an issue. I'm going to go off wireless and try a wired connection. Seems like an odd fix but it's an odd problem.

  • benthroop Level 1 Level 1 (0 points)

    Yep that worked.

  • grant77 Level 1 Level 1 (0 points)

    I tried plugging my laptop directly into my (Sky) router but that didn't help. I even tried updating my iPhone via my spare laptop (which has Lion) and even there I get the same problem.

     

    The coruption problem is actually broader than just occuring when I try update my iOS5 - I'm having corrupted data errors when I try to update my software too - and annoyingly the error only gets displayed at the very end of the process - after the download has completed.

     

    This leads me to think it's either the router itself, my ISP or my Apple account that is the problem. Any advise would be much appeciated. Apple Express Lane Tech support so far haven't had any ideas.

  • Screenpeace Level 1 Level 1 (0 points)

    Can you get onto your Sky router (put it's IP address in your web browser) and change the settings?

     

    For me, disabling the firewall function fixed it. I now have created a DMZ where the Time Capsule is in, so effectively the TC has become the central point in my network and the (ISP provided) Thomson Router/Firewall/Access-Point's functionality is reduced to the absolute minimum. No more issues since.

     

    Doesn't seem to work for all but worth trying especially as you are getting the error on multiple computers in your network.

  • Matt Wolanski Level 6 Level 6 (10,255 points)

    I have been having the same problem - just very inconsistenly - two iPhones, one attached to Mac and the other to Windows updated just fine yesterday - today the iPad connected to the same Mac keeps saying corrupted - it is sayingonly 3 minutes to download - compared to about 10 or 12 minutes for the iPhones yesterday.

     

    I restarted iTunes - and the download is now showing more like 10 or 12 minutes total. and then it worked. or at least it looked like it was going to - got the full 700MB or so download and THEN said it was corrupted.

     

    this also happened when iOS 5 first came out - I just kept trying - might have rebooted my cable modem - but not really sure that anythign I did or did not do had any impact on it.

     

    You would think that if the issue was on Apple's end that they would have some wya to detect multiple failed attempts to download and look into any network issues on their end that might be affecting this.

     

    Download of iPod update on another mac on the same netwokr is saying 30 minutes to download - which seems odd since the file sisze is the same - but for some reason that download is only running at about 2Mb/sec comared to 10Mb/sec for the iPhone and iPad downloads on this Mac.

  • Matt Wolanski Level 6 Level 6 (10,255 points)

    iPad download worked on abotu the 10th attempt.

  • DWG1 Level 1 Level 1 (0 points)

    This is extremely dissapointing. I've spent at least 10 hours on this with no resolution, having shut down antivirus, firewall, and killing every conceivable competing process to get the darn thing to just download. Finally at 3am it does, only to say the file is corrupted.

     

    Apple, you've got a problem. Maybe I'll find out some small thing I've done that will make this work, finally. But when you have an update that is this fragile, and numerous posts about this and each of the related issue without resolution, it's just bad.

  • tattoohead Level 1 Level 1 (85 points)

    Download the firmware directly (Google), then when you're in iTunes press the 'shift' key (Windows only) and restore button in iTunes then direct it towards the firmware you've just downloaded. I had to do this for my iPhone 4S and my iPad 2.

  • DWG1 Level 1 Level 1 (0 points)

    Finally, after 9 more hours it worked. The problem must be have been with the Apple servers, as I did nothing different. Not cool.

Previous 1 2 Next