Previous 1 2 3 4 Next 77 Replies Latest reply: Jul 29, 2014 5:48 AM by Jack01945 Go to original post
  • ShadyMac Level 4 Level 4 (1,250 points)

    Yes. The caller ID is in iPhone only for IMessage.

     

    I had issues getting iPad and iPhone to actually sync up when sending test iMessages to my wife who also has iOS 5 on her iPhone.

     

    Whether it was coincidence or not the trick that made it all work was going into both iPhones mine and hers and in the iMessage settings you'll see a field that says caller ID. I changed this option and selected the email address for both iPhones and only after that did I get joy.

    Not sure what that option is and it does NOT make her iPhone pulse an email address to other people she texts...

     

    I also made sure that in both of our separate contacts we had each others iMessage apple ID email that's tied to iMessage.

     

    Strange but that worked for me.

  • rbbcpa Level 1 Level 1 (0 points)

    Apple's much-anticipated iOS5 has a lot of cool features, one of which is the iMessage platform.  What I've discovered is a lot of confusion among the masses on how this platform works.  I, myself, have been confused on how to set this up so that I can maintain iMessage convos on both my iPad2 and iPhone.  Last night, I set out to figure this all out and post my findings here.  What I am about to outline has worked for me and I feel is the way Apple intended it to work.  For good or bad, I don't plan to discuss the merits of how Apple has designed this platform.  I am simply sharing what has worked for me.

     

    In order for me to test my theories I used my iPad 2, iPhone 4S and my wife's iPad and iPhone 4.  This allowed me to test the iMessage platform as if I were messaging one of my contacts who I know had installed iOS5 but theoretically doesn't live under my roof, so to speak.  My example will center around my particular situation:  someone who has both an iPad (or other non-iPhone device) and an iPhone 4S (or 4 or 3GS) AND wants to keep iMessage convos in sync across all my devices.  After all, this is one of the main benefits of iMessage that Apple touts.

     

    First and foremost, it is important to activate iMessage on all your iOS5 devices using the same Apple ID.  This will "link" all your iOS5 devices in the Apple ecosystem and keep convos you initiate in sync across your iOS5 devices.  Some of you may run into a situation like I did where our PRIMARY Apple ID is the one we use as a family to purchase music, apps, etc.  In the case of iMessage, every family member should have their own unique Apple ID (a secondary ID to your primary ID) to use on their own iOS5 devices.  This will keep all your iMessages separate and distinct from other family members' iMessage convos.  The next important setting, and the one that causes a lot of confusion, is the "Receive At" setting.  On your iPhone this is your cell phone number, by default.  You will also want to add an e-mail address as another "Receive At" location.  If you have an iPad or other non-iPhone iOS5 device, you will want to choose an e-mail address (on my devices my Apple ID is the same as my e-mail address I am using on the "Receive At" setting) as your "Receive At" setting.  The important thing to note is that if you have both an iPhone and iPad (or any other non-iPhone device) you will want to use the same e-mail address on both devices.  This will help keep your convos that others have initiated to you in sync across your iOS5 devices.  Finally, the Caller ID is the next setting to consider.  You have two options here:  (1) your cell number, or (2) the e-mail address you entered in the step above.  Your choice depends on how you want others to see your contact info and whether or not keeping convos in sync across your iOS5 devices is important.  My example below will illustrate this.

     

    EXAMPLE:

    Keeping messages in sync across my devices is important so I have provided my Apple ID that I used above to all my contacts who use iOS5 devices and I have asked them to use this to iMessage me.  This is the only way that an iMessage convo initiated by one of your contacts to you will stay in sync across all your iOS5 devices.  If they use your cell number, then the iMessage convo will only show up on your iPhone.  Even though the Apple ID you used to activate iMessage in the Apple ecosystem links your devices, a reply from your iPhone to an iMessage sent only to your cell phone will not "push" the reply to your non-iPhone device.  Long story short, give all your iOS5 contacts the e-mail address you entered above in the "Receive At" setting and all your convos will stay in sync.  This is very similar to the BlackBerry Messenger protocol and the PIN that BBM users need to provide other BBM users so they can message each other.


    I commandeered my wife's iPad and iPhone and began sending iMessages back and forth between my and her devices.  Step 1, I sent an iMessage from my iPad 2 to her cell number.  Because I initiated the iMessage to my wife and my devices were both activated in the Apple ecosystem using my Apple ID, the convo appeared on both my iPad and iPhone but she received my iMessage on her iPhone but NOT her iPad.  This is because her iPad is connected to the iMessage platform through her "Receive At" email address; there is no "link" between her iPhone cell number and her iPad.  When she responded to my iMessage, the convo continued to appear only on her iPhone but appears on both my iPad 2 and iPhone.  Step 2, I sent her an iMessage to her "Receive At" email address and she received the message on both her devices.  As in the first scenario, the convo appears on both of my devices.  At this point, because I used her "Receive At" email address, the convo is in sync on both of her devices. Here is an important tip:  when you type in a contact name on the "To:" line of an iMessage, their available iMessage "Receive At" email addresses and cell phone number will appear with a little blue balloon next to them.  The opposite of the above occurred when my wife initiated the iMessages to me as described in Step 1 and Step 2.

     

    In summary:

    First, make sure you activate iMessage on all your devices using your unique Apple ID.  This links your devices in the Apple iMessage ecosystem.  Second, choose a "Receive At" email address that you can provide to your contacts that use iOS5 so that convos that they initiate to you will be in sync across your iOS5 devices.  Lastly, I recommend setting your Caller ID to your "Receive At" email address.  This will prompt any users that don't have your "Receive At" email address to add it to their contacts.  It may go without saying, but if your iOS5 contacts have multiple iOS5 devices and they are interested in keeping their convos in sync across their devices they will have to provide you their "Receive At" email address as their preferred iMessage contact.

     

    Hope this helps.

  • MacHay Level 1 Level 1 (15 points)

    Thank you so much for this detailed fix. At last both my devices are in sync. One point I also noted, it only starts working with completely new messages. Trying to add to a current thread did not work. So delete and start a new message and all works as noted. Thanks again

  • rbbcpa Level 1 Level 1 (0 points)

    Glad it worked!

  • drummergirl13 Level 1 Level 1 (0 points)

    Thank you! I now have my iPhone and iPad synced on iMessage :) Do you know what happens if I'm not on wifi and an iOS 5 user wants to iMessage me? Will it default to my cell number even if I set my email address as the Caller ID?

  • InJeanne Level 1 Level 1 (0 points)

    THANK YOU!!!!

  • bioniqueultra Level 1 Level 1 (5 points)

    i deactivate de MMS messaging  on the iPhone...and the iPad conversation sync started to work!

  • bioniqueultra Level 1 Level 1 (5 points)

    reactivated it later... and the iphone/ipad conversation sync is still working!

  • kanyfilm Level 1 Level 1 (0 points)

    i was having the same problem.  noticed my ipad was logged in myname@mac.com  and phone was @ me.com.  made them consistent, restarted imessage and now it works...  just have to play around a bit.  great feature tho!!!

  • davidfromwinfield Level 1 Level 1 (65 points)

    I don't want mine to sync how do I stop it please help!

  • kanyfilm Level 1 Level 1 (0 points)

    just go into the settings on the device and turn off iMessage

  • Kenneth Termin1 Level 1 Level 1 (5 points)

    Thanks for the tutorial. The wife and I were getting very frustrated when she would text me and it would go to my ipad at home and not my iphone while I was at work. So, thanks again!

  • Arnel Nacino Level 1 Level 1 (0 points)

    So, just to be clear, even if I've changed my caller ID On my iPhone 3GS to my Apple ID email address, other people who do NOT have iOS 5 devices of any kind ie Apple Haters, will still be able to text me, cellphone number to cellphone number? 

     

    Thanks

  • Whet Wurm Level 1 Level 1 (0 points)

    I'm not sure who put together iMessage, but it's really counter-intuitive.  Why does it have to have a "Caller ID" at all.  Why not just have EVERY message sync with EVERY device and then have a toggle switch to turn off iMessage at the device level? 

     

    I love iMessage, and it has a lot of potential, but it needs refinement.

  • Stefan Laros Level 1 Level 1 (0 points)

    I think I've understood all of this, but I am still having erractic behaviour with iMessage. I will outline a few situations.

     

    First off though, I am using iPad 2, iPhone 4S, all with the latest iOS (5.0.1 at the moment) and I have the Receive At addresses and numbers all filled in correctly (on iPhone both number and Apple ID email address; on iPad the same Apple ID email address) and the Caller ID on the iPhone is set to that same Apple ID email address).

     

    Now for the examples:

     

    1. When I initiate a conversation with a friend from my iPhone or iPad, it will appear on both my devices. If he replies, its shows up on both. So that's exactly as I would expect it to work. However... if he initiates the conversation, it will ONLY show up on my iPhone and the conversation does not syn to the iPad (even if I reply).

     

    Although I don't have an example of it on my iPad at the moment, I am sure there have been conversations initiated by others, that appeared on both my iPhone and iPad.

     

    2. Another friend sent me an iMessage that arrived on my iPhone only. I sent a reply, which only shows on my iPhone. Then the following day I sent him another reply (WITHOUT having deleted the conversation first), and that message (from me to him) appears on both iPhone and iPad. His reply shows on both as does the rest of the conversation. There is nothing I did (as far as I know) to explain this change in behaviour. So the conversation on the iPhone is the complete one; the one on the iPad "joins in" at some point, with the first few messages missing.

     

    3. I have a conversation on both iPhone and iPad; the one on the iPhone is in the right order, but the one on the iPad is not.... how does that happen? In this particular conversation it's not causing confusion, but it's not difficult to see how that sort of thing can lead to a lot of misinterpretation all over the place.

     

    All in all very strange if you ask me. Does anyone else have this? Any suggested solutions? I thought it might be to do with the network operator (O2 in the UK), but they say everything is working on their end, and that it is a problem on Apple's end.

Previous 1 2 3 4 Next