Previous 1 2 3 Next 79 Replies Latest reply: Mar 27, 2015 2:07 PM by Kiwi518
BehnRocker Level 3 Level 3 (690 points)

Hey all,


So, I have a 3GS and an iPad 2, both on iOS 5.0. One of the advertised iMessage features is that you can start the conversation on one device, and finish on the other. However, messages I receive on my iPad don't show up on my iPhone, and vice versa.


I've heard that this has to do with the Caller ID defaulting to the device's phone number on the iPhone, but I'm not 100% sure if this is the case or not. I've also heard of other people having success of this syncing between iPhone and iPad, so I'm really not sure.


Just wondering if anyone has any insight as to why iMessage isn't syncing between my iPad and my iPhone that are both signed into the same Apple ID/iCloud account?



  • tyassine Level 1 Level 1 (5 points)

    I'm having the EXACT same issue with my iPhone 4 and iPad 1.



  • tyassine Level 1 Level 1 (5 points)

    figured it out!

    make sure "set caller ID" is set to the same address!

  • BehnRocker Level 3 Level 3 (690 points)

    Tried this, but it's still not syncing, even with the same Caller ID address set on both devices.


    Anyone else have any thoughts?

  • Cory Bauer Level 2 Level 2 (275 points)

    I set the Caller ID under the iMessage preferences on my iPhone 4 to my email address instead of my phone number, and I'm still not getting any conversations showing up on my iPad 1.

  • Tsac77 Level 1 Level 1 (0 points)

    I don't have a Caller ID preference in my iMessage preferences, but I do have one in my phone preferences.  Is this the one you're talking about?

  • Tsac77 Level 1 Level 1 (0 points)

    Where exactly is the "set caller ID" setting?

  • tyassine Level 1 Level 1 (5 points)

    Settings>Messages>Recieve At>Caller ID

  • BehnRocker Level 3 Level 3 (690 points)

    So, it just started to work today for no reason.


    I was talking to a work mate about this. Seems as though the messages I sent him yesterday from iPhone and iPad were all in one message for him, but a message I sent this morning showed up as a separate message thread. I deleted all threads from my iMessage contacts on both iPad and iPhone, and then they started to sync properly. The first message I sent my work mate showed up on my phone and my iPad. Not sure if deleting them is what fixed it, but everything worked after that, while directly before deleting them it didn't work.


    May have had to do with setting iMessage up on one device, and using it before setting it up on the other device, maybe.


    Unsure, but it works now. Hooray.

  • Josh 90046 Level 1 Level 1 (10 points)

    I just sent a new message to the persons using their phone number from my iPad and now they are syncing on both devices. Hope this helps!

  • borzy Level 1 Level 1 (5 points)

    As far as I can gather, the Caller ID setting directs where replies to your message are doing to land.


    So on your iPhone, the "Received At" will have both your phone number and your Apple ID.

    On your iPad, the "Received At" will probably just be your Apple ID.


    So if you were to message someone from your phone, and they reply to you.... If your caller ID was set on your phone number, the reply will only go to your phone.  But if your caller ID was set on your Apple ID, then then when some replies to your message from your iPhone, whole message thread will sync across both devices.

  • Stephen West Level 1 Level 1 (0 points)

    I thought the same.  Then I had a group chat with another iPhone + an iPad and that chat ended up syncing to my iPad also.


    Apple needs to put out a definitive guide to navigate these iMessage waters.

  • John O'Keefe Level 1 Level 1 (5 points)

    I'm pretty sure the caller ID actually identifies where the message originated.  On the phone it can be a number or an email address. On the iPad it can only be an email address.  I'm thinking the sync issues have to do with the service itself going live and possibly a bug in the way the service connects phone numbers and Apple IDs.


    I have not been able to produce consistent results. For example, last night, I was sending iMessages from my iPhone to my wife's iPhone number (not her Apple ID) and the conversation was syncing on my iPad but not her iPad. This morning I did the same thing and it would not sync on my iPad or her iPad. Conversations originating on the iPad (hence the Apple ID) seem to sync fine.


    It seems to me that for now the only way to ensure that a conversation thread says synced accross all devices is to make sure the conversation begins with an iMessage to the Apple ID rather than to a phone number.


    Maybe some of you have figured this out, but the diverse number of responses in this thread and others suggests to me that the service is behaving a little erratically.

  • John O'Keefe Level 1 Level 1 (5 points)

    I'm not sure about that. I think the caller ID just identifies where the message originates. I think this syncing problem is actually in the system and related to rolling out a new service.  Frankly, I have not been able to get consistent results.


    For example, last night I was sending iMessages to my iPhone to my wife's iPhone.  Both phones have caller ID set to phone number and the messages were sent to her phone number, not her Apple ID. The conversation thread show up on my iPad but not her iPad.  If I did the reverse, that is sent the message from her iPhone to mine, I still got the tread on my iPad but not her iPad. Conversations originating either iPad to either Apple ID synced just fine on all devices.


    That said, this morning, I tried the exact same thing - sending a message to her phone number from mine -- and this time my iPad did not sync as it did last night and her remained unresponsive.


    My conclusion: the service is behaving erratically and the only way to ensure a fully synced thread for now is make sure the conversation originates with a message to an Apple ID and not a phone number.

  • John O'Keefe Level 1 Level 1 (5 points)

    Sorry about the double post. I tought the first one did not work.

Previous 1 2 3 Next