Previous 1 24 25 26 27 28 Next 537 Replies Latest reply: Aug 18, 2015 3:24 PM by rtneace Go to original post Branched to a new discussion.
  • Kimballer Level 1 (5 points)

    Ok. I had the same problem just a couple hours ago and here's what worked for me: Settings--> General--> Reset--> Reset Network settings.

  • applesucksbad123 Level 1 (0 points)

    This is happening to me too. Facetime works fine, but iMessage stays saying "waiting for activation."

     

    This is RIDICULOUS.

  • chaos.rox Level 1 (0 points)

    There apparently was a service disruption.  My phone still hasn't activated but I'm hoping by tomorrow morning it will.

     

    http://news.cnet.com/8301-13579_3-57551579-37/apples-imessage-service-experienci ng-another-disruption/

  • cdklein11 Level 1 (0 points)

    Hi All,

    I struggled all day long with this issue and I FINALLY got it to work after much frustration and refraining from throwing my phone against the wall, but for those of you still having an issue I wanted to share what I did to fix it!

    So:

    - I started with all the quick fixes such as turning iMessage and FaceTime off, turning my phone on/off via the lock button and holding the home button and lock button, tried pulling my SIM card out (without rebooting the phone), tried signing in and out of my Apple ID in both, tried various combinations of signing in and out and then rebooting my phone, tried restoring my phone, resetting all of the settings BUT here's what finally worked for me, in this order:

     

    - First ended up changing my password to my Apple ID, not sure if that matters or not but thought I'd mention it anyway

     

    - I went into Settings>General>Reset>Erase All Content and Settings (IMPORTANT: BACK UP TO ICLOUD OR ITUNES BEFORE DOING THIS)

     

    - I then proceeded to let my phone do it's thing while erasing everything

     

    - Then instead of restoring my phone from back up I set it up as a new phone (don't panic you can restore it later via iTunes or iCloud)

     

    - I was frustated because that still wasn't making it work HOWEVER I then went into iTunes and still restored it from my last backup because I was ready to give up BUT then I tried one last thing

     

    - I pulled out my SIM card again like the first time but instead of putting it back in right away I kept it out and hard rebooted the phone (hold down home key and lock button at the same time until apple logo comes up, about 10 seconds or so)

     

    - When the phone booted up and said "No SIM installed" I pushed the SIM card back in

     

    - While this was going on I went into iTunes and when to the iTunes store, in the top right hand corner where it shows your apple ID, I clicked on it and typed in my password and clicked "View Account"

     

    - I scrolled down to "iTunes in the Cloud" and clicked "Manage Devices"

     

    -I didn't end up doing anything with the settings because I checked my phone again and amazingly my iMessage and Facetime were working like a charm.

     

    Don't know what combination of things that it was that made it work in the end but I hope this will help someone who is as frustrated as I was!

  • Tyler Nettestad Level 1 (0 points)

    I realized that "my info" was not set in my contacts so it was not letting me use my phone number on my new iphone for imessage and facetime. I had to go to Settings>Mail, Contacts, Calendars. Scroll down to "My Info" and make sure you have a contact card set up with your name and phone number and it is selected for you own info.

  • Sprungson Level 1 (0 points)

    This issue was really frustrated to me, and i usually never write on threads, but i wanted to atleast tell people that this worked for me.... 

     

    I followed what Tyler Nettestad said, and i was able to select my phone number in my phone, ipad, & mac.. I am now just using my phone number in all three devices.  Thanks a lot.

  • fertorab Level 1 (0 points)

    Thank you very very much Tyler. Facetime and imessage  works again ... That´s the key,

  • ashley3490 Level 1 (0 points)

    Kimballer's solution worked for me.  My info was already selected, so maybe a combo of the two!

  • 3tr3x Level 1 (0 points)

    just a note, after a lot of research , it appears that the apple servers were down, for a lot of people, this is the real problem, what apple needs is a way to notify the public of when these things happen, it would cause a lot less problems , and for the those who still don't work, can then start finding the solution to their problems.

  • tungddao Level 1 (0 points)

    Use my method by following this link: https://discussions.apple.com/message/20327628#20327628

    That will help you clear out the issue!

  • Zoddex Level 1 (0 points)
  • kavlo26 Level 1 (0 points)

    Thanks! That worked for me as well!

  • Plappers Level 1 (0 points)

    Thanks Tyler, the My Info fix worked for me. Think the problem started when I linked my Facebook accounts to my phone, and I don't store my mobile number on Facebook. Added it to the phone contact it was using and iMessage came back.

  • tomas.bek Level 1 (0 points)

    I have the same annoying problem. After clean restoring to iOS6.0.1 for the first time, my iMessage settings were wiped out. So I just entered my Apple ID and password, in the next page it showed my phone number + my e-mails. However, after pressing the last button it just tries to activate, and in Send/Receive section mobile phone number is gone!

     

    I am trying to activate iMessage for 24 hours now and nothing helps

     

    photo.PNG

     

    I have been repeating turining on/off iMessage for hours but it won't activate

  • MPagani Level 1 (0 points)

    After reading article by tungddao I finally figured out my issue. I am on a top up package and with out extra credit it will not send an international sms. This in turn prevents imessage from activating as an international sms is needed to activate.

     

    After topping up my account and turning on and of iMessage and Facetime all is working now.

Previous 1 24 25 26 27 28 Next