Previous 1 31 32 33 34 35 36 Next 537 Replies Latest reply: Aug 18, 2015 3:24 PM by rtneace Go to original post Branched to a new discussion.
  • kelviantor_2 Level 1 Level 1



    This worked for me. Most of the time the sms center number is incorrect. First step is to check the sms center number by pressing *#5005*7672# press call.


    You will then get the message


    Setting Interrogation Succeded

    Service Center Address

    +447958879879 (T mobile UK)


    If your sms centre number is incorrect, type in


    Once complete the folllowing message will appear

    Setting Succeeded

    Service Center Address

    No Address


    Check typing *#5005*7672# to confirm sms center number has been changed.


    Good luck :-)

  • ArifH Level 1 Level 1

    Worked Perfectly!!!!

    I had almost given up hopes after having tried everything on almost all the forums!!

    Thanks a ton!!

  • ArifH Level 1 Level 1

    Try this!!

    Go to settings --> IMessages --> Uncheck the email address (if checked)--> Turn off iMessages

    Do the same for FaceTime settings as well.


    Go to General --> Reset --> Reset Network Settings

    It wil reboot the phone. Once the phone is up. Turn on the iMessages and it should auto detect your phone number for iMessages.

    P.S: Upon rebot it may ask for your apple Id Password.


    Hope this Helps

  • Yardly24 Level 1 Level 1

    Thanks Thomas. Your solution did work for me. I spent 2 weeks with activation failures with imessage and facetime. 2 weeks web research, 2 days on phone with apple support. They has suggested me to do a restore my phone, and when it did not work to replace my device. I was not convinced to replace my device for a validation issue with either my carrier or apple server.


    Finally i updated my contact details on my apple account changed password, deleted my account which had in my other ipod, meanwhile imessage and facetime was off. Gave it a 42hrs reset my phone. and today i tried ..... AND IT DID work.

  • MartinaBecka Level 1 Level 1

    I tried everything include restore iPhone - without resolution. ONE THING helped me...


    In Settings I changed my number to my friend's number... then in Messages I switched on iMessage (still text - waiting on activation), but my number in outcoming and incoming is now BLACK and checked (not gray and not checked). Even that iMessages are still in phase "waiting on acitivation" for me are working without problems.


    Hope I'll help somebody to solve this annoying bug.

  • ellenholcomb Level 1 Level 1

    Okay guys I tried all these and nothing worked for me.


    My imessage only worked on wifi.


    So I called sprint and this worked for me!!!


    Go to Settings>General>Reset>Reset Network Settings

    Then your phone will turn off and back on


    Once its back on type in this in the keypad ##273283# then dial and it should say "Starting Service Update" and then you hit "OK". Wait anywhere from 30 seconds to a minute and a message should pop up that says "Service Update Complete".


    If it fails, turns your phone on and off and try it again.


    This worked for me on the second try. It took about 2 minutes to kick on. Make sure the wifi is turned off once you check it. Check it by going to a internet site and texting another imessage user by making sure it's blue and not green.


    Hope this helps!


    Btw I live in the Ohio (USA) so I don't know if that number is the same for your area, might have to call sprint and check!

  • gabrielpop Level 1 Level 1

    Well, iTunes provides (send) your email accounts for iMessage and Face Time. SO my advise would be to quit ( force quit) and restart iTunes on your Mac. iTunes will automatically do these jobs and let you know by banners on your screen. Something like : 'iMessage uses youremail@yourserver'. Same for FaceTime.That's all.

  • ccvanklyn Level 1 Level 1

    Sorry if this a stupid question but how do you type in "smscentrenumber"?

  • Luism94 Level 1 Level 1

    nguyenann13 is right... Just go to iTunes and press restore. Then when it says do you want to backup your device say no! Then the new firmware will be downloaded into your phone. Finally when everything is done check that your iMessage and Facetime is working. Then go back into your iTunes and restore your old stuff. I did this and it worked the first time.

  • zoecita Level 1 Level 1

    My Solution:


    For about a week, I've had my iphone stuck on "waiting for activation" for both imessage and facetime, not letting me sign in with my apple id either.


    I have ios 7 beta 3 on my phone with a registered UDiD and everything but I never experienced a problem with imessage with ios 7, well until I updated it so I'm not claiming this works for everyone.


    What I did was download ios 6 (and ios 7 beta 3 which was already on my computer) onto my computer to see if ios 7 was the problem. I went to settings and turned imessage and facetime both OFF! Then, I plugged my phone in, backed it up on the computer, then pressed option + check for update and selected the ios 6 software. itunes then said I couldn't restore the data from my phone because the back up was "too old" (ie, from ios 7 not ios 6). Next, I clicked Restore iPhone and set it up as a new phone when asked because again my back up wouldn't work. Next, I clicked option + check for update and now chose the ios 7 update. After that, I clicked restore backup... and clicked my original back up that i did before I updated back to ios 6, waited for everything to download again. Then went to settings and turned on both imessage and facetime. I checked back after a minute and imessage and facetime were both back up and running!


    Hope this helps one of you!

  • Scoobydoo1973 Level 1 Level 1


       I fixed this issue on my i phone 4 .As dre_apple above .Went into my i tunes account and checked  the mobile   number is the same number that  is Saved as My number in phone settings .I still get the waiting for activation message but i message started to work within a few  minutes .

  • Mortessa Level 1 Level 1

    So.. almost a whole year later, this was the problem. I had already put my phone number in as "my phone number" but in my contact info it had put my iPhone number as some random number and my real cell number was under the 'mobile' field. I deleted the 'mobile' and put my number in the 'iPhone' field and then it worked. Thanks dude!

  • rachel_Adepoju Level 1 Level 1

    I'm with vodafone IE and maybe it's just my network but I had to top up before it would work so maybe you just need to top up or get a data plan

  • mallaraj Level 1 Level 1

    This is what we extactly need to do. No need to hard reset and blah blah...

  • Mosandre Level 1 Level 1

    There is probably a ton of ways to resolve this problem!Mine didn't work with any of the suggested methods. I spent so much time resetting networks, restoring in iTunes, the App store signing in and out, and waiting patiently but none of them worked. I decided to take a walk and after a couple of hours of tinkering with the device, I tried some more and ALAS I figured something that DID it for me!Under phone settings, show my caller ID was switched OFF. Flipping the **** switch to ON worked wonders!!Give it a shot guys and thank me later!!!