Previous 1 2 Next 16 Replies Latest reply: Nov 10, 2014 12:57 PM by Saad 221999
Aditya Yadav Level 1 (5 points)

I've updated my Factory Unlocked iPhone 4 to iOS 5.0 this morning.


Everything's fine but I'm having a hard time Activating iMessage and Facetime. I have created an iCloud email. I've made that my Primary Apple ID and attached it to my iMessage.


Whenever I try to turn it on it says 'Waiting for Activation' and then after a long time, it says Activation Unsuccessful.


I'm on Vodafone India Network operator (GSM). Also, when I try to add another email, it says that the email is already in use if it's an Apple ID. If I create a new email account (one which is not an apple id), iMessage sends me a verification email and after I click 'Verify Now' it opens the Apple ID verification page which asks for my Apple ID and Password to complete verification. Now How can I have a password if the email is not yet registered with an Apple ID.


Also, there's no phone number tab in my iMessage 'Receive At' option. And I never got any confirmation email on my Primary Apple ID (iCloud ID).


I've even tried the following:

- Reset network settings

- Restarted the phone several times

- Tried over Wi-fi and 3G

- Waited for a long time.


I'll really appreciate any kind of help activating my iMessage and Facetime. Thanks!

iPhone 4
  • Aditya Yadav Level 1 (5 points)

    I got it to work. Finally. After 2 days of failed attempts and countless hours of google, I figured it out myself.


    I put my iPhone in DFU mode. (Just google how to put your phone in DFU). And then did a clean restore of iOS 5. Now Facetime & iMessage are working great!

  • ruffstuff Level 1 (0 points)

    I've encountered the same problem.


    When you did a full restore, did you recover a backup or not? when i did a full restore with backup recovery, the problem still persists.

  • Aditya Yadav Level 1 (5 points)

    No, I didn't restore from a Backup. I restored it as a new iPhone. You should try putting your iPhone in DFU Mode and then restoring it. That's what solved my problems.




    Settings>General->Reset->Erase All Content and Settings. and then Restore it as a New iPhone.


    That should work.

  • svictorino Level 1 (0 points)

    I still have the same problem. I already did a factory reset, I set up as a new iPhone.. It worked for 1 hour or so... then it went back to regular Text Messaging. This was y'day. Today iMessage worked for 5min... I was able to send 2 messages over iMessage and then went back to text messaging. On iPad2 is working great, I turned my iPad2 off but nothing changed. Now I gave up and came back to whatsapp. Maybe some day apple will figure out how to create a good messaging system.

  • seq2 Level 1 (0 points)

    I have a solution to all of you who faced this problem of waiting for activations for both FaceTime and iMessage.

    Here's how I did mine;


    For "FaceTime"


    1) Launch "Settings" app

    2) Select "FaceTime"

    3) Select "Apple ID: (your ID)"

    4) Select "Change Location" (to where "Country" your phone number is registered)

    5) Select the "Country" you are in

    6) Back to "Settings"


    Do the same for "iMessage"


    1) Launch "Settings" app

    2) Select "Messages"

    3) Select "Receive At"

    4) Select "Apple ID: (your ID)"

    5) Select "Change Location" (to where "Country" your phone number is registered)

    6) Select the "Country" you are in

    7) Exit


    After you've done all the settings as aboves; Now hold down the "Home" and "Power" button until you see the "Apple" logo to reboot your iPhone. Let go you fingers after seeing the "Apple" logo appears.


    Go back to the "Settings" app.


    For "Facetime"


    1) Select "FaceTime"

    2) You'll notice your "FaceTime" has been activated

    3) Go to the bottom and Select "Caller ID"

    4) You should have your "Phone Number" selected

    5) Back to "Settings"


    For "iMessage"


    1) Select "Messages"

    2) You'll notice your "iMessage" has been activated

    3) Select "Receive At" (now you'll see "2 Addresses >)

    4) Go to the bottom and Select "Caller ID"

    5) You should have your "Phone Number" selected

    6) Exit and enjoy your iOS5


    Hope that helps. Cheers!

  • alexander293 Level 1 (0 points)

    after one week trying to get imessage activated it worked today.

    what I did:

    1) change my apple-id password --> apple now requires at least 1 uppercase letter, my old one didn't have one (maybe the issue???)

    2) restarted iphone

    3) settings/message/receive at --> touch the apple-id, log-off, log-on again with the new password and activated immediately with my phone number.

  • Fenerium Level 1 (0 points)

    I have been having this problem ever since i buy new iPhone 4S in Australia Melbourne since first came out and fixed today.


    Basically my problem was i can send iMessage but no SMS to standard phones. And my iMessage and facetime wouldn't activate at all even though i have the right plan with lots of credit.


    After extensive hours of backups and restores i have fixed and is only small issue.


    Happy to help you all.


    Here is the problem.


    1) First check you have enough credit or BALANCE in your phones bill account. If you do and have valid SMS function enabled from your carrier then proceed to next step, Please call your phone carrier make sure you have credit and sms is enabled.




    2) Ensure you are still logged in to your apple id in message and facetime however Turn off iMessage and Facetime (settings-> imessage & settings -> facetime)


    3) Please type in phone -> keypad *#5005*7672# and then press CALL


    This will show you your SMS service center number.


    Now please note if it does provide you with a number write it down, now Phone you phone carrier and ask them if this is the correct SMS service center number for your Contract/Prepaid/Postpaid plan. verify with them. If it isn't get the new number. You can also look on GOOGLE for the right service number just search it.


    If there is no number/address showing then this is also the problem which was my same problem


    So i found my SMS service center number which is for Virgin in Australia number was +61411990010


    Now when you get correct the service center number you type it together in keypad and press call:


    So What i typed is




    You just must replaced the +61411990010 with your carriers service center number and your done.


    Once the number is set you now goto settings iMessage and Facetime (settings-> imessage & settings -> facetime) turn them on as you desire! All works. Provided that your service center number was set correctly.


    I have been on the phone to APPLE customer support they could not even figure this out i figured it out after so long.


    Good luck i hope this works for you all!

  • urbanhopper Level 1 (0 points)

    This worked for me. Prior to iOS 5, my password consists of numbers ONLY.


    Thanks man!!!

  • selenasegura Level 1 (0 points)

    I have the same problem with my iPod touch :/ any help ?

  • iRadicalOne Level 1 (0 points)

    Mine doesn't even get that far, I try to log in then touch next then to goes to the email verification page and either goes back to the log on screen or I quickly touch verify then it goes back.  I haven't rebooted but am about to do that.  It is really annoying.


    NEED HELP!!!!!!!

  • redfish907 Level 1 (20 points)

    I'm temporarily out of the US and have no cell signal. My iMessage worked in the US, but quit working overseas; this is to help similar people. After iMessage quit working I was able to apply and send messages w/ my AppleID but not cell phone number. All I did was sign out of Apple ID under Settings >> iMessage. Then went to the AppleID account website and removed all phone numbers from my account. Save. Sign out. Checked Settings >> Phone listed my correct number. Restarted phone via Home + Top button. At restart I turned on iMessage and iMessage activated and my cell phone number verified. Add AppleID if you want.

  • Kliffy Level 1 (0 points)

    Problem solved! If you have premium sms service deactivated enable it by calling the operator. And wait 24h then enable Facetime and Imessage and it should work again like charm!

  • thuru Level 1 (0 points)

    oh my word dude/ dudette ! thank you so much! saved me a trip to Apple!


    it worked.





  • Tim B. Level 1 (5 points)

    I've been trying to resolve this for days and have tried everything. Confirming the country location and doing a reboot suddenly and miraculously activated my phone number and allowed me to use it for both iMessage and FaceTime. Thank you!

Previous 1 2 Next