Skip navigation

iOS 5 iPhone update Ringtones won't sync

212219 Views 177 Replies Latest reply: Sep 17, 2013 3:03 PM by lstung RSS
  • dollum Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 8, 2012 7:01 PM (in response to starrn1)

    Please help.  I beg of you!  In short I have:

     

    - turned WiFi syncing off

    - toggled the correct sync boxes over and over and over again

    - custom ringtones are under 38 seconds

    - the Artist information is filled in

    - removed everything to an external Library, resynced then rebooted everything.  Imported back and attempted to restock.  Three times.

     

    Only some tones transfer (custom and purchased) but I can't figure out why some do and others don't except that the ones that do are from my first set up while later add-ins don't.

     

    There isn't some kind of maximum, is there?  And no, I have barely anything loaded onto the device.

     

    Been at it for days and am sooooooooo frustrated.  What have I missed doing?

     

    Just when I think I have a handle on this whole iTunes business, something craps out.

     

    PS:  when syncing, it says the tone is transferring but I can't see it in the list and it's not in the Music folder either.

  • dollum Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 8, 2012 7:56 PM (in response to dollum)

    Sorry.  Tried to delete that post because I realized it was the NOTIFICATION sounds I was wanting to update. 

     

    In case this is something that interests you, while ringtones can't be more than 40 seconds, notification sounds can't be more than 30.

     

    So it's all good ... for now.

  • sharradog Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 8, 2012 8:57 PM (in response to starrn1)

    The sync on/off trick didn't work for me.  Neither did the trick to upload a new ringtone.
    When I went into "ringtones' into my itunes account (NOT the iphone ringtones screen) I had the exclamation marks.  The computer couldn't find the ring tone.  I went to the app I used to create the ring tone, it was still there, downloaded it again although instead of clicking the "download" link, I dragged the attached file directly into my file on my computer under "music", then "itunes" then ringtones. 
    I think if I click on the "download" button the ringtone somehow goes into itunes but not stored in the "ringtones" folder on the computer. 
    Hopefully it makes more sense than it sounds. 
    So this is what I did

    1.  itunes - click on your iphone logo, then on ringtones and uncheck ringtones, sync then recheck ringtones

    2. a variety of above with turning phone off/on (always works for me but not this time!)

    3.  Reading above thread

    4. Went into itunes library -not iphone icon - but instead of choosing "music" on left hand list chose "tones".  (list goes - music, movies, tv shows....apps, TONES)

    5. Under ringtones in library my ringtones were there but had exclamation marks indicating the file was not found

    6.  Couldn't find the file under a search of the computer

    7.  Went to app where I originally made the ring tone (of my son telling me I love you - hard one to lose) and re-sent it to my email.

    8.  Instead of clicking the "Download" button in the email I dragged the file into my folder under "Music" then "itunes" then "ringtones" (as you would for any other document like say a word document you were moving)

     

    Hope this helps someone!

  • nathir Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 10, 2012 2:16 AM (in response to starrn1)

    Ok guys i had the same problem for about a year now and i tried all the actions proposed in forums from time to time with no luck. Today, accidentally i must say, i found the solution and i think it will help all those whose the ringtones (under the iPhone at "Devices") are showing up in gray (as "synchro" stated).

     

    So follow the steps:

    First delete your gray ringtones and sync.

    In iTunes select Edit > Preferences

    In the box that comes up under "General", check the "Tones" box and press OK.

    Now in the upper left corner of iTunes under "Library" you will be able to see a "Tones" tab like the one you see under the iPhone at "Devices".

    Drag and drop your ringtones in "Library" box. If you select the "Tones" tab you will be able to see the ringtones.

    Finaly drag and drop the ringtones from the "Library" to iPhone under "Devices".

    Now if you select the "Tones" tab in iPhone you will hopefully be able to see your beloved ringtones in black font again. Sync and ring happily ever after.

     

    Hope this works for everyone.

  • Rootesy Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 10, 2012 5:02 PM (in response to nathir)

    Yep! I done exactly what nathir did and it WORKED!

    I tried dragging ringtone files directly from my folder on my iMac to my iPhone 4S within iTunes but they did not show up on my iPhone, they just showed up in "grey" in my "Tones" folder under my iPhone in iTunes. It just would not sync up!

    Then I just deleted those grey ringtones and then I found the ringtones were in my "Library" under "Tones" within iTunes. I just dragged the ringtones from there to my iPhone and then it updated my iPhone and ALL IS GREAT... finally

     

    Just follow what nathir says above! CHEERS!

  • MrD800 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 11, 2012 11:03 AM (in response to starrn1)

    Whenever I update my iPhone 4S, I lose my custom ringtones. No worries - I just use iToner to resync my saved ringtones on my MBP.

     

    Too bad Apple still has not fixed this problem up to iTunes 10.6. Hope everyone having this problem can use this solution.

  • jlsdunn Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 12, 2012 6:33 AM (in response to AbbyWhiz)

    I HOPE someone can help me. This is so fustrating.

     

    I have the iphone 4s. I have itunes. My itunes are on my phone. I created a ringtone in itunes on my computer for one of the songs I had purchased. That worked great. The ringtone shows up in itunes on the left sidebar under 'tones'. Right there it is.

     

    I have synced my iphone with itunes. I have synced it 6 times. The ringtone is not showing up on my phone. I go to settings, sound, ringtones...and all that is there is the default list. My ringtone that I created and that shows up in itunes under the tones tab is not on my phone. Why? I thought when I synced my phone with itunes, it would show up.

     

    PLEASE for the love of God...someone help me.

  • MrD800 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 12, 2012 6:55 AM (in response to jlsdunn)

    jls,

     

    See my post just above yours. I use iToner to sync my ringtones (saved on my MBP) with my iPhone 4S. Unfortunately, the latest version of iToner, 2.0.7, is not entirely compatible with iOS 10.7.

     

    Whenever I sync my iPhone 4S with my MBP (say due to an update in my cal, contacts or notes), I follow it up with another sync (for the ringtones) using iToner. I find that this is the easiest solution when it comes to sync'ing ringtones between the MBP and the iPhone 4S.

     

    Hope this helps.

  • jlsdunn Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 12, 2012 8:32 AM (in response to MrD800)

    Thank you...I finally got it to work. I appreciate your help1

  • Tammy64 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 13, 2012 7:51 PM (in response to starrn1)

    OMG! Just upgraded last night and after trying all of these fixes found one that worked. Go to devices in left hand column and select your device(mine was Tammy and was the first one listed under devices). Click on it and then at the top of the screen under the "apple" is a toolbar menu that says summary,info,apps, tones..select tones. You will then see "sync tones" with the option "all tones" or "selected tones"...click selected tones and then underneath that will list all of your tones. Click all that you want and then at the lowe left of the screen will say "apply" click that and it will reload your tones. IT WORKED! I went to the verizon store today and they did not even have a fix. It has been driving me crazy to fix. Hope this helps yall!

  • Tammy64 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 13, 2012 7:57 PM (in response to SandraNewJersey)

    This worked for me. I have the 4.0 and just upgraded last night and after trying all the others..this worked. THANK YOU!!!!

  • Keith Bierman Level 1 Level 1 (15 points)
    Currently Being Moderated
    Mar 19, 2012 1:33 AM (in response to Tammy64)

    Humm, having read this (and several other) threads I remain confused. My custom tones show up under the iPhone device, but greyed out (no exclaimation marks). I can play them from the "Tones" section of the Library pane. I have "unsynched" and "resynched", with and without the "Sync Tones" pane. I do have sync over wifi and music match on ... is that what is killing me? I've disabled sync over wifi that just leaves music match ...

     

    Any other clues?

  • Mystic method Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 20, 2012 6:57 AM (in response to Keith Bierman)

    Of course, that is how Apple rolls…welcome to the iTunes labyrinth.

     

    (Keep the ******** 'sync' options off. Use the 'manually manage music and videos' option in the summary page when you click on your device in iTunes)


    As you know when you connect your idevice to your pc, 2 libraries are shown – the iTunes library and the idevice library.

    You need to have the ringtone ready in your iTunes Ringtone / Tones library. Just drag and drop it below in to your idevice ringtone/ tones library.

    If your .m4r ringtone is 40s or less ( 40s for ringtones, 30s for alerts) and it is in proper AAC audio, you should briefly see an “updating” status bar right on the very top of iTunes (similar to when you transfer songs). Check your iphone > settings > ringtones.

     

    For those still confused (seriously there are so many and seriously not patronizing, just explicitly imparting what worked for me):

     

    1. I need 30s of that guitar riff from “All Along the Watchtower” as a ringtone otherwise I’m never answering my phone again.
    2. I use the ‘Wavepad Sound Editor’ to cut out that part of the song. So now I have a small mp3 clip called ‘All Along the Watchtower Riff only.mp3’
    3. Open iTunes. Drag that mp3 into the Music folder of the iTunes library
    4. In iTunes, right click on the mp3 clip > Get info > Options > Make sure the clip is exactly 30 secs not more (otherwise iTunes will inform you it is too long)
    5. You will now see 2 versions of that clip > Right click the 0.30s version of the same song under the original > create AAC version (This converts that file into AAC audio)
    6. Now open the iTunes folder on your pc. By default its in ‘My Documents\My Music\ iTunes\iTunes Media\Music’    OR you go do the next smartest thing
    7. Right click on the 0.30s clip and click ‘Show in Windows Explorer or browser’
    8. In this folder you will see the .m4u that has been created. In my case, “All Along the Watchtower Riff only.m4u’.
    9. Rename. Make the name shorter and rename the end .m4r (“Watchtower.m4r”)
    10. Now, you could flip a coin for either 11 or 12
    11. Back to the iTunes library > open the Ringtone tab. Drag n drop it in there.
    12. On your pc, you could cut/copy it from the iTunes Music folder and paste it into the Ringtone folder. Then use the 'add file to library' option in iTunes)
    13. Connect iphone > the iphone library should show up
    14. Drag n drop ‘Watchtower.m4r’ from iTunes ringtone library to idevice ringtone library    (OR right click on ringtone in the iTunes tones library > copy > open the idevice ringtone tab > control & v
    15. If you suddenly sense a deep profoundness creep in to the soul, hear a baby giggle somewhere off in the distance, feel the sun grin and massage the back of your neck and see a souffle of long lost clouds rush in to give you shade… …that’s because the ringtone is now in your idevice
    16. If not, it’s just another regular effin day

     

    Currently listening to Nina Simone – Please LORD, Don’t Let Me Be Misunderstood


  • Keith Bierman Level 1 Level 1 (15 points)
    Currently Being Moderated
    Mar 20, 2012 7:36 AM (in response to Mystic method)

    Well, I don't run Windows (except when Corporate Overlords require it), but your instructions seem sound. However, the issue proved to be "solved" by manually changing all the tag info in the Library Tone version (as per someone's suggestion in another thread).

     

    I appreciate the clean design, but useful diagnostics would be a godsend sometimes.

  • GreatScots13 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 25, 2012 9:29 PM (in response to starrn1)

    After reading all of the suggestions I couldn't find one that solved the problem for me. Contacting customer support didn't help either. I was able to listen to the ringtones and alert tones directly in the iTunes library but not all of them would sync to my iPhone 4S. After checking, unchecking, and syncing repeatedly nothing worked. One of the alert tones wouldn't even delete from my phone. When I plugged the phone in to iTunes and went to the "Tones" option under devices I found some of them were on there more than once with exclamation marks next to them and the others were stuck in syncing limbo and grayed out. Eventually I found the fix.

     

    1. Once iTunes is open and the iPhone (or iPad2 as I was having the same problem with both) are detected go to the device "Summary" tab and check "Manually manage music and videos"

    2. Click on the "Tones" option under that specific device in the left side toolbar

    3. Delete the ringtones/alert tones that aren't syncing (these will either be grayed out and stuck in syncing limbo or have the exclamation marks next to them). Each time you delete one the status bar at the top of the iTunes screen will say "Updating"

    4. Go back to the device "Summary" tab and uncheck "Manually manage music and videos" (I let mine default to "Sync only checked songs and videos")

    5. Go to the "Tones" tab across the top of the screen (to the right of the "Summary" tab)

    6. Check "Selected tones" and make sure everything you want synced is checked then check "All tones" and sync your device

     

    This worked for by my iPhone 4S and iPad2. Hope this works for you.

1 ... 6 7 8 9 10 ... 12 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (4)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.