4 Replies Latest reply: Oct 15, 2011 10:05 PM by SotongLuv
Skyphax Level 1 Level 1

So my friend Mitch just got iOS 5 and sent me an iMessage for the first time. He sent if from his iPhone, yet came through on my phone from his email address, not his phone number like normal. I now have two conversations for him in my messages - one is iMessages and the other is text. Why are try not appearing in the same conversation? Both his number and email are under the same contact in my contacts.


It's highly annoying as on his end, I appear as one conversation - both texts from before and now iMessages. Why isn't te same thing happening on my end?

iPhone 4, iOS 5
  • Oliver Jobson Level 1 Level 1

    Do you have any duplication in your address book? Is your friends email address and phone number stored in the same contact? I imagine this would be worth checking. If this doesn't help, delete the sms and imessage conversation streams and start a new one by sending him a message... it should just work.

  • sy278 Level 1 Level 1

    This is happening with my wifes conversation with me, i get seperated messages from her, mine are collated properly on hers. I have found the issue is that on hers her phone number is missing from


    Settings >> Messages >> Recieve at



    On mine in that position my phone number is there and is greyed out as is all my colleagues. My wifes however the phone number is missing and it doesn't allow you to add it, so is using her email address for iMessage.


    So i message her and it sends as SMS but when she replies it comes as iMessage.

  • linderoth_ Level 1 Level 1

    First see in https://appleid.apple.com if her apple ID is linked with her iPhone phone number, if not, modify and save changes, then in her iPhone go to settings -> messages -> and deactivate iMessage and activate it again (the phone number should appear in "Receive At" greyed out). Do the same in settings -> FaceTime. After that reboot your iPhone. Hope that works, it worked for me

  • SotongLuv Level 1 Level 1

    hi guys , try logging off your Apple id followed by Offing iMessenge. Than ON your iMessage again and relog in =)