Previous 1 2 3 Next 70 Replies Latest reply: Apr 28, 2015 9:38 AM by aimeecherie
Ge0ph Level 2 Level 2

When I set Pages in my iPad 2 to use iCloud and then I open Pages none of my documents are there. After opening Pages I go back into the Pages settings and iCloud is turned off. If I turn it back on, as soon as I open Pages it turnes back off again. It will not stay on and Pages will not sync documents with iCloud.


Numbers works fine on my iPad and Pages works fine on my iPhone, just not on my iPad.


I have removed Pages and re-installed but that didn't work.

Mac Mini, Mac OS X (10.6.4)
Solved by michaelgt10 on Oct 22, 2014 12:24 PM Solved

Hey I found out that iCloud Drive was turned off in the iCloud setting on my iPad.  Switched it on and then turned on 'Use iCloud' in Keynote, Pages and Numbers.  Providing that you are running IOS 8.  Everything started syncing.

Reply by Ge0ph on Oct 13, 2011 4:34 PM Helpful

After restoring my iPad and setting it up as a new device Pages is now syncing with iCloud. I wish there were another way but this worked...for me.

All replies

  • danmoo Level 1 Level 1

    I am experiencing exactly the same behavior on my iPad (in all three iWork apps). On my iPhone syncing works just fine with all three apps. Of course I did nothing different there than on my iPad.


    Just as with Ge0ph, reinstalling the apps did not help and the iCloud Sync option only remains activated until the app in question is launched. Of course Documents & Data syncing is active in the iCloud settings.



  • Ge0ph Level 2 Level 2

    When I get home from work today I'm going to try to factory restore my iPad and start from the begining. I'll let you know how that works out.

  • Ge0ph Level 2 Level 2

    After restoring my iPad and setting it up as a new device Pages is now syncing with iCloud. I wish there were another way but this worked...for me.

  • danmoo Level 1 Level 1

    Yeah, I can confirm this: a full restore to factory settings and setting everything up as a new device does the trick. Now documents are syncing to all iWork apps on my iPad.


    Thanks a lot for coming up with the idea! Though not the most pleasant solution, it works

  • marcozima Level 1 Level 1

    Is factory settings the only way to fix it? I would really avoid that...

  • Burma Sauce Level 1 Level 1

    Thanks for testing this out - I think I'm going to wait for a fix from Apple as it would be too painful to set mine up from scratch again.


    By the way, I presume if you do a factory reset you get to pick your iCloud account again? If so it is an (admittedly awkward) workaround for the 90 day iCloud account lock.

  • Hassaan Level 1 Level 1

    To solve the Documents sync issues with iCloud (my discovery):

    1) copy all documents from Numbers, Pages and Keynotes to iDisk.

    2) turn off iCloud on your devices. Be warned it will stupidly delete all your documents on the device and iCloud!! So you must do step 1 above.

    3) deactivate iCloud on all devices.

    4) copy the documents back on one device from iDisk.

    5) now all documents will show up on all devices.

    6) problem solved.

  • MDC Level 1 Level 1

    I also had this same problem on my iPad 2, but then I decided to remove the other MobileMe account that I had converted to iCloud.  This was a separate account from my main MobileMe account, which was the first account that I converted to iCloud.  I was able to add the secondary account, and the iPad 2 told me that it could not be used as a primary iCloud account (because I already had one setup) but could still be used for Mail, Contacts, and Calendars.  I only wanted to use it with Mail, so that's how I setup it up.  But, I noticed that it also showed Documents and Data in the Mail, Contacts, and Calendars settings, under Accounts.  However, when I clicked on the account for more detail, Documents and Data was not listed.  So, at the time, I didn't think much of it.  But, then when I started using Numbers and Pages and noticed the problems syncing, I decided to remove the secondary account and re-add it.  Once I removed it, the documents immediately appeared in Numbers and Pages.  I then added the seconard account back, and it successfully added (this time only reflecting Mail as the service used).  So, I thought I'd share.  I'm chalking this all up to some kinks in a fairly new system.  I expect things will get better as Apple works through them.

  • michaelfromAL Level 1 Level 1

    I noticed the same thing with my iPhone. I had a secondary account that was only used to check e-mail, but I also noticed it showed "Documents and Data" on that account, even though the option was not visible in the account setup screen.


    It seems as though the primary and secondary accounts were conflicting. Every time I enabled iCloud for Pages, Keynote, or Numbers it would become disabled after opening the apps.


    MDC's method has also fixed this problem for me. I can now see the documents in my iCloud account.

  • michaelfromAL Level 1 Level 1

    I forgot to mention that both of my accounts were migrated from MobileMe to iCloud.

  • marcozima Level 1 Level 1

    I did it in another similar way wich made it work as well:

    1) backup all documents from Numbers, Pages and Keynotes to your Mac and then upload them to

    2) remove all your iWork apps

    3) restart ipad

    4) reinstall back your iWork apps from iTunes

    5) start them up and activate iCloud and you will see the documents downloading back to your iPad!

  • Burma Sauce Level 1 Level 1

    Thanks! This worked for me. I deleted my secondary iCloud account from Mail, Contacts and Calendars and it successfully synced my Numbers documents between devices.

  • meeaspapa Level 1 Level 1

    Same issue here pages and numbers will not move to or from I am having similar issues with photo stream..its works fine beetween my iOS devices but will not place photos in photo stream on my Mac.


    I think it has something to do with the apple id's.

  • eds72 Level 1 Level 1

    My Pages documents on my iPad would not upload to iCloud, even by re-installing the Pages App.


    SOLUTION: On iPad, save the files to iTunes, and then from iTunes save them to iMac desktop. Then confirm the files on iMac desktop are good by opening them in Pages, then upload those files to iCloud via Then backup iPad to iMac in iTunes. Then on iPad, in Settings, completely restore iPad to factory settings. Then connect iPad to iMac and restore from the backup. Pages on iPad should now sync with iCloud files.


    Hope that helps - worked for me anyway.

Previous 1 2 3 Next