1 2 3 4 5 Previous Next 67 Replies Latest reply: Jan 11, 2014 7:11 AM by Panteliz Go to original post
  • 15. Re: Pages and iCloud will not sync.
    pvdongen Level 1 Level 1 (0 points)

    After hours of trying everything because having the same problem, I read your solution and it worked for me. Thank you very much for sharing your knowledge to this forum.

     

    Peter van Dongen, The Netherlands.

  • 16. Re: Pages and iCloud will not sync.
    mikeru Level 1 Level 1 (0 points)

    I've just found a very easy solution for the iPad! :)

     

    1- Erase the iCloud account and re-enter it

    2- Open Pages: u'll see no docs. No problem. close pages completely.

    3- go to options-icloud, and desactivate the documents

    4- open Pages and select Use iCloud. Docs are back :)

     

    so just trying to play with switching on and off stuff, dont need to restore. Be sure you always close completely the programs, using the button doble click not to leave them in memory.

  • 17. Re: Pages and iCloud will not sync.
    ozwheels Level 1 Level 1 (0 points)

    I tried several solutions unsuccessfully...

     

    • Switch Off/On Documents & Data setting
    • Quit all Applications, then Powered Off/On iPad
    • Switched off iMac Documents & Data setting
    • Deleted iCloud Account on iPad
    • Setup iCloud Account on iPad again

     

    ...however, what actually worked...

     

    • Backup any iOS iWork documents to your computer or send emails
    • Delete all iOS iWork apps on iPad
    • Sync with iTunes and add iOS iWork apps back onto iPad
    • Launch each iOS iWork app on the iPad and at the welcome say "Yes" to use iCloud
    • iCloud documents start to sync/download immediately

     

    ...just be careful in backing up any iPad document because I sent mine to iTunes, but they didn't get there. My documents weren't important, but It may be better to email.

     

    This solution also saved me doing a full restore on the iPad

  • 18. Re: Pages and iCloud will not sync.
    Dtb Level 1 Level 1 (10 points)

    Spot on! Thank you but shouldn't Apple be letting people know this??

  • 19. Re: Pages and iCloud will not sync.
    ryanfrommercersburg Level 1 Level 1 (0 points)

    Deleted account that had been moved from MobileMe. All iWork apps then prompted me to use iCloud when I opened them.

     

    Problem solved.

  • 20. Re: Pages and iCloud will not sync.
    davper Level 1 Level 1 (0 points)

    Thanks that also worked for me.  Though one wonders why it's necessary to do all this.  What happenned to "it just works"?

  • 21. Re: Pages and iCloud will not sync.
    NJB2308 Level 1 Level 1 (0 points)

    I had the same problem with Pages, Numbers & Keynote not getting docs from iCloud or syncing test documents up to it after upgrading from a 3GS with iOS 5 to an iPhone 4S. Everything else was workong for me - Photostream, Calenders and email. What solved the problem for me, after reading the suggestions on this thread, was the following:

    1 Turn off document support in Settings/iCloud

    2 In Settings, turn off iCloud use in Pages, Numbers & Keynote.

    3 Open Pages, Numbers & Keynote, then for each one close it from the multitasking line.

    4 Enable Documents support in Setting/iCloud, and enable iCloud use in all three apps from Settings.

    5 Open each app in turn, and they began downloading from iCloud.

     

    Thanks to all who gave their experiences.

  • 22. Re: Pages and iCloud will not sync.
    philfromtwickenham Level 1 Level 1 (0 points)

    Hey, thanks so much for this - this problem has been driving me crazy! The weird thing is, i have never used mobile me or any of these services before, but I still had a duplicate account set up under mail.  Took a deep breath, deleted it, now everything works perfectly.

  • 23. Re: Pages and iCloud will not sync.
    Enzoe Hm Level 1 Level 1 (0 points)

    This easy solution will make your iDevices succesfully sync with iCloud

  • 24. Re: Pages and iCloud will not sync.
    bobbyv3333 Level 1 Level 1 (0 points)

    After spenings a few hours with Apple support on the phone we discovered (it was a surprise to a level 3 technician) that the problems with this and all other icould syncing issues was with the wireless router I was using. There is something with the security settings that was preventing the sync updates. It seems to be that when the ipad and/or the iPhone (both in my case) loses some contact with the cloud, it erases (or at least hides) the data that was supposed to be syncing. So at home, where I had all apple devices (time capsule router), I would get everything synced perfectly, but when I walked into my office everything, contacts, events and iWork documents would just dissapear before my eyes.

     

    After changing the WPA settings in the router, everything works fine and syncs perfectly.

  • 25. Re: Pages and iCloud will not sync.
    FirstAngle Level 1 Level 1 (30 points)

    Excellent, this solved my problem!

  • 26. Re: Pages and iCloud will not sync.
    JBCollinet Level 1 Level 1 (0 points)

    Some ISPs just don't support the constant syncing that is required for iCloud to work flawlessly.

     

    Contact your ISP and ask about iCloud. Explain your issue.

    Apple cannot fix your ISPs issues and vice-versa .

  • 27. Re: Pages and iCloud will not sync.
    nyrangers25 Level 1 Level 1 (0 points)

    i have had the same issue and sat on the phone with Apple support for 2 hours before i figured out a quick solution on my own.

    Back up your data onto i disk or your computer or something jsut in case you lose your stuff.

    Go to settings an scroll down the side bar until you see icloud and turn documents and data OFF.

    the go further down until you see Pages and turn icloud ON.

     

    i dont know why but all of my stuff started loading onto my iPad again once i did this.

     

    its a quick fix that does not require factory resets and things. i'm thinking its a glitch in the 5.0.1 update.

     

    hope this helps!

    Stephanie

  • 28. Re: Pages and iCloud will not sync.
    JBCollinet Level 1 Level 1 (0 points)

    Hey Stephanie,

     

    Same happened with 5.0 so 5.0.1 is not more glitchy...

     

    Switching on/off, toggling on/off... Just browse the community forums and you'll know it has been done over and over.

    I'm glad it worked for you! It worked for me with 5.0 …

     

    I mailed Scott Forstall (Senior VP of iOS development) about this. Chances of reply are very low, but I'll keep plugging!

     

    /JB

  • 29. Re: Pages and iCloud will not sync.
    Geekseeker Level 1 Level 1 (10 points)

    Well ... everyone one seems to have the same issue here, but there are multiple solutions! ... or not!  

     

    Here is my experience:  I noticed that my "me" mail account (within settings) showed "documents and storage" as well as mail being supported even though within this account only mail was selected.

     

    So I deleted the "me" account, turned the iCloud setting for Numbers, Pages and Keynotes back on and opened each of them. Yup ... each then sync'd to iCloud without a problem.

     

    Afterwards, I reinstalled the "me" mail account, and it behaved just as it should.

     

    So when all else fails, here is one more "solution."