Skip navigation

Yahoo mail not working with iOS 5

4196 Views 11 Replies Latest reply: Aug 14, 2012 6:49 PM by BR guy RSS
MikVG Calculating status...
Currently Being Moderated
Oct 13, 2011 7:59 AM

I just updated my iPhone 4 with iOS 5. When I go to the mail app, I only emails from August 30 and older. Though there are newer emails on my account they are not displaying. They are not displaying on my Touch or my IPad 2 either. It worked fine prior to the update. Any ideas on how to fix this or what might be the problem?

iPhone 4, iOS 5, iPhone 4, 32gb
  • mark-knoxville Calculating status...
    Currently Being Moderated
    Oct 13, 2011 7:11 PM (in response to MikVG)

    in your settings, check you wifi network. make sure your password is still there. when i upgraded to ios5, it removed my password so that i could not connect with the yahoo mail server

  • San Fran Dave Calculating status...
    Currently Being Moderated
    Oct 14, 2011 7:46 AM (in response to MikVG)

    I fixed Yahoo Mail on my 3GS with iOS 5:  In Settings, "Mail, Contacts, Calendars", I reduced "Show" to "50 Recent Messages"

     

    It had been set to "200 Recent Messages"

     

    I also have an Exchange and MobileMe account setup on the phone.

     

    I guess that there is not enough memory or something with iOS 5 on some devices to hold 200 Recent Messages from multiple accounts.

     

    Hope this helps!

  • OldNEgirl Calculating status...
    Currently Being Moderated
    Oct 14, 2011 9:03 AM (in response to MikVG)

    I had the same issue on my ipad2 after the ios5 download and used safari to access yahoo mail. I noticed a new yahoo mail display mode I hadn't seen before http://mobile.yahoo.com/ipad#mail. I noticed there were two folders below the standard folders that contained emails from contacts and emails with attachments. I think these emails are being put in these folders by yahoo before they can be pushed to the ipad.  On the bottom left corner of the screen your name/account appears and when you click on your name, a settings menu appears.  It gives you the option to switch to yahoo classic view.  After I reverted to yahoo classic view, I receiving emails.  I think it's working OK now.  I'll have to keep my fingers crossed.

  • ronfromtallahassee Calculating status...
    Currently Being Moderated
    Oct 16, 2011 10:18 AM (in response to MikVG)

    I cannot get my emails from yahoo either. I sent an email from yahoo to gmail and gmail to yahoo. I did get the one in my gmail but not the yahoo. Does anyone know how to really fix this or is there and update that fixes it? I know there are email because I logged in thru safari and there are new emails. I have tried deleted my account and redoing it, checked password, tried everything!

  • brf7 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 16, 2011 7:02 PM (in response to MikVG)

    I fixed the problem on my iPhone 4 by following the steps someone else suggested on this forum and it worked for me:

     

    1. Log onto Yahoo mail using a computer web browser
    2. Starting with the oldest message in your inbox load each message individually.
    3. If you come to an email message that Yahoo mail gives the following error message "There was a problem viewing this email message", delete it. Moving the message to another folder may solve the problem as well, but I did not try it.

     

    Thats it!

  • nusch ray Calculating status...
    Currently Being Moderated
    Oct 17, 2011 2:36 AM (in response to ronfromtallahassee)

    same problem here, no yahoo mail newer than september 22 in my inbox. some other folders do show newer mail, and some do not. someone had suggested deleting unreadable mail via a browser; i moved it to another folder, but that apparently did not help so far, or i may not have moved all unreadable mail yet. when i look into the folder with the unreadable mail, it shows up there until i clck on it, then it vanishes. the problem definitely is related to these unreadable mails.

  • AngelGirl74 Calculating status...
    Currently Being Moderated
    Oct 17, 2011 4:19 PM (in response to MikVG)

    I have been having the same issue with only one of the yahoo accounts.  One of them is working just fine as well as my google account.  I read other suggestions and created a new folder in yahoo called Inbox Old.  I moved all my emails in the current inbox into this new folder.  I did this all on the computer.  As soon as I did that, the new message I had just sent myself pushed immediately to my iphone.  On the phone, I went into the new folder and was able to load all the message and see all of them.

     

    I hope this helps someone.  It is only a quick fix though as I am unable to see some of my messages in my other folders that I know are there.  But until they fix it permanently, you will be able to get new emails pushed to your phone.

     

    Good luck!!!

  • Morac Level 1 Level 1 (70 points)
    Currently Being Moderated
    Oct 17, 2011 4:37 PM (in response to MikVG)

    I've noticed a few problems with Yahoo after upgrading to iOS 5. 

     

    Problem #1:

     

    First after upgrading to iOS 5 on my 3GS, I noticed it was grabbing emails while my iPad 2 (also upgraded to iOS 5) was.  I looked under "Mail, Contacs, Calendar" settings under the "Fetch New Data" -> Advanced screen and saw that Yahoo was set to "Fetch" and there was no way to change it to "Push".  The only options were "Manual" and "Fetch".  I tried to delete my Yahoo account off the phone, but it kept coming back.  Since I had added an iCloud account, I changed all the defaults (calendar, mail, etc) to use the iCloud account.  After that I could delete my Yahoo account off my phone.  Once I re-added it, it was set to "Push" and was working and emails downloaded.

     

    I had the same exact problem after restoring my new iPhone 4S with the backup data of the 3GS, so it appears the backup data wasn't exactly good.  I fixed it the same way (though I needed to delete the Yahoo account a few times for it to take).

     

     

    Problem #2:

     

    I think iOS 5 was (is?) corrupting emails on Yahoo's web servers so they can't be read on the Yahoo Mail page.  After upgrading to iOS 5, I noticed a number of emails that I moved from my Inbox to other folders on my phone could not be opened on the mail.yahoo.com page (classic, new or mobile).  They could be opened via the phone's mail app and other IMAP programs, but not via the web site.   This is affecting all email I moved from October 12th through October 15th.  I moved one today and it can still be read via the web site, so maybe it's something on Yahoo's end.  Or maybe Yahoo isn't compatible with the new "marking" feature in iOS 5 (even though it seems to work).

     

    I have an open support ticket to fix the broken emails.

  • ryamamoto Calculating status...
    Currently Being Moderated
    Oct 27, 2011 9:30 AM (in response to MikVG)

    I been having the same problem and used all of the fixes mentioned on this post.  The problem is that it seems to synch intermittently.  However, I noticed this morning that it 1) either updates overnight through the yahoo server, or 2) seems to work after I logoff yahoo mail through my desktop which may either force the update or release some connection.  Hope this helps.

  • BR guy Calculating status...
    Currently Being Moderated
    Aug 14, 2012 6:49 PM (in response to ryamamoto)

    I am having the same issue with both my ipad and with the iMac since updating my ipad 3 to ios 5; the iMac was already ios 5. Is only with Yahoo; hotmail works fine.  

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.