5 Replies Latest reply: Oct 15, 2011 6:17 AM by Texas Mac Man
shnicky83 Level 1 Level 1 (0 points)

Hi,

I have been into the apple store today but didn't get very far...

I have an iBook g4 with leopard 10.5.8 installed, iTunes has been upgraded to 10.5 (the newest one from yesterday) without any problems. When I connect either my iPhone 3GS or my iPad 2 it shows that iOS 5 is available and downloads it. When I try to install it gives me a "not eligible for update" error. When I spoke to two different employees at the apple store they both said that as iTunes 10.5 is compatible with leopard 10.5.8 that installing iOS 5 shouldn't be a problem. I have tried and tried again, still no joy. Any ideas? Thanks for the help


iBook, Mac OS X (10.5.8), iPhone 3GS and iPad 2
  • BDAqua Level 10 Level 10 (119,740 points)

    The requirements seem confusing...

    System Requirements

    • Apple ID (required for some features)
    • Internet access6
    • Syncing with iTunes on a Mac or PC requires:
      • Mac: OS X v10.5.8 or later
      • PC: Windows 7; Windows Vista; or Windows XP Home or Professional with Service Pack 3 or later
      • iTunes 10.5 or later (free download fromwww.itunes.com/download)

    http://www.apple.com/iphone/specs.html

     

    iCloud requirements...

     

    System requirements

    iPhone, iPad, iPod touch

    • iOS 5

    Mac

    • OS X Lion 10.7.2
    • iTunes 10.5
    • iPhoto’11 (version 9.2) or Aperture 3.2 (for Photo Stream)

     

    http://support.apple.com/kb/HT4759

  • shnicky83 Level 1 Level 1 (0 points)

    Thanks for your reply. I bought my ipad2 so I didn't have to buy a new laptop at the moment. My only alternative is to update my ipad2 and iPhone on my friends iMac but my concern is that it won't then sync back to my iBook, I'm not concerned about wireless syncing at present but to have a two week only iPad already out of date seems a little unfair. The guys at the apple store reckon it should still sync back to my iBook but looking on the net from other users I'm a little concerned. Is anyone else having similar issues?

  • Nikhil Raj Level 2 Level 2 (225 points)

    Any luck?

     

    I'm in the same situation -- OSX 10.5.8 and want to upgrade to iOS5. 

     

    Has anyone else tried this?  Will I lose all sync capabilities? Wired too?

  • BDAqua Level 10 Level 10 (119,740 points)

    You won't be able to sync according to my tests, but you will be able to view certain thinks in the iCloud in 10.5.8

  • Texas Mac Man Level 8 Level 8 (46,540 points)

    I upated iTunes to 10.5 & then upgraded to iOS 5 on my iPad2. When it was supposedly done, I got an error message that I need to Restore the iPad. Clicked on Restore & after a while got repeated error messages (errors 1611 & 2006). Tried numerous times. Looked at Apple's suggestions & tried one - to Restart my Mac. This time it worked & everything works. Have also interfaced to iCloud.

     

    So try Restarting your Mac. If that doesn't work, reinstall iTunes 10.5.

     

     Cheers, Tom