Skip navigation

iMessage not working on iPad

274088 Views 200 Replies Latest reply: Mar 27, 2014 5:08 AM by Päl Allofson RSS
  • Avill Calculating status...
    Currently Being Moderated
    Oct 15, 2011 3:39 PM (in response to computerman0219)

    Ok add this to the list. When I creat a new iMessage on my phone and select my @me.com email address and send it I receive the iMessage on both my iphone4 and ipad1. If, however, I delete that message and make a new one, this time selecting my phone number instead of the email address, it goes only to the phone. So for some reason it seems if you don't select the email address as the original send point it doesn't work. Replies do, however (using the email method). And yes, the number and email address are listed under the same (and only) contact. Very weird.

  • Neddy123 Calculating status...
    Currently Being Moderated
    Oct 15, 2011 8:23 PM (in response to Taddd)

    @taddd Google's public DNS illegal??? Why? Before trying to inform people, please be informed yourself... Anyway, setting Google's DNS servers fixed the iMessage issues I was having, not sure why it works. It the same fix used to fix signin issues with FaceTime.

  • Michael Daninhirsch Level 1 Level 1 (25 points)
    Currently Being Moderated
    Oct 15, 2011 9:07 PM (in response to tdbell)

    RE: pretty sure you can only send to an email address from iPad.. see if that works...

     

    Not true. You can select a cell number or an email to send a message to someone from an iPad.

  • ujjwalfromnew delhi Calculating status...
    Currently Being Moderated
    Oct 15, 2011 10:14 PM (in response to Taddd)

    Hi!

     

    8.8.8.8 is the Google DNS Server address. Dont thinks its illegal to change your DNS address to that.

     

    Uj

  • ujjwalfromnew delhi Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 15, 2011 10:15 PM (in response to Neddy123)

    @Neddy123 - yeah its the same fix for the FaceTime issue. I've been trying to figure out why iMessages wasnt working on the iPad and remembered this fix and just decided to try it....and it worked!! Whatever works!!

     

    All the best!

  • mheatley Calculating status...
    Currently Being Moderated
    Oct 16, 2011 12:31 AM (in response to computerman0219)

    I had the exact psame problem could not send imessage from ipad2 but could send and recieve them on my iphone. Checked all the information and emails accounts the same. I eventually used my iphone as the hotspot for the Ipad and somehow it now works.

  • roryjt Level 1 Level 1 (10 points)
    Currently Being Moderated
    Oct 16, 2011 3:16 AM (in response to willfromcairns)

    this worked for me:

    go into SETTINGS > WI-FI > (SELECT YOUR NETWORK) > CHANGE DNS TO 8.8.8.8

     

    Rory

  • ZGOZZ Calculating status...
    Currently Being Moderated
    Oct 16, 2011 5:48 AM (in response to roryjt)

    <NUMBER> is not registered with iMessage

    There are problem with this OS I am seeing this issue all over.

    Looks like apple did not test this os very well.

  • Jeff Shaw1 Level 1 Level 1 (30 points)
    Currently Being Moderated
    Oct 16, 2011 5:59 AM (in response to ujjwalfromnew delhi)

    Ok. Try this:

     

    Turn off iMessage on iPhone but leave it on with iPad 2.

     

    Now attempt to send a message on iPad to someone to whose you successfully sent one on your iPhone.

     

    If it works, then go back and turn iMessage on with iPhone.

     

    This worked for me and I was able to see the conversation on both devices.

     

    Remember, the message sent on iPad while iMessage was turned off on iPhone will be a new conversation on both devices.

     

    Some folks have also tried setting their network DNS to 8.8.8.8 and that seemed to work. Apparently, this was previously a fix for some FaceTime issue.

  • Picnicmetoo Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 16, 2011 9:49 AM (in response to TMega)

    Mine was working properly on Ipad 1 last night but friend who has 4S, 4 and Ipad is trying to get all her devices to work properly.  I am now getting from her addresses, all devices but I can't reply unless I add a photo to the message.  Ghe send button is greyed out.  Last night I tried a photo and all went well but then messaging was working well.  Today I can only create/send if I add a photo.  She can then receive and reply normally from any of her devices I believe.

     

    Try adding a photo and see if you can send. Weird behavior.

     

    Diane

  • Fitzhemingway76 Calculating status...
    Currently Being Moderated
    Oct 16, 2011 10:39 AM (in response to computerman0219)

    Concerning the 8.8.8.8 dns posts its a great quick (temporary fix until apple fixes it) it. And if you're concerned, google actually encourages you to use their dns: http://code.google.com/speed/public-dns/

  • pamfromclinton Calculating status...
    Currently Being Moderated
    Oct 16, 2011 12:01 PM (in response to computerman0219)

    I did all these suggestions on the DNS settings, re-booting ect. Nothing worked, then went in settings for the iMessages and shut off show subject box. Everything works now. Hope keeps working, nice feature!

  • Thebigbr Calculating status...
    Currently Being Moderated
    Oct 16, 2011 12:43 PM (in response to computerman0219)

    i also got this to work by confirming the right DNS of your ISP. once i changed that on the ipad, all my test messages were sent and came in...the iphone had the same settings but worked....very weird.

     

    this also fixed my find my iphone issues

  • fadi136 Calculating status...
    Currently Being Moderated
    Oct 16, 2011 2:13 PM (in response to Fitzhemingway76)

    it's great man thank you very much! the DNS suggested helped to solve it!  i was going crazy (actually it remindes the dark ages when i had a PC in my life ) it is so NOT Apple!!

  • blueboy322 Calculating status...
    Currently Being Moderated
    Oct 17, 2011 4:51 AM (in response to computerman0219)

    I dont know if this helps but i had the same problem with my IPad2 I had to turn off Send Read Receipts and Show Subject Field and then it started to work

1 2 3 4 5 ... 14 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (5)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.