Skip navigation

iCloud Contacts Will Not Sync

288949 Views 189 Replies Latest reply: Mar 12, 2014 10:12 PM by Greeneida RSS
  • Venui Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 13, 2012 10:28 AM (in response to DanielSJ)

    Thanks DanielSJ, this worked a treat and thanks for sharing

  • Arnhembeard Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 14, 2012 10:34 AM (in response to missingsc)

    Do not know if this is the solution for all of you... iCloud would not sync my contacts from the iPad to iPhone. I asked about in the store and the answer was simple. Turn off in both devices the switch in settings for iCloud fot sync Contacts. You chose of course for save contacts on this device. Then turn the switch on and choose 'combine', join, or whatever it says in your language. After that contacts will sync. You only will have to remove doubles on one device, it will sync on the other in seconds.

  • onetruearies Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 20, 2012 10:52 AM (in response to MarkyMarkSoCal)

    This would be great if www.icloud.com actually loaded and didn't just have a never ending spinning pinwheel.

  • debiHB Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 6, 2012 4:56 PM (in response to missingsc)

    In the address book in iCloud, select the little gear and import the vCard file created on your computer/phone.  Not sure if this will sync, but a quick way to upload to iCloud.

  • JerriAtric Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jun 15, 2012 12:33 AM (in response to jackmec)

    This fixed my issue -- thank you for the detailed write-up.

  • dvb Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jun 23, 2012 10:14 AM (in response to missingsc)

    i have a lot of information in the "notes" field of my address book. will vCard format save all information for each contact?

    -db

  • onetruearies Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 26, 2012 4:09 AM (in response to MarkyMarkSoCal)

    I've read this thread twice. I've upgraded to Mac OS X Lion (and it *****). And I still can't seem to get this to work. It's embarrassing because I actually am not a computer novice, but for whatever reason, I can't delete any contacts from my mac address book or my icloud account by selecting all and clicking delete. It just doesn't happen. If anyone can help me figure this out so I can move on to the next step (I've already saved my vcard file) I'd be most grateful.

  • jadag88 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 27, 2012 9:37 AM (in response to MarkyMarkSoCal)

    Thank you so much MarkyMarkSoCal! It worked perfectly.

  • jadag88 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 27, 2012 9:54 AM (in response to dvb)

    dvb--I just did this and all of my notes appear to have remained intact.

     

    onetruearies--I am also running Lion, and I just clicked on the top name in my address book on my computer, hit command-a, then hit the delete button next to the plus/equals button on my keyboard. All of my entries were deleted. When I logged on to my iCloud account, the entries were gone from there as well, so I didn't have to do anything there.

  • macheek Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 22, 2012 4:58 PM (in response to Stephen Affolter)

    Ok this fixed mine.

    • Turn off Contacts, leave contacts on iPhone  and ipad
    • On the icloud, in contacts, select all and delte all contacts 
    • Verify they are gone on iCloud website 

     

    • Turn on contacts  on ipad, then i phone
    • Everything sync'd on my iPhone and iPad fine after that. 
    • Changes on any device showed up in the others and iCloud

    So easy!!!!!

    thanks!!!!!!

  • peterdigit Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 29, 2012 4:42 AM (in response to jadag88)

    Yes, thanks MarkyMarkSoCal(see page 2 of this thread)

     

    But there is a simpler way! No need to log in and log out of accounts.

     

    1. Connect devices to Mac. In iTunes check "Sync Contacts" and synchronise.

    2. Uncheck "Sync Contacts". Synchronise again, and choose delete/erase from device.

    3. Open Contacts and Export All as vCard, then delete all contacts.

    4. Drag vCard-file back into Contacts and drop it on "All iCloud".

     

    Now everything is back and should also appear on all devices that sync with iCloud.

     

    Update: The vCard export didn't export my groups.

  • Wolfrus Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 2, 2012 12:25 PM (in response to kevincsd)

    We are having the same problem. The question is 'where is Apple support on this?'  I have actually lost many contacts. Cloud based systems are free for one reason - they get free info to sell. Nothing is for free. Apple, please provide simple fixes to you questions on syncing, etc. 

  • toadysycophant Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 10, 2012 4:05 PM (in response to Arnhembeard)

    I too noticed that contacts that were created on my laptop were showing up at icloud.com but not on my new iphone. Instead of going the export/delete route, I simply turned off icloud on the phone and then turned it back on. Presto, the missing contacts appeared. Recommend trying this first before going through more complicated steps!

  • dougbellaire Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 16, 2012 8:48 PM (in response to missingsc)

    The easy way to add a contact from my mac address book to icloud contacts is simply to open address book to the new contact and drag the contact to "ICloud - All iCloud".  Then it will show up on your iPhone and iPad.  Too easy. 

  • Jesse Barnum Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 2, 2012 6:02 AM (in response to 2twenty2)

    2twenty2's fix worked perfectly for me:

     

     

    2twenty2 wrote:

     

    I too ran into this problem and stumbled on the following which seems have it working for me.

     

    First I made sure I had set the default account to be iCloud.

     

    Then I went to Preferences > Accounts and made the iCloud account enabled and disabled the On My Mac one.

     

    Then I clicked on the red bookmark icon on the top left page of the Address Book. I selected the "All on My Mac" list and moved them from there (select and dragged) to the "All iCloud" list. I did the same for any custom groups as well. Then I deleted them from the "All on My Mac" list.

     

    Now new additions and edits to existing contacts area all showing up on my phone immediately and going into the iCloud account by default.

1 ... 7 8 9 10 11 ... 13 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (11)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.