Previous 1 9 10 11 12 13 14 Next 197 Replies Latest reply: Feb 24, 2015 10:24 AM by gillian smith1 Go to original post
  • Queueman Level 1 (0 points)

    Geoff1234, I think you have the right answer. Only the iCloud accounts sync. I have this question:

    If I have contacts I want to archive, that is keep on the Mac but not the iPhone, can I create an "on My Mac" account, with the expectation that those contacts will not sync?

  • Higgsinspace Level 1 (0 points)

    Hi All,


    I think I have a good fix for this issue.


    1. Install Cobook on you mac


    2. Set it up so that all your local contacts sync with google/gmail. You can also add in Facebook/Linkedin/Xing etc. All your local mac users and groups will be migrated to Google cloud.


    3. Once this is done, verify by logging into gmail and checking contacts. If all there..


    4. Add a CardDAV account to your iPhone/ipad by following these steps steps ontacts-to-your-iphone/


    5. Once Sync is complete you should have all of your Google contacts synced back to your idevice from the Google/Gmail cloud. This is process is like Vacuuming all of your local Mac contacts into Google, then pulling back from Google onto your iDevice.


    6. You can then either disable icloud contacts on your phone and use only Google contacts, or, keep them both running. If you use Google CardDAV contact only, this will be you new cloud storgae for all contacts and groups.


    Works like a charm


    Shame that Apple's competitor are the ones who have the best solution. Personally, I use Cobook on the Mac and have it sync to local contacts and gmail, but I only use gmail contacts on my iPhone and iPad


    Come on Apple sort this out, these are kinds of things that cause mass exodus. I used an Android for a year and hated it, this to me is the best of both worlds.

  • pmstrain Level 1 (0 points)

    I was nervous about deleting all my contacts...

    After much fiddling, I finally just turned off my contacts on my iPhone (5), kept the contacts on the phone, then turned Contacts back on (in settings...I don't know why it took me a while to see that), then the iPhone resynced with iCloud and now when I add a contact on the iMac at home it shows up across the board. 


    My rant... I'm still not 100% clear on the inter-relationship between "On My Mac" and "On iCloud" - it seems most of want to know our computer is storing all the contacts on the hard drive somewhere, so if the cloud gets totalled, we aren't losing all our contacts. doesn't seem that most of us want to specifically keep contacts off the cloud...though maybe some do, which is why there exists the two.  It seems there's a misunderstanding if "On iCloud" = shared or if "On iCloud" = stored on the iCloud server and not on your computer.  Me, personnally, I would like to know "On iCloud" means stored BOTH on your comptuer and the iCloud server and accessible to your other devices.  Is that what it means?

  • Frustrationer Level 1 (0 points)

    Thanks, this helped me. The good old unplug/switch off - plug in/switch on - thing.

    Why should Apple be immune to the oddities of technology (rhetorical question).

    Still, it's too bad Apple keeps being bad at "cloud"-services...

  • McIntire Level 1 (0 points)

    My problem was the sync between On my Mac and iCloud. Nothing worked. Nothing does. I tried almost everything explained above, and now On my Mac has disappeared completely! Even the heading! All I have is iCloud contacts in my Mac Pro. I suppose that is one solution: destroy the other option.

  • kim-in-melb Level 1 (0 points)

    Thanks - very useful tip.  Would be great if the refresh button was more easily accessible.

  • marinaccio825 Level 1 (0 points)

    I was having similar issues and thought my phone wasn't updating contacts after installing the latest iOS update but I finally realized that under contacts I have groups, the "All Contacts" group had been unchecked. Checking it fixed the problem.

  • LindaLeeMee Level 1 (10 points)

    No, that's not going to fix most problems people are having. Adding new contacts on the iMac does not add them to the iPhone.Quite frankly, turning contacts on and off just now did not fix this, either and....last time I did it, I lost quite a few contacts as that time, it wasn't synching either. Bummer.


    So, I guess from now on, if I add a contact on my iMac, I'll share the contact by emailing it to myself and opening it on my phone and then adding it to my contacts. Ridiculous!!!!

  • 4miler Level 1 (30 points)

    Me too. Just today, 19 March 2013, noticed that a new contact I added to iPhone did not sync to Mac, no matter how many times I pressed the sync button on the iPhone, re-started the Mac's address book several times, re-booted. Nothing worked.

  • sophandfinn Level 1 (0 points)

    I am hoping someone can help = my challenge is a little different.

    I wiped everything on my iphone and backed my ipad up to icloud.

    how do I now transfer my ipad back up on to my iphone.

    Because currently my ipad is not automatically syncing to my iphone.

  • cheonweb Level 4 (3,450 points)

    In your iPhone: Settings>General>Reset>Erase all Content and Settings. Then you will guided to setup your iPhone as new or from backup. Choose "Restore from iCloud backup".

  • sophandfinn Level 1 (0 points)

    It has not replaced my contacts I need to transfer my contacts across

  • cheonweb Level 4 (3,450 points)

    You are talking about backup. Contacts syncing its not backup.

    About Contacts sync through iCloud check this:

    Are your Contacts on

    Are you using the same icloud account on iPad and iPhone?

  • Bill181 Level 1 (0 points)

    Are you saying that unless you are using the storage in icloud an imac, iphone & ipad will not sync? I would like to use icloud for sync between these three devices, not as a backup, but cannot get this to happen.



  • ragerber Level 1 (0 points)

    OMG, something else fundamental that is broken. I have been updating my Contacts from all my devices and a bunch of Mac computers assuming they all would sync. Now I see that they don't. I have no way to do a "join" as far as I can tell except by manually comparing each entry, which is impossible. Great.