Previous 1 10 11 12 13 14 Next 197 Replies Latest reply: Feb 24, 2015 10:24 AM by gillian smith1 Go to original post
  • deeleeda Level 1 (0 points)

    It worked. Thank you! Now, will I have to continue doing that every time I add a contact on my phone?

  • chumac Level 1 (0 points)

    Thanks for your article. After spending days researching, your article did it for me. Like you I needed to use Google contacts as a central cloud storage for my contacts. I have a question though, why did you not recommend 2 way sync on the Mac using Contact Sync.


    I first of all deleted all the contacts on my mac, then dis a one way sync from Google - Mac and all my contacts and groups are now in Mac. Since I have disabled the CadDAV account on the Mac Contacts Application, why cant I use the 2 way sync functionality on Contact Sync. This way i can add contacts on my contact app in addition to my phone and online via gmail.




  • Higgsinspace Level 1 (0 points)

    I think a few things have changes since I posted my article. Cobook removed support for Google Sync a month or so ago. What used to happen is if you synced with Cobook and checked 2 way sync in conatcts you would get duplicates, this was actually under the guidance of the Cobook devs.


    Since Gmail now supports CardDav, its easier to set up a gmail contacts CardDav account in both mac contacts and across all of your iDevices, effectively completely replacing the iCloud contacts.


    However, I had noticed duplicates using 2 way sync from iCloud contacts into gmail using the check box within contacts. This was well over a year ago however.


    I would say if you sync with gmail from contacts using the check box, dont use gmail carddav on your devices, use icloud. you would then filter a back up copy of your contacts to gmail from your mac only.


    Alternatively, just use Google for conacts across the board or use icloud across the board.


    Not gospel mind you, this is just what worked for me at the time.


    Some folks seem to be having no problem with iCloud contacts these days, which is cool. Just make sure you have multiple backups of your contacts before you experiment.



  • ChristianAzen Level 1 (0 points)

    If you have your contacts on iCloud, and need to sync it onto your phone simply turn off contacts on the device you need them on and turn it back on. It will ask to merge, from there you say yes. Cheers:) settings> iCloud> Turn off contacts (keep on iPhone)> turn on contacts (merge)

  • ARuz Level 1 (0 points)

    Also faced this issue today.  The root cause for me seemed to be inconsistencies in credentials being used with iCloud i.e. multiple accounts.  Ultimately, I deleted one account and re-emphasised the link on all devices with the correct single credentials, and then everything started working again.


    Good luck!

  • adiare Level 1 (0 points)

    My issue was the following:


    - New contacts added to phone will stay on phone and NOT merge to iCloud.

    - New contacts added to Mac will stay on Mac and Not merge to iCloud.

    - iMessage on Mac to new contacts added on iphone would not display contact name.


    This fixed my issue:


    1- Re-enter icloud password on iphone.

    2- Turn off iCloud contact

    3- Select keep contacts saved on phone when prompted

    4- Wait for iphone to turn off contacts.

    5- A few minutes later turn contacts back on.

    6- Select Merge when prompted.

    7- A few minutes later, all iphone contacts are merged with icloud and mac picks up all new iCloud contacts.

    8- Optional, you can sign off icloud on Mac and sign back in. (ensuring contacts is ON on Mac as well).



  • chredmond Level 1 (0 points)

    I've just worked through the same issue - iPhone, Mac and iPad Contacts not synching with iCloud or each other - but not the same way, in case anyone else finds the above steps don't do it for them.  They did not fix the problem for me.  Additionally, just about all the Mac CPU time was being consumed by whatever process kicks in when iCloud synching is not successful, to the point where all 16GB of RAM on my Macbk Pro were in use and the machine started running out of RAM, even if I was only running Mail and a browser.  Kind of like the good ol' days of a Mac LC, when the interwebs were all AOL, all the time, and crashes were hourly, if not more than.


    Pls note:  I had previously backed up all Contacts from my MacBk and then restored them, which probably was backing up and restoring the real problem, along with the contacts.  One big clue here was that the Contacts app would crash out after about 15 mins of being active on the MBP.  Regularly, like clockwork.  So whatever record in Contacts was diseased was corrupting the entire Contacts app, which in turn consumed the full 16gb RAM and MBP processor, then freezing and locking up the MacBk, as well as preventing the iCloud sync process from proceeding.  Kind of annoying.


    To get out of this ****, I tried several of the techniques identified in this discussion; they did not solve it for me.  This set of steps did finally provide deliverance:

    1.  Backed up all contacts from Contacts app on my iPhone using the Easy Backup app and emailed that backup to myself.  Also saved it onto my Dropbox acct.

    2.  Deleted all contacts from the MacBk Pro Contacts app.  Restored contacts from the iPhone/Easy Backup copy I had emailed myself.

    3.  Tested sync process amongst all devices and on iCloud.  New records entered into each device now appear on all others within seconds.  And the MBP can actually perform computing functions again, like a real computer.  It's alive!

  • gkagad Level 1 (0 points)

    I have tried all the ways you suggest but I cannot succeed on that


    I have 1339 cards on gmail and 1291 on icloud


    I used to have it synchronized every time i put a new contact on either one.


    one more thing is that on MAC contacts prefs on My MAC account it has nothing under 'Account Information'


    it is really empty


    please, give some advice



  • jimmyb12015 Level 1 (0 points)

    Well. All I did as you said. Turned off IOS devices iCloud Contacts but in addition turned off  also contacts in iCloud on the Mac Air  then turned iCloud Contacts back on on IOS devices then turned back on iCloud contacts and BAM the icloud synch occured as adertised (But hardly automatic i'd say). Automatic function for iCLOUD SYNCH OF CONTACTS IS BROKE. That is from an iPhone 4S with current IOS and 10.9.2 Mac Air.

  • Greeneida Level 1 (0 points)

    Try My Contacts Pro (Free download). You could export all contacts on your iPhone and send them via e-mail, also could import them to your Address Book on your Mac.

  • threesixty Level 1 (0 points)

    I have the same basic problem - iTunes says my contacts are syncing via iCloud, except they aren't.


    New contacts entered in my Mac do not appear on any other device.


    Not ever.


    And no, it's not in any way practical to always enter contacts in my phone or iPad.

  • redisle Level 1 (0 points)

    Isn't it so sad to see a great company gradually shrink into the dust!

    Having done some programming I took pride in fixing all reported bugs overnight and apologising to my clients for inconvenience.  Apple programmers could fix this bug in a couple of days so WHY DON'T THEY?  It is the year 2014 and Apple Contacts on my iMac can't even handle alphabetical order!  The cloud is a disaster.


    I don't want "workarounds"; I want fixed programs!  We should not be using these forums to come up with solutions to Apple's weaknesses.  Fixing their troubled products is Apple's job.  We can use the forums to report problems, to ask about more technical aspects, to suggest new modifcations and uses.  But I would suggest respectfully that the forums are not intended to be a DIY fix Apple workshop!



  • B. Bruce Brinson Level 1 (25 points)

    I am in complete agreement.  I (and many others) first reported this bug in the very first iteration of the technology - years ago - and Apple have still not fixed it.  Amazing - the engineers are quite aware of the problem, as I spent nearly 2 hours on the phone with them when the technology first shipped.  Seems pretty clearly a management decision that it was 'good enough', which seems to be the operative criterion applied to their whole cloud platform.

  • ww77 Level 1 (0 points)

    My apologies for multiple posting, new at this game.


    My thanks to all of you, but particularly adiare.


    - ww

  • ww77 Level 1 (0 points)

    adiare, you are a genius,


    Thank you, thank you, thank you.


    - ww