5 Replies Latest reply: Nov 23, 2014 9:50 AM by kirsten137
Jeffers123 Level 1 Level 1

I upgraded my iphone 3GS to iOS5 last night. Now all the events have gone from my calendar. Also, the '+' icon to add new events has disappeared. I only used the Calendar app on the iphone itself. I do not have any other Calendar software. What has happened? This is really frustrating, as I have lost all my appointments, and is adding to my general disappointment with iOS5.

Solved by Jeffers123 on Oct 14, 2011 12:38 PM Solved

Well, i solved it in typical counter-intuitive fashion. I chose NOT to sync my calendar with icloud. This removed the calendar from my iphone, it appears. By turning this back on (Settings>icloud>Calendars ON), I got my Calendar (and the events and + button) back. This means I have to use icloud if I want to use the calendar app.

  • ameliet28 Level 1 Level 1

    I have the exact same problem and I really want it solved

  • Jeffers123 Level 1 Level 1

    Well, i solved it in typical counter-intuitive fashion. I chose NOT to sync my calendar with icloud. This removed the calendar from my iphone, it appears. By turning this back on (Settings>icloud>Calendars ON), I got my Calendar (and the events and + button) back. This means I have to use icloud if I want to use the calendar app.

  • unixnerd09 Level 1 Level 1

    Had the same problem, your fix worked fine.

    Just one comment. If you delete the cloud from your phone, then it goes back to classic, with "+" for add event.

    it also asks you if you want to keep your events or delete everything once you removed the cloud.

  • chercat Level 1 Level 1

    I had this same problem.  I tried your fix :  turned OFF calendars in icloud; chose to keep events; then turned calendars back ON to icloud.  This did not bring my previous events back.  Is there something I missed?  All events from May 4 back are gone!  Please help me!  Thanks.

  • kirsten137 Level 1 Level 1

    I think I'm having the same problem but it is from syncing my iPhone with my iTunes on my laptop, do you have any ideas on how to fix this?