5 Replies Latest reply: Oct 17, 2011 10:27 PM by graniel
Macfaz Level 1 Level 1 (0 points)

I updated my iPhone 4 to iOS 5 yesterday and I noticed a weird incident that my wife also faced as well as a couple of friends.

Very few incoming phone calls have numbers showing without resolving to the names in our contact list.

I tried playing around with the phone region (Settings -> General -> International -> Region) but that didn't help either.

 

My contact list has names with full numbers including + sign followed by the country code, followed by their phone number. Even if they are local to me.

All local incoming calls gets ID'd without the international code yet the phone used to recognize that prior to iOS 5.

Now, and for very few numbers, it doesn't.

 

Anyone facing this issue as well? If yes or not, any suggestions on what to try?

 

The workaround of course is to add 2 numbers for each person we're facing the problem with; one with international code and one without. But I was hoping for a permenant solution if any.

 

Thanks fellas.


iMac, Mac OS X (10.7.1), 27" 2.93 GHz i7 with 8GB RAM
  • Sashi Level 1 Level 1 (10 points)

    me too

  • ahmed_mh1 Level 1 Level 1 (0 points)

    I have exactly the same issue for me, my wife, and ALL of my friends having iPhones after the upgrade to ios 5. I restored ios 5 again many times with no use, i tried all the options in the settings including the one you have mentioned, but with no use. It is really very disappointing.

     

    I have also many other issues after the upgrade, but this one is the most importnat one for me to find a quick solution for it.

     

    Does anyone have a solution for that? Or shall we wait for the next update of ios 5?

  • FirasAR Level 1 Level 1 (5 points)

    Same problem here after upgrading to iOS 5. Everyone please submit a bug report here so that hopefully Apple will release a quick patch for this:

    http://www.apple.com/feedback/iphone.html

  • ahmed_mh1 Level 1 Level 1 (0 points)

    Thanks a lot for the help. I already did that yesterday. I have also other problems regarding the personal hotspot and my apps in the cloud at the App store which I have reported to Apple as well on the above link.

     

    Hope that Apple will listen and release the required update very soon.

  • graniel Level 1 Level 1 (0 points)

    Everything was fine til I upgraded to iOS 5! All my contacts have country codes as I travel frequently. The problem is when people calling me locally, iPhone can't match the numbers as the carrier does not send the country code. Example in Kuwait, I save numbers as +965xxxxxxxx. When I get a call in Kuwait, it appears only as xxxxxxxx and the iPhone cannot match it with my contact that has the +965. If I reformat the contact without the country code, it solves this problem but then I hit another problem with SMS as the carrier always sends the country code. The only workaround is to add the same number twice - one with country code and one without. This is unacceptable! Anyone know how to fix this?