Skip navigation

Disable iMessage for certain people

118532 Views 40 Replies Latest reply: Dec 12, 2013 4:14 PM by mjm1231 RSS
1 2 3 Previous Next
phel Level 1 Level 1 (0 points)
Currently Being Moderated
Oct 13, 2011 3:26 PM

Hi

 

I have to specific problem with iMessage!

 

One of my friends has an iPad2 and a mobile phone from Nokia. He has activated iMessage on his iPad2 which means that I automatically will send messages to him via iMessage.

However, the problem is that those are not shown on his Nokia mobile phone, which he uses all the time.

 

How can I send normal SMS to him without having to manually turn on and off iMessage?

Is there anyway you can disable iMessage for certain people??

 

This is frustrating!!

 

Kind regards

Philip

  • sjbrown23 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 14, 2011 4:20 PM (in response to phel)

    I'm only replying since I want to follow this thread.. I have a similar issue... I want to only SMS my wife on her iPhone but iMessage my daughter on her iPod...

  • buffbuff Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 14, 2011 4:31 PM (in response to phel)

    Without knowing how you store your contacts, but when you create a new message and select your friend, if their contact contains an email address (used for iMessage) and a tel no., then you select the tel no and it should create the green SMS bubble. If you want to send an iMessage, then you select the email address.

     

    After that if you just go into the Message app and select a conversation history, just select the conversation depending on the method you want to use as there will be 2 for your contact.

  • sjbrown23 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 14, 2011 5:16 PM (in response to buffbuff)

    I set up my wife's contact with her iphone # and email... I cleared the old messages and then tried starting a new one (from the contact - not even in the message app) and it immediately defaulted to iMessage... if I touched the message it gave me the option of sending as sms but then it's two messages and no savings on data...

     

    I even tried deleting her phone # from the contact and putting it into a separate contact but it somehow still defaulted to iMessage.. 

     

    Not sure what to do next...

  • g1r2e3g Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 14, 2011 7:14 PM (in response to phel)

    I'm having the same issue. My partner has an iPhone 3GS but switched to Android recently but still uses the iPhone at home as in iPod. However now after upgrading the 3GS to iOS5 if I try to send an SMS to their number it will iMessage the iPhone and not SMS to the Android, so I have to disbale iMessage altogether to send an SMS to their actual phone.

     

    Surely there is many people in various situations like this. There should be a way to disbale certain contacts from iMessage altogether or at least some way in the message composer to choose the transport method per message.

  • LTRossi Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 15, 2011 6:32 AM (in response to g1r2e3g)

    I am having the same problem, I gave my old iPhone  3Gs to my girlfriend, and when I upgraded the 3Gs to iOS5 it asked for a sim card. I put in her sim card from a samsung phone into the iPhone just to activate the phone. I put her sim card back into her samsung and now when I send her a text it goes to the iPhone even though it has no sim card.

  • buffbuff Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 15, 2011 3:32 PM (in response to sjbrown23)

    Now I am experiencing this with a friends iPhone I setup earlier. What I said above doesn't work with his contact on my phone, but it still works for anothe contact I have. Will explore this further.

  • buffbuff Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 16, 2011 7:24 AM (in response to buffbuff)

    I checked out my friends phone and the reason why I was able to choose either an SMS or iMessage was because on his phone, he only had his iMessages to be received at his email address only.

     

    However at that time in his message settings screen, it was still saying waiting for activation. After he went into the "received at" screen and waited a few seconds, it added his phone number to the received at, and now I can no longer choose as it creates an iMessage no matter what I select.

     

    I think the reason why I was able to choose SMS or iMessage was because his phone number hadn't yet been activated for iMessage, just his email address.

  • NickL-UK Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 16, 2011 8:30 AM (in response to phel)

    I have pretty much the same issue as you all - but a slight variation therein.

     

    https://discussions.apple.com/thread/3397594?tstart=0

     

    I am hoping that the simple answer will be that you can access the list of numbers associated with iMessage through your AppleID, via iTunes or however, and deselect numbers. If that functionality isn't available yet - I hope it will be at some point in the future.

  • joelfromladera ranch Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 20, 2011 11:53 AM (in response to LTRossi)

    I have this exact same issue.  Any idea what to do about this yet?

  • joelfromladera ranch Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 20, 2011 11:53 AM (in response to phel)

    Bump.  Just was hoping someone else had resolved this already. 

  • sjbrown23 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 20, 2011 2:19 PM (in response to phel)

    On a recent business trip, I asked at the AT&T store in Arlington, TX and according to them there is no way to change the default from iMessage w/o just disabling iMessage...  hopefully Apple will release that in the next iOS release..

  • g1r2e3g Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 20, 2011 4:17 PM (in response to sjbrown23)

    There is no way in your own device to be selective about which contact you iMessage wiht. You only have the option to completely disable iMessage. In my case the problem has been solved by disabling iMessage on my partners iPhone that no longe has a sim card in it.The alternative would have been to buy a cheap pre-paid sim card to re-activate the iPhone and therefore their iMessage account would be attached to a different number.

  • immaViLLaiN Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 24, 2011 12:13 PM (in response to phel)

    I have the same problem. I upgraded to the iPhone 4S and sold my iPhone 4 to a friend. He started getting messages from people that had iOS5 and using iMessage, who was texting me. Good thing I didn't sell it to a stranger. This is a huge problem.

  • sjbrown23 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 24, 2011 3:34 PM (in response to immaViLLaiN)

    From what I've read I think your issue is easily resolved (not guaranteed though)...  Go to settings and then click on messages and check the "Receive At" settings. Your old email addy might still be listed and / or phone number. You will have to establish a new email address and that might help (I had that issue with  my kid's iPod and that cured it) 

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.