Skip navigation

Cant Update to iPhoto 9.2

2772 Views 15 Replies Latest reply: Aug 23, 2012 5:13 AM by wollvieh RSS
1 2 Previous Next
BluRose Calculating status...
Currently Being Moderated
Oct 13, 2011 4:18 PM

I bought a new macbook pro in June with iLife 11 installed on it (which now has been upgraded to Lion, which I got for free because I bought it close to release fate). Now I would like to update so I can use photostream. But I can not install the update. Whenever I go to the system updates in preferences, it says no new software updates. When I go to the updates in iPhoto it "This version of iPhoto (9.1.5) is the current version." When I download a manual update from apple.com, I download it, extract it open iPhoto9.2Update.pkg and I get the error

"Alert. iPhoto 9.1.0 or later is required to install this update."

 

Why?? I want to fully use my iCloud!

  • Terence Devlin Level 10 Level 10 (121,745 points)
    Currently Being Moderated
    Oct 13, 2011 10:58 PM (in response to BluRose)

    Have you moved the iLife apps from their default install location?

  • Bready29645 Calculating status...
    Currently Being Moderated
    Oct 14, 2011 3:56 AM (in response to Terence Devlin)

    I'm having the same issue.  I have upgraded to Lion on my iMac. I've moved to iCloud EXCEPT iPhoto requires an update to use Photo Streaming. I'm stuck on iPhoto 9.1.5 and it tells me that's the most current version when I use the check for updates. I have never moved any iLife apps from their default install locations.

  • Terence Devlin Level 10 Level 10 (121,745 points)
    Currently Being Moderated
    Oct 14, 2011 4:03 AM (in response to Bready29645)

    If you have a very recent Mac and/or your purchased iPhoto 11 from the App Store, then you check for updates there.

     

    Otherwise you use Software Update.

  • Bready29645 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 14, 2011 4:06 AM (in response to Bready29645)

    Problem solved. Go to Preferences and then Software Update.  It found the iPhoto update and installed successfully.  I just couldn't do it directly from the iPhoto app.

  • Allison Williams Calculating status...
    Currently Being Moderated
    Oct 14, 2011 4:11 AM (in response to BluRose)

    Frankly, right now you are better off with the old version since 9.2 seems to be crahing everywhere.

  • cfryson1 Calculating status...
    Currently Being Moderated
    Oct 14, 2011 6:03 AM (in response to BluRose)

    I am still trying to get the new Iphoto 9.2 uploaded.  I am getting the error message of Iphoto can not be istalled on my disk drive.  Iphoto 9.0 or later is reqquired.  Help!

  • jefferyfromartesia Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 14, 2011 8:30 AM (in response to BluRose)

    I'm also having this same problem.  Software update shows everything is current; I downloaded the update directly from Apple (mentioned in another thread) and when running it, get message that I need at least 9.1.0 installed (9.1.5 is installed).  Tried running update from within iPhoto and get the message that it is the current version.  Followed Bready's advice and checked Preferences | Sofware Update and found that iLife or iPhoto is not listed as an installed application.  Interesting since it was installed when I purchased my MacBook from Apple in March 2011 (and setup by an Apple Store employee (making this statement to answer the "did you register the software" questions)).  I have since updated the OS to Lion and I am pretty sure there has been updates to iLife app's since I got the notebook.  Needless to say, this is no longer about getting PhotoStream to work - it has now become a quest as to why my MacBook isn't recognizing my installed software.

     

    Thanks for any help.

  • Darla Mack Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 14, 2011 10:41 AM (in response to Terence Devlin)

    Terence thank you sooo much!  Lol for 2 days I've been tryin to figure out why I couldn't update and kept getting those messages.  I remember awhile back I found a pretty iLife folder icon and moved iPhoto, iMovie and Garage Band into it so that the folder displayed in my Applications section.  Once I moved the apps out of the folder the update worked.  Thx again!

  • jefferyfromartesia Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 14, 2011 12:35 PM (in response to Darla Mack)

    Darla, I realize you were replying to Terrence; who in turn fixed my issue too; but thank you for posting on this thread.  I guess you can't organize your Applications folder without some negative impact.  Who knew!!

  • CRM-114 Level 1 Level 1 (20 points)
    Currently Being Moderated
    Oct 19, 2011 3:59 PM (in response to BluRose)

    If you are still experiencing the issue and:

    • cannot update from Software Update
    • cannot update from Mac App Store (incorrect account error)
    • cannot update using the manual installer
    • have not moved the iPhoto App out of the root of the Applications folder

     

    Then try this taken from MacRumors forum thread which appears to work - did for me.

     

    http://forums.macrumors.com/showthread.php?t=1248365

     

    See entry #6 from rk25123. Thank you, who ever you are

     

    • go to Applications folder - this assumes that the iPhoto app has not been moved from here as I have seen on other threads
    • select iPhoto app
    • right click/double tap and select Show Package Contents
    • open Contents folder
    • trash the _MASReceipt folder or the receipt file within (admin password required)
    • Run software update and iPhoto 9.2 will now show as available

     

    But seeing as 9.2 seems to be buggy and crashing, mayhaps wait for another update as I am.

     

    But you can trash the receipt and run software update to see if it shows. As a further test, I replaced the receipt and was back to no new update.

  • co_gaucho Calculating status...
    Currently Being Moderated
    Oct 19, 2011 9:08 PM (in response to CRM-114)

    Thanks, CRM-114. This did the trick.

  • Terence Devlin Level 10 Level 10 (121,745 points)
    Currently Being Moderated
    Oct 19, 2011 11:21 PM (in response to CRM-114)

    I would be very ccareful about removing that receipt. We have no idea if it will cause problems in the future. The correct method to del with the issue is to contact App Store support.

  • CRM-114 Level 1 Level 1 (20 points)
    Currently Being Moderated
    Oct 20, 2011 12:54 PM (in response to Terence Devlin)

    Hi Terence,

     

    I agree that removing the receipt could result in future issues and I did consider it - personally, I'll take the risk.

     

    My recently purchased iMac came pre-installed with iLife 11. Updates to iPhoto (and other apps) went through fine without any problems.

     

    I don't recall any other past updates on my previous new Macs ever having caused issues that didn't show on Software Update, didn't install from the manual downloader or state incorrect Apple ID used. Granted, Mac App Store hasn't been around that long.

     

    It is only iPhoto 9.2. It's an odd problem, that's for sure. I'm really no expert, but is it fundementally a 9.2 and iCloud (Apple ID) linked issue? Or is it related to any work Apple are doing to merge IDs? In any case, Apple need to be, if not already, working on a point update which fixes amongst other recently reported issues, this one.

     

    I appreciate the advice you have offerred in this and across all the other posts but I am less sure at this stage of the steps Apple Support are taking as it seems to be inconsistent and more of a patch than a fix which is fair enough at this stage.

     

    And if my next iPhoto update has problems, I'll come knocking on your door where you can say "I told you so"  and then hopefully help me fix it.

     

    Kind regards,

     

    CRM-114

  • Terence Devlin Level 10 Level 10 (121,745 points)
    Currently Being Moderated
    Oct 20, 2011 2:18 PM (in response to CRM-114)

    I think you need to look at other threds on this issue. On poster got an explantion - it's a muck up  when they set up the machines at the factory - the apps are assigned to a specific ID and not to  generic one. As the issue is worked out App Store support are issuing codes  to fix the issue and vouchers to people.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Related Articles

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.