Previous 1 2 3 4 5 Next 307 Replies Latest reply: Sep 4, 2013 7:19 AM by vandamelloc Go to original post
  • Limegrntaln Level 1 Level 1

    Yeah just got 3 emails only after I manually checked it, which were 20 minutes old.

  • Rich5481 Level 1 Level 1

    its possible that the issue is with people who migrated from MobileMe to icloud, one way to verify is doing the following.

     

    please do the following test:

     

    (1) close all apps in the background

    (2) restart your iOS 5 device

    (3) send an e-mail from another client

    (4) waiting for push mail

         --> it should work at this time (there is no mail.app in the background)

     

    (5) now open the mail.app on your iOS 5 device, and send it to the background

    (6) send an e-mail from another client again

    (7) waiting for push mail

         --> it works (with the mail.app in the background)

     

    (8) now close the mail.app completely (kill the app from running in the background)

    (9) send an e-mail from another client again

    (7) waiting for push mail

         --> it doesn't work

     

    It seems to me, that killing the mail.app from the background in iOS 5 the process which receives the pushed e-mails is also killed.

  • Limegrntaln Level 1 Level 1

    I didn't even get push after closing and restarting in step 1. This is getting annoying.

  • Andoman Level 1 Level 1

    I've been a MobileMe user for years and after updating to iOS 5 and the iCloud push has stopped working on my iPhone 4, and as of yesterday also on my iPad 2.

     

    This is a pretty big screwup on Apple's part

  • Boomdog Level 1 Level 1

    Just adding my voice to the chorus - still having the same problem.  (And yes, push is turned on in my settings.)

  • TheOnlyRandy Level 1 Level 1

    I'm in the exact same boat...MobileMe user for years, and as of this morning still no push emails for 2+ days now...COME ON APPLE!

  • mightymilk Level 1 Level 1

    I was having the same problem for the first few days, but now it seems to be working again.

     

    Judging by that information, I'm starting to think this may be a Server issue and completely out of our hands.  If I'm right, Apple does however need to fix this a.s.a.p.

  • alfred53 Level 1 Level 1

    I was using another email (rogers.com) before on my iPhone and the push was perfect. But because I heard that apple is offering the free me.com since the iOS 5 release, I thought I'd switch over to me.com since I'm gonna be using iCloud a lot. After creating a new Apple ID (me.com) The email was pushed perfectly. But once i disabled or deleted my rogers.com email, I have the same problem as everyone here. I can only get pushed email to my me.com when my mail app is running in the background. But for some odd reason when my rogers.com email is enabled, both emails get pushed even if the mail app is closed, not running in the background. I don't know if there's any association with the Apple ID switch.

  • Limegrntaln Level 1 Level 1

    It's been pushing for me most of the day. It's going to be a while though, before I trust it.

  • unseenmagik Level 1 Level 1

    Another Mobile Me user moving over to iCloud.

    Push mail seems to be a bit hit and miss.

    It WILL not push mail at all if the mail app is closed from the multitasking bar.

    If the mail app is open sometimes it push's but very rare.

    This needs to be fixed. Not sure if its an iOS5 issue or an iCloud issue.

    No emails on my lockscreen or homescreen this morning. opened up the app " that was running all ready " 27 emails. Something is not right.

    Apple PLEASE fix this.

  • StevenW890 Level 1 Level 1

    Here is what worked for me. It seems there is a app that is running in the background that is conflicting with mail notifications. Don't know which one it is yet, but if you close all apps running in the background, and reopen mail, the notifications will return.

      Like I said I haven't figured which app(s) is creating the problem, but this works for me.

  • Limegrntaln Level 1 Level 1

    Seems to work for me as long as I leave the app open. Regardless of what else is open. I can't believe I'm not reading this all over the tech blogs.

  • rachellee12 Level 1 Level 1

    I am having the same issue as everyone. I have migrated 2 family accounts from mobile me (lots of kids) took hours to do them all individually. Not sure about the kids but  my husbands iphone is pushing emails, like in mobile me and also to his ipad, my emails are going to my ipad but not to my iphone!!!! VERY frustrating, used to just seeing a number on my email app that tells me i have mail, HATE having to load the app and then see i had mail that i didn't know about!!!! Glad to see it's not just me though, Is a bit annoying thought know I am paying for a service that non mobile me members are now getting for free!!

  • rachellee12 Level 1 Level 1

    I closed all of my apps, still doesn't work

  • EddieT Level 1 Level 1

    Not working for me either. Switched over from MobileMe this morning. MobileMe pushed email to my iPhone 4 without a hitch. Showed up on my locked screen and everything. Since moving to iCloud, I have to open Mail to check for email. Bummer.

Previous 1 2 3 4 5 Next