Previous 1 2 Next 18 Replies Latest reply: Sep 30, 2012 11:34 AM by TonyynoT
Septiansyah Level 1 Level 1 (0 points)

I have a small problem with the iMessage. My phone only recognize and auto detect the apple ID but not the phone number who are available for iMessage. Does anyone experienced the same problem?

 

These print screen below is 2 examples from my contact who actually available for the iMessage with their phone number.

 

Picture 897.png

Picture 898.png


iPhone 4, iOS5
  • LonePar Level 1 Level 1 (10 points)

    It looks like your friend needs to validate his telephone number in the imessage accout settings (receive at) on his phone. I noticed this and had to do it myself as it only linked my Apple ID at first after installing iOS 5?

  • Castans Level 1 Level 1 (0 points)

    How can you do it? I am having the same issue and in the 'Receive At' I cant add my phone number.

  • Castans Level 1 Level 1 (0 points)

    Turn iMessenger off then turn it back on, works

  • kai zhin Level 1 Level 1 (0 points)

    I turn it off and then turn it back on still doesn't work

  • uahero Level 1 Level 1 (5 points)

    I had the same problem before - your iPhone is automatically authorized both for email and phone IDs but email is set as default one. To change you should go Settings -> Messages -> Receive at -> Caller ID -> set phone as default one

    Actually it is very confusing why isnot the phone is selected by default

  • toddaz Level 1 Level 1 (0 points)

    When I go to Settings -> Messages -> Receive at -> Caller ID -> there is no phone option, just the two email addresses that I registered to iMessage. How do you get it to default on the phone?

  • Riz2011 Level 1 Level 1 (0 points)

    you dont. its a flaw. Im having the same problem. it seems to work with some and not work with others. I have read all the discussions and it seems like a bug some get and some dont. no solutions to it yet.

  • rocel Level 1 Level 1 (0 points)

    i think it's iOS 5 bug. yes some have MMS messaging option and others dont. I also reading a lot of discussions but no positive answer as of this writing. I hope apple can fix it immediately in their next update.

  • makan1 Level 1 Level 1 (20 points)

    oops wrong post sorry guys

  • yjsoon Level 1 Level 1 (0 points)

    Try adding a country code (e.g. +1 for US) in front of the other party's phone number, and it should be able to pick it up.

     

    When your iMessage caller ID is set as an email address, you won't be able to auto-detect iMessage capabilities on numbers without country codes. However, if you use a phone number as your caller ID, I think iMessage searches local numbers (same country code) to recognise the other party's iMessage capability.

  • mdcastle Level 1 Level 1 (0 points)

    Try clearing your conversation in iMessage with that particular person.  Just worked for me after hours of searching.

     

    In the Messages App go to Edit -> Clear All

  • narf_44 Level 1 Level 1 (0 points)

    This worked for me

    Open your text message app and delete ALL your conversations then...

    Settings>Store>Turn off Music and Apps

    Settings> Messages> turn off iMessage

    Settings>face time> turn off

    Restart phone

    Settings>Store>turn back on music & apps

    Settings> Turn back on Facetime

    Setgins>iMessage>turn on

    Then in iMessage...Received AT>caller ID (verify it is on phone number not email)

  • mattydunn1701 Level 1 Level 1 (0 points)

    i am having this problem aswell but only with 1 of the 7 contacts i have with iphones only one of my contacts picks up the email and not the phone number any solution to this yet? i have tried the removing email by signing out of the Apple ID and setting it just to phone number then turned imessage off and back on to let it reactivate but it still dosnt pick the phone number up.

     

    anybody got a solution to this?

     

    i think Apple made a mistake intergrating it to the messages like they have done i think it should have been a stand alone App that used the phone number the add a friend much like the Blackberrys use the Blackberry Pin to add a friend to BBM it would most likely work and people wouldnt end up with stupid problems like this

  • mattydunn1701 Level 1 Level 1 (0 points)

    i think i have found a fix for this its worked for me so its worth a try. You will need the other persons phone to do this.

     

    1) Delete the contact from your phone.

    2) On your phone go to Settings > Messages then tap receive at, it it has your Apple ID e-mail address at the top tap that and sign out this will remove your e-mail address from iMessage leaving just your phone number.

    3) Go back to Message settings turn off iMessage.

    4) Turn off your phone and back on.

    5) Go back to Settings > Messages and turn back on iMessage it will then reactivate iMessage

     

     

    Now for your friends phone

     

    1) Go to yourself on your friends contact list and remove your e-mail address if they have it saved.

    2) Go to Settings > Messages then tap receive at, if it has their Apple ID e-mail address at the top tap that and sign out removing their e-mail address.

    3) Go back to Message settings turn off iMessage.

    4) Turn off their phone and turn it back on

    5) Go back to Settings > Messages and turn back on iMessage

     

    once reactivated on both phones follow these steps.

     

    1) Send a message from your friends phone to yours

    2) On your phone the message should come through and will have your friends mobile number at the top

    3) Reply to your friends message.

    4) Save your friends phone number as a contact again leaving the the country code (i.e UK country code +44)

    5) Delete the message between you and your friend on your phone then compose a new message and and select your friends number and it should automatically send as a iMessage send the message then go back to your contacts remove the Country code from the number and from there on then the iMessage will detect that persons phone number as a iMessage compatible device.

     

    This has worked for me and 3 other of my friends who where having the same problem with a number of their contacts, it seems the error is more to do with your friends phone, when activating iMessage for the first time it automatically defaults to the Apple ID and in some cases causing the phone number not to register correctly with the Apple servers this step by step removes the e-mail and reactivates nothing but the phone number with the iMessage servers.

     

    Hope This Helps.

Previous 1 2 Next