Previous 1 2 3 4 Next 48 Replies Latest reply: Jul 15, 2014 6:02 PM by MarvelGrl313 Go to original post
  • mr.prince Level 1 Level 1 (0 points)

    I can't activate my mobile number with facetime and imessage as well. I have done several troubleshooting such resetting, restoring and clean install of iOS5 from DFU mode but to no avail. It's really frustrating that apple hasn't given any official statement about this.

  • deggie Level 8 Level 8 (47,825 points)

    As I asked the other poster, are you using an authorized Apple cell provider?

  • Abhinav26 Level 1 Level 1 (0 points)

    Yes

  • deggie Level 8 Level 8 (47,825 points)

    Then call them, a text message is sent for activation and apparently in your case it is not being properly handled by your carrier.

  • InfamousOne Level 1 Level 1 (25 points)

    Call who, the carrier or Apple?

     

    Problem with calling Apple is I'm not under warranty and don't want to pay for their one time telephone help.

  • InfamousOne Level 1 Level 1 (25 points)

    Okay, so I just tried this with my official Carrier SIM (Rogers) and it worked. I guess it's not supported with unofficial carriers yet, even if you own an unlocked iPhone? Anyone know any solutions to that?

     

    Abhinav26, if you're on an official carrier, try this. Just worked for me when I tried it. Turn off iMessage. Take out the SIM, put it back in and hold sleep/home button until it restarts (you see the Apple logo, then let go). After it restarts, go and turn on iMessage and wait, hopefully it get's activated by phone number (as this just worked for me).

     

    Got a bit of time today, so going to try to see if I can get it to work with an unoffical carrier (the one I actually use).

  • Roberto Avanzi Level 1 Level 1 (15 points)

    I had the following problem: Change SIM, facetime and imessage NOT activating on the new number and still showing the old one.

     

    What I did was the following.

     

    To be done just once:

     

    Go to Settings -> Mail, contacts, calendars -> My info, select your own card.

     

    To be done every time you change the sim

     

    go to address book, make sure the current phone number is the ONLY one that is marked "iPhone"

     

    (Deactivate/reactivate FaceTime and iMessage)

     

    After a short while, facetime and imessage should be activated with the NEW number

     

    NO "erase all settings" required, NO reboot.

     

    Note that I did this with official carriers and also non-official carriers (all with a factory unlocked iPhone). I can now reproduce this on a regular basis.

     

    Roberto

  • Roberto Avanzi Level 1 Level 1 (15 points)

    I had the following problem: Change SIM, facetime and imessage NOT activating on the new number and still showing the old one.

     

    What I did was the following.

     

    To be done just once:

     

    Go to Settings -> Mail, contacts, calendars -> My info, select your own card.

     

    To be done every time you change the sim (in your case that can be also only once).

     

    Go to address book, make sure the current phone number is the ONLY one that is marked "iPhone"

     

    (Deactivate/reactivate FaceTime and iMessage)

     

    After a short while, facetime and imessage should be activated with the NEW number

     

    NO "erase all settings" required, NO reboot.

     

    Note that I did this with official carriers and also non-official carriers (all with a factory unlocked iPhone). I can now reproduce this on a regular basis.

     

    Roberto

  • Abhinav26 Level 1 Level 1 (0 points)

    Done
    Turns out my SMS mailbox was full and as soon as i cleared all the messages and re-inserted my sim card, iMessage was activated!
    Thanks alot for all your help

  • InfamousOne Level 1 Level 1 (25 points)

    Tried it, and that doesn't work. Wish Apple just updates it to accept it with ANY carrier. I don't see why an unofficial carrier should have a problem.

     

    I don't have a warranty on it, so I might just give a visit to an Apple Genius and see if they know anything about.

  • deggie Level 8 Level 8 (47,825 points)

    The problem is if you are not on a supported carrier the text message needed for activation does not make it through. This is the case with using an iPhone with T-Mobile in the US.

  • Roberto Avanzi Level 1 Level 1 (15 points)

    Well, I tried with TWO SIM cards of non-official carriers (even *resellers* of non-supported carriers: a german simyo SIM and an italian WIND SIM) and it worked. Reliably. And I had been fighting for a few days to no avail to get it working.

     

    The idea is to deactivate facetime/imessage, and THEN update the information in your contact book: Change the label of the old number to "cellular" and the label of the number you want to use to "iPhone" - there must be only one iPhone, I verified with two "iPhones" and it did not work.

     

    Double check that in Settings -> Mail,contacts,calendars -> My Info  you select your own contact card, otherwise the Facetime/iMessage servers do not know which number to activate. Check that the number is in international format with the GSM IDD shortcut "+" in place of the IDD "01" or "00" (that's the only way to get it really realiably working from a mobile phone). This may sound complicated and in fact the iPhone could just use the number stored in the SIM for this, but whatever. (Some SIM do not give this information correctly.)

     

    After this, you may want to extract and reinsert the SIM, I do not know if this is really necessary, and you can now reactivate iMessage/Facetime. ACCEPT that you are going to send the SMS (I think that there is one outgoing from the iPhone and one ingoing for the activation process). Then wait a bit. For a few seconds/a couple of minutes the iPhone may still show the old number (if you are switching from another SIM) while it is "waiting for activation", but eventually it will activate and show the right number. YMMV: Once it activated iMessage immediately and Facetime only after a few minutes.

     

    Of course there may be _other_ reasons for no proper activation, but at least this solved the problem for me. No restore, no "erase all settings", nothing more annoying that just checking that the information was indeed correct and unambiguous.

     

    Roberto

  • jliew Level 1 Level 1 (0 points)

    Hi guys,

     

    My iMessage worked after doing these steps:

     

    1. Go to Settings

    2. Click on Phone

    3. Ensure the number on "My Number" is your right number

    4. Go back to Message in Settings

    5. iMessage should be activated by now

     

    I am a business traveler and I often switched SIM cards. I couldn't use the SIM in Philippines (Globe) but when I changed it to my orginal SIM from Malaysia, it worked.

     

    Try it if you can.

  • Roberto Avanzi Level 1 Level 1 (15 points)

    Are the numbers you use marked as "iPhone" in your own contact card?

  • InfamousOne Level 1 Level 1 (25 points)

    Yeah, I took out the SIM, re-inserted it. Selected myself as a contact in My Info and made sure it was selected iPhone for my own number (I only have one of them saved in contacts anyway). I restarted my phone, I made sure the phone number at the top was correct. Still waiting for activation and failing..

     

    I think it may just be my carrier (Chatrwireless) in Canada.