Skip navigation

iMessage not activating

43335 Views 46 Replies Latest reply: Sep 20, 2013 12:46 AM by patrickak RSS
  • Fenerium Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 4, 2011 6:42 AM (in response to InfamousOne)

    I have been having this problem ever since i buy new iPhone 4S in Australia Melbourne since first came out and fixed today.

     

    Basically my problem was i can send iMessage but no SMS to standard phones. And my iMessage and facetime wouldn't activate at all even though i have the right plan with lots of credit.

     

    After extensive hours of backups and restores i have fixed and is only small issue.

     

    Happy to help you all.

     

    Here is the problem.

     

    1) First check you have enough credit or BALANCE in your phones bill account. If you do and have valid SMS function enabled from your carrier then proceed to next step, Please call your phone carrier make sure you have credit and sms is enabled.

     

     

     

    2) Ensure you are still logged in to your apple id in message and facetime however Turn off iMessage and Facetime (settings-> imessage & settings -> facetime)

     

    3) Please type in phone -> keypad *#5005*7672# and then press CALL

     

    This will show you your SMS service center number.

     

    Now please note if it does provide you with a number write it down, now Phone you phone carrier and ask them if this is the correct SMS service center number for your Contract/Prepaid/Postpaid plan. verify with them. If it isn't get the new number. You can also look on GOOGLE for the right service number just search it.

     

    If there is no number/address showing then this is also the problem which was my same problem

     

    So i found my SMS service center number which is for Virgin in Australia number was +61411990010

     

    Now when you get correct the service center number you type it together in keypad and press call:

     

    So What i typed is

     

    *5005*7672*+61411990010#

     

    You just must replaced the +61411990010 with your carriers service center number and your done.

     

    Once the number is set you now goto settings iMessage and Facetime (settings-> imessage & settings -> facetime) turn them on as you desire! All works. Provided that your service center number was set correctly.

     

    I have been on the phone to APPLE customer support they could not even figure this out i figured it out after so long.

     

    Good luck i hope this works for you all!

  • Mubashir Calculating status...
    Currently Being Moderated
    Nov 12, 2011 10:58 AM (in response to Fenerium)

     

     

    Hi there

     

    I have been having issues with iMessage on my iPhone 3gs for the past few days. Initially, it was working fine all of a sudden it crashed. And now, I am unable to activate it again - i have tried everything possible yet unable to activate I get this error everytime. Any help will be much appreciated.

     

    mail.png

    Many thanks.

     

    Muba

  • Hoss Sawarbi Calculating status...
    Currently Being Moderated
    Nov 27, 2011 10:59 AM (in response to InfamousOne)

    I tried something that actually worked immediately, it may sound funny and has no relevance, it worked with me:

     

    Purchase an app called WhatsApp Messanger which is very popular for group messanging (I'm not sure if its free or not, I purchased it a long time ago). Activate WhatsApp then iMessage should work.

  • Bigmac1008 Calculating status...
    Currently Being Moderated
    Dec 6, 2011 2:09 PM (in response to InfamousOne)

    DNS of the WIFI connection changed in 8.8.8.8

    Works for me !

  • djolson Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 19, 2011 11:57 AM (in response to Bigmac1008)

    Here's what I learned, and it worked:

     

    If you are using a Sprint phone with Google Voice, you CANNOT use iMessage. Google Voice intercepts the activation SMS that is sent, and it never reaches your phone. That SMS message must be accepted by your phone software and processed in order to activate iMessage. You must deactivate your Google Voice service for the phone, THEN activate iMessage. It takes about 3 minutes to activate at that point.

     

    Note that (at least currently) GV is incompatible with iMessage, period. So until they address the issue, you can either use GV and "regular" SMS messaging, or not use GV and have iMessage.

     

    Your choice. Check it out....

  • EasyA Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 30, 2011 6:47 AM (in response to InfamousOne)

    Hi, I have a very easy solution. It took me only 3 seconds. Go to Settings>messages, activate iMessage and deactivate sms. Next time you send a text, it will automatically send as iMessage!

    Also, do it while your phone is connected to your pc, so it gets easy internet access to activate i Message

  • huskyte Level 1 Level 1 (25 points)
    Currently Being Moderated
    Jan 20, 2012 5:04 AM (in response to InfamousOne)

    For those experiencing the same problem in switzerland (no caller id shown, not activating), just for the records: This issue is provider related and known. This also suggests it is being worked on.

    The people affected are the ones who are on contract with orange or chose to swap to sunrise.

    This also means: there is currently no workaround, no fix, no reason to get excited. Just wait for the problem to be resolved.

    For those in other countries: The issue is related to sort of a sms block activated and long forgotten. You might want to check with the apple support, most 4S might still be valid for support.

  • kingdomhearts09 Calculating status...
    Currently Being Moderated
    Jan 26, 2012 12:26 AM (in response to seq2)

    I had the same problem with my bf's iphone 3gs ios 5, Thank you seq2 your a champ! i tried your method and what do you know it worked.

  • Kelly329 Calculating status...
    Currently Being Moderated
    Feb 13, 2012 5:04 AM (in response to InfamousOne)

    Hi everybody.

     

    I had this problem for quite some time with my iPhone 4S with iOS 5, and went searching through the apple forums for help, trying everything but resetting my phone completely, to no avail.

    My iMessage had stopped working, and I had no idea why. It told me that it was waiting for activation and that messages could not be recieved through my mobile number, but instead my Apple I.D.

     

    I realised after some thought of what could have caused this annoying problem, that perhaps the fact that I once removed the sim card out of curiosity (this being the first iPhone I have ever had), might have done something to cause this, seeing this problem only started after I did that. 

     

    So, I tried to fix this problem myself. This worked for me instantly, without having to reset any settings or my iPhone in general.

     

    • Open your message settings (settings -> messages) until you can see the iMessage 'Waiting for Activation...' message. Turn on iMessage.
    • Grab the sim card key (that came with and is hopefully still in your iPhone box) or use a paperclip to open the sim card slot, on the side of the phone while having the message settings open and your iMessage turned on.
    • After a couple seconds, slide the sim card back in, and unlock your sim.
    • Go back into your message settings (it will have closed while removing your sim card) and see whether the 'Waiting for Activation...' message has gone, and is now working properly and recieving messages from your mobile number.
    • Test it, by open a message with a friend that has an iPhone and see if the message bar has changed from 'Text Message' (green) to 'iMessage' (blue).

     

    Hopefully, this works for you guys! It did instantly for me, and my iMessage is now working fine.

    Good luck!

     

    Message was edited by: Kelly329

  • BerniePena Calculating status...
    Currently Being Moderated
    Feb 27, 2012 3:37 PM (in response to InfamousOne)

    Hi I'm trying to activate my imessage, but i keep getting error message saying "could not sign in. Please check your network connection and try again" i have full service, plus am connected to wifi

  • Fortu Calculating status...
    Currently Being Moderated
    Feb 29, 2012 11:36 AM (in response to InfamousOne)

    I have the same problem.

    My Iphone 4S cannot read my phone number. It does not my number under MY PHONE NUMBER.

    Also I cannot activate IMessage.

    I just spoke with Apple Support and they do not have a clue. She said: just will till is activated.

    My Apple ID case number is: 294030177

    Do you have any solution?

    Please help

    I bought my phone unlocked from Apple. My number is from Peru

  • lefteros Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 26, 2012 3:57 AM (in response to InfamousOne)

    So, after trying EVERYTHING and still get nothing, I searched a bit in the official Apple site and found this: http://support.apple.com/kb/TS2755 .

     

    iPhone automatically registers your phone number for use with iMessage during activation. If you encounter issues activating or using iMessage with your phone number:

    • Verify that you are connected to a cellular network.
    • Toggle iMessage off and on in Settings > Messages.
    • If you are unable to activate iMessage on a device after remote wiping it, wait at least 24 hours and try again.

     

    So, yesterday i switched iMessage & FaceTime off all day long, and today I turned them on, waited a bit (~1 minute) and everything was activated.

     

    I hope this works well for anybody who has the same problem as I had (and was VERY disturbing).

  • chrisfromkeswick Calculating status...
    Currently Being Moderated
    Apr 2, 2012 4:37 AM (in response to seq2)

    seq2 wrote:

     

    I have a solution to all of you who faced this problem of waiting for activations for both FaceTime and iMessage.

    Here's how I did mine;

     

    For "FaceTime"

     

    1) Launch "Settings" app

    2) Select "FaceTime"

    3) Select "Apple ID: (your ID)"

    4) Select "Change Location" (to where "Country" your phone number is registered)

    5) Select the "Country" you are in

    6) Back to "Settings"

     

    Do the same for "iMessage"

     

    1) Launch "Settings" app

    2) Select "Messages"

    3) Select "Receive At"

    4) Select "Apple ID: (your ID)"

    5) Select "Change Location" (to where "Country" your phone number is registered)

    6) Select the "Country" you are in

    7) Exit

     

    After you've done all the settings as aboves; Now hold down the "Home" and "Power" button until you see the "Apple" logo to reboot your iPhone. Let go you fingers after seeing the "Apple" logo appears.

     

    Go back to the "Settings" app.

     

    For "Facetime"

     

    1) Select "FaceTime"

    2) You'll notice your "FaceTime" has been activated

    3) Go to the bottom and Select "Caller ID"

    4) You should have your "Phone Number" selected

    5) Back to "Settings"

     

    For "iMessage"

     

    1) Select "Messages"

    2) You'll notice your "iMessage" has been activated

    3) Select "Receive At" (now you'll see "2 Addresses >)

    4) Go to the bottom and Select "Caller ID"

    5) You should have your "Phone Number" selected

    6) Exit and enjoy your iOS5

     

    Hope that helps. Cheers!

     

     

    This worked for me. Only took 2 minutes! Thanks very much. Located in the UK on T-Mobile

  • peterbata Calculating status...
    Currently Being Moderated
    Dec 15, 2012 4:42 PM (in response to InfamousOne)

    Hi there.

     

    Not that this is any consolation, but I too am with chatr wireless and am having the same problem. What really bothers me is that 1) it was working for a short while then stopped 2) I called chatr today and was told that it had nothing to do with them. This is an iPhone 4 that I received from my daugther who upgraded to the new iPhone 5.

     

    She is with Fido and never had issues with iMessage. So, I know for sure that it is not the phone. Found out that Walmart is selling the chatr iPhone Micro Sim. Been about a week. Full sized chatr sim = 10.00 - chatr Micro sim 20.00. Highway robbery. Pay more for less material. Go figure.

     

     

    I still think that my iMessage problem is related to chatr.

     

    Let me know if you find a solution. Good luck. Peter

Actions

More Like This

  • Retrieving data ...

Bookmarked By (4)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.