Previous 1 2 3 4 Next 48 Replies Latest reply: Jul 15, 2014 6:02 PM by MarvelGrl313
InfamousOne Level 1 Level 1 (25 points)

Hey, I upgraded to iOS 5 and my iMessage refuses to activate by number...

 

It activates if I sign in with my Apple ID, and use my email, but it won't activate by number like I want it to..

 

Restrictions are off, and iCloud is on.

 

Anyone having this same problem, or know any solutions?

 

Thanks.


iPhone 3GS, iOS 5
  • Abbas Sarfaraz Khan Level 1 Level 1 (15 points)

    I am in the same boat. I have an apple unlocked 3GS and I have been waiting for iMessage activation for a few hours now. I tried another e mail address but I get an error message that it is already in use!!!!!! Not sure what is going on. I guess it's a waiting game as the apple servers might be overloaded?!

  • Rexeany Level 1 Level 1 (0 points)

    Same problem for me!!

    I've tried everything.

     

    I restored my devices (iPhone 4 and iPhone 3GS) many times.

    I used my previous backup, but I tried also a fresh new installation as new phone, I tried in more of one computer, I tried to use Wi-Fi, I tried without Wi-Fi ... I tried everything ...  anyway no luck. FaceTime and iMessage send the SMS to activate the services ... but on "Settings" for both of them writes "Waiting for activation" and they don't work.

     

    In fact they work but only with the mail ... If I send a message or a Facetime call to mail everything works, if I use my phone number doesn't work.

    Some of my friends updated yesterday and they didn't have problem with activation for FaceTime or iMessage ... they can use everything with their phone number.

     

    Please help!

     

    Any way to manually activate Facetime or iMessage?

  • erikagm Level 1 Level 1 (5 points)

    I found the following answer on another board, and it FINALLY worked!!!

     

    Try this :


    1. Go to the Settings App.

    2. Tap on Wi-Fi

    3. Your chosen network will be ticked. Tap on its white arrow over a blue circle button to its right

    4. Tap on DNS

    5. Replace the current information with 8.8.8.8,8.8.4.4

    6. Try visiting a website with Safari to see if this works

    7. Try registering iMessage / FaceTime

  • Roberto Avanzi Level 1 Level 1 (20 points)

    It did not work. It showed activation at the beginning. And after a while it stated again it was awaiting activation.

  • seq2 Level 1 Level 1 (0 points)

    I have a solution to all of you who faced this problem of waiting for activations for both FaceTime and iMessage.

    Here's how I did mine;

     

    For "FaceTime"

     

    1) Launch "Settings" app

    2) Select "FaceTime"

    3) Select "Apple ID: (your ID)"

    4) Select "Change Location" (to where "Country" your phone number is registered)

    5) Select the "Country" you are in

    6) Back to "Settings"

     

    Do the same for "iMessage"

     

    1) Launch "Settings" app

    2) Select "Messages"

    3) Select "Receive At"

    4) Select "Apple ID: (your ID)"

    5) Select "Change Location" (to where "Country" your phone number is registered)

    6) Select the "Country" you are in

    7) Exit

     

    After you've done all the settings as aboves; Now hold down the "Home" and "Power" button until you see the "Apple" logo to reboot your iPhone. Let go you fingers after seeing the "Apple" logo appears.

     

    Go back to the "Settings" app.

     

    For "Facetime"

     

    1) Select "FaceTime"

    2) You'll notice your "FaceTime" has been activated

    3) Go to the bottom and Select "Caller ID"

    4) You should have your "Phone Number" selected

    5) Back to "Settings"

     

    For "iMessage"

     

    1) Select "Messages"

    2) You'll notice your "iMessage" has been activated

    3) Select "Receive At" (now you'll see "2 Addresses >)

    4) Go to the bottom and Select "Caller ID"

    5) You should have your "Phone Number" selected

    6) Exit and enjoy your iOS5

     

    Hope that helps. Cheers!

  • Abhinav26 Level 1 Level 1 (0 points)

    iMessage still says activation unsuccessful

  • deggie Level 9 Level 9 (50,805 points)

    Where are you located?

  • InfamousOne Level 1 Level 1 (25 points)

    Didn't work for me either, I'm located in Canada.

     

    Basically, when I activate iMessage it says waiting for activation, and it ultimately fails but I can still edit recieve at and use an email address, but it will not activate by my number, which I want it to.

     

    Anyone figure out a solution to this, or call Apple and Apple acknowleged it?

  • Abhinav26 Level 1 Level 1 (0 points)

    India!

  • deggie Level 9 Level 9 (50,805 points)

    If it is not with an authorized Apple carrier it will probably be the problem. If this is with an authorized carrier you might want to contact them and have them check your text provisioning.

  • rcvelasquez Level 1 Level 1 (0 points)

    hey guys any news from apple regarding our iMessage problem world wide?????? Its getting worst all my friends now are experiencing same problems as ours.

  • rcvelasquez Level 1 Level 1 (0 points)

    any words from apple? any offcial statement will do ????

  • Sadbouy Level 1 Level 1 (0 points)

    Deactivate all restrictions from your settings. iMessage will start working.

  • Abhinav26 Level 1 Level 1 (0 points)

    Tried that!
    anything else?

Previous 1 2 3 4 Next