7 Replies Latest reply: Oct 26, 2011 1:44 AM by HardCharger
BornSaint Level 1 Level 1 (0 points)

How do you set up iMessage to work simultaneously on your iPad and iPhone?


iPad 2, iOS 5
  • ShadyMac Level 4 Level 4 (1,250 points)

    So are you having issues or just don't know where to start for setup?

     

    Without knowing that... The simple answer is that you need to have iOS 5 running on both iPad and iPhone. Then sign into iMessage using the exact same credentials and accompanying email for both devices.

     

    Then as a side note... I had issues getting iPad and iPhone to actually sync up when sending test iMessages to my wife who also has iOS 5 on her iPhone.

     

    Whether it was coincidence or not the trick that made it all work was going into both iPhones mine and hers and in the iMessage settings you'll see a field that says caller ID. I changed this option and selected the email address for both iPhones and only after that Sid I get joy.

    Not sure what that option is and it does NOT make her iPhone pulse an email address to other people she texts...

     

    Strange but that worked for me.

  • RAT_DOG Level 1 Level 1 (5 points)

    I sort of had the same question.. When having a conversation via iMessage, can I get the entire conversation to be shared and appear on both iPad and iPhone simutaniously with the same apple I'd? In other words, I received an iMessage on my iPhone but it didn't show up on my iPad.. I was able to contact that person fron iPad but it didn't show conversation from iPhone, or visa-versa from iPad message to iPhone.

  • stuartjohnwood Level 1 Level 1 (0 points)

    Same issue here.  iMessage sent from iPhone to iPhone address doesn't show up on ipad.  Responding to an iMessage from iPad displays as a seperate conersation on the reciving iPhone.

  • BornSaint Level 1 Level 1 (0 points)

    Thanks shadymac, but I had both iPhone and iPad set to my email address and it didn't work. What I had to do was reset my iPhone a couple of times and it finally started working.

  • BornSaint Level 1 Level 1 (0 points)

    Same here, I found having them both logged in to the same apple I'd wasn't enough. You have to change the caller ID on your iPhone and try resetting them both. That worked for me.

     

    Hope that helps.

  • stuartjohnwood Level 1 Level 1 (0 points)

    Reset all settings?

     

    I've tried Resetting the network setting but that had no effect.

  • HardCharger Level 1 Level 1 (0 points)

    I'm having the same issues, I thought that once an iMessage appears on your iPhone, it should also show up in you iPad and that you should see your "conversation" in both devices. This was not the case for me.

     

    I was wondering what was wrong and did a lot of irrelevant things. I use the same Apple ID for both devices and put in all the relevant email addresses where I can be reached. The only difference betweent the settings on both devices is that my iPhone has a mobile number (greyed out) while my iPad does not have this.

     

    I tried changing my Caller ID on the phone from my mobile number to the same email address used by my iPad but all that does is to port incoming messages to both devices provided the sender used your email address to send the message. Messages sent to your mobile number will appear only on your iPhone. In this set up, if I reply to a message, only the current device being used will show the reply. I thought you were supposed to see it synced and that you can switch between the two devices and still keep track of what's going on? What gives?

     

    Some of you mentioned Resetting the Phone, how does one do that? Is it the reset option found in the settings?

     

    This is the only thing that I haven't resolved with my transition but once this is all sorted out, I'm good to go. Helpful advice is welcome.

     

    Thanks in advance!