3 Replies Latest reply: Oct 24, 2011 9:09 PM by Kenneth Collins1
stellamaris5 Level 1 (95 points)

After setting up iCloud my 'Find My Mac' section keeps  staying greyed out and I can't tick the box to enable it. It says' Administrator Authorization Required'


It is not prompting me for an Administrator password.

iMac 27, Mac OS X (10.7), iPhone 3GS 16Gb iOS4, MBP 15" (mid 2010)
  • stevereed Level 1 (15 points)

    It seems the Find My Mac only work is your logged into an account with Administrator privileges.


    I've even added them to my son's account checked the box, rebooted, then took admin privileges away and the box unchecks itself.


    I don't quite undestand the logic of forcing peple to run as admin to use this feature. Hopefully they fix that.

  • aaxe Level 1 (10 points)

    Once it is enabled as the Administrator account, it will always reply.  I just tried it.


    1.  Accessed my iCloud account and viewed find my iPhone.  Only my iPhone showed up.

    2.  Signed off as my regular account, logon as Admin.

    3.  Go to System Preferences -> iCloud.  Find My Mac says it needs an update.  Download a 500MB update.

    4.  Enable and logged on as my iCloud account.

    5.  Logged out of Administrator and back into my regular account.

    6.  Went to iCloud.com and was able to see my laptop now.


    I repeated this for my other laptop, and it worked again.  This is extremely unintuitive, of course.

  • Kenneth Collins1 Level 1 (5 points)



    I tried to use this feature on two different Macs with disastrous results.


    On the first Mac, my account is an admin account. After setting up Find My Mac, the computer restarted, but it forgot all the account passwords. I was unable to log into any account. I restarted into the recovery partition, diddled around, restarted again, and somehow the passwords worked again. I'm not sure what I did to fix it, but I will definitely not try using Find My Mac ever again.


    On the second computer, my account is not an admin account. I set up Find My Mac in the admin account. After I remotely locked the computer, it would not restart again. I get the startup sound and a white screen, and that is it. The computer won't restart from a DVD or from the recovery partition, and there is no way to unlock it.


    I did this more or less at the same time, so I didn't have lessons learned from one Mac to apply to the other.


    I wanted to go to bed early tonight and now I'm trapped in this disaster of Microsoftian proportions. I'm sure this feature works for some people, but is it really worth the risk of finding out that it kills your Mac?