1 2 Previous Next 27 Replies Latest reply: Oct 17, 2012 5:37 AM by mabelt
Davvido Level 1 Level 1 (0 points)

Hello,

 

I use iCloud alias and I want my iPhone to use it as "From" address every time I compose a new mail. Is there a way to make it default?

 

Thanks in advance.

 

Dawid


iPhone 4, 16 GB
  • 1. Re: How to make iCloud alias behave like a default email
    pascalfromhamburg Level 1 Level 1 (0 points)

    i looking for a answer too ! pls help us someone :)

    best regards

  • 2. Re: How to make iCloud alias behave like a default email
    mdup01 Level 1 Level 1 (0 points)

    Alos looking for this.  Apple please fix this !!!

  • 3. Re: How to make iCloud alias behave like a default email
    emdur3 Level 1 Level 1 (0 points)

    Is there even a way to send from an alias in mail on the iPhone???

     

    I have been using my alias as my primary address for a couple of years, and it seems that I am now unable to send an email with my iphone using this alias... Am I the only one???

  • 4. Re: How to make iCloud alias behave like a default email
    Davvido Level 1 Level 1 (0 points)

    emdur3, just tap "From" and you will be able to choose an address.

  • 5. Re: How to make iCloud alias behave like a default email
    mdup01 Level 1 Level 1 (0 points)

    I know... I want the default to be assigned to my alias instead of my main @me.com email account.  I know I can manually change the email address it will be sent from when I compose and email but I need it to be used all the time (especially when the emails are sent automatically by my iphone - examples: when sending a contact card or a photo, you don't have the opportunity to change the email as no email windows pops up... the email is sent in the background using your main @me.com address.....  This can be changed on the online www.icloud.com mail application but only when you compose emails on the web interface.

  • 6. Re: How to make iCloud alias behave like a default email
    emdur3 Level 1 Level 1 (0 points)

    Thanks!!!

     

    I feel like a complete idiot... the fact is that I DID try this yesterday (as this was the way to do with mobile me) and my alias would not appear in the list...

     

    I just retried it, and now it is available..

     

    thanks again! I am looking forward to find how to set it by default, as it was possible with mobile me...

  • 7. Re: How to make iCloud alias behave like a default email
    dbehn Level 1 Level 1 (20 points)

    Use the OTHER option instead of iCloud or MobileMe. Use the alias as the email address.  Incoming mail server is mail.me.com. User name and password is your primary acct name. Outgoing server is smtp.mail.com.

     

    This will allow you to send mail from alias. You will continue to receive mail for all aliases and the primary.

  • 8. Re: How to make iCloud alias behave like a default email
    mdup01 Level 1 Level 1 (0 points)

    Thanks. Good workaround. I guess I should disable email under my iCloud account in order to avoid receiving double emails in my "All inbox". Too bad the push option won't be available.

  • 9. Re: How to make iCloud alias behave like a default email
    izzy35 Level 1 Level 1 (0 points)

    @Dbehn~~Thanks so much for that tip! Manually changing it for EVERY email was killing me!

     

    @mdup01~What do you mean it won't be push?? I just did the workaround and it seems to be pushing to my device. Maybe I don't understand what push is because I can do all that I was able to do when I was going directly through the icloud email account.

  • 10. Re: How to make iCloud alias behave like a default email
    izzy35 Level 1 Level 1 (0 points)

    I have a question. I now see that I'm getting duplicate emails from the account that I set up using the alias (it's obvious why it's happening), but if I shut off "mail" in order to stop this from happening, is there a way to continue to get mail from the other aliases??

  • 11. Re: How to make iCloud alias behave like a default email
    izzy35 Level 1 Level 1 (0 points)

    Sorry for all the questions but this is really bugging me and now I'm getting this message when using the alias that I set up the account for: "A copy has been placed in your Outbox. The sender address was rejected by the server"

     

    I turned off "mail" in the main iCloud account so that I don't keep getting duplicates to the phone. Any idea how to resolve this??

  • 12. Re: How to make iCloud alias behave like a default email
    aaanorton Level 1 Level 1 (0 points)
    What do you mean it won't be push?? I just did the workaround and it seems to be pushing to my device. Maybe I don't understand what push is because I can do all that I was able to do when I was going directly through the icloud email account.

     

    You likely have a Fetch interval enabled as well (Settings > Mail, Contacts, Calendars > Fetch New Data). So you're seeing your new mail, but it is being fetched instead of pushed. If you set the Fetch interval to Manually, you won't receive any email until you actually view your Inbox.

     

    @ izzy35

    You need to enter your main account identity in the IMAP and SMTP server settings. Using an alias in those fields will result in the error you're getting.

  • 13. Re: How to make iCloud alias behave like a default email
    EveryNameIsTaken Level 1 Level 1 (0 points)

    Did anyone have trouble with getting a message that the Username or Password for "mail.me.com" is incorrect?  I put in my primary email and password.  The one that I login to the regular site every day, but it will not go through.  Can't figure out what I'm doing different.  I'm really getting angry. 

  • 14. Re: How to make iCloud alias behave like a default email
    John French1 Level 1 Level 1 (5 points)

    This is an issue that has bothered MobileMe/iCloud users for too long. Please everyone go to www.apple.com/feedback/ and relay your concerns. If enough buzz is created they will work on the issue. I want my push back and not to get wrong name and password everything I check my ema from my iPhone! I want to use my iCloud alias as the default.

1 2 Previous Next