Previous 1 2 3 4 Next 47 Replies Latest reply: Aug 25, 2014 12:25 PM by MzLortta Go to original post
  • CoolDixon Level 1 Level 1

    This confirms my theory... It's Fusion 4.0.2 the one to blame!! (in combination with Dock)


    At least we know now how to solve it.

  • GuyHelmer Level 1 Level 1

    Reply to self ^2: Uninstalled and reinstalled VMware Fusion 4.0.2. Have been running Windows 7 under VMware for an hour this morning without Dock incidents. Hope the problem doesn't reappear.

  • Jim Meinen Level 1 Level 1

    I have the exact same problem high CPU utilization due to the Dock. Running VM Fusion 4.0.2. Installed Lion 10.7.2 and Dropbox two days ago. This is when the problem started. Have been running VM Fusion for sometime without the problem. Problem persists after quitting VM Fusion. However, the problem stopped after quitting Mail. I just restarted Mail and both VM Fusion and Dropbox running. 15 minutes and it has not returned... yet.

  • cconsite1 Level 1 Level 1

    Ok, forget off the console logs and what not. This is a bug in VMware Fusion. That is one. Two I posted this on the forum over there and I will repost it for for all of you. I use Windows 7 Professional in a VM that I must have for work so here you go:


    I am also having the same issue. Within an hour of starting a simple Windows 7 x64 VM - using 1 core and 2GB RAM - the processor usage and memory go through the ceiling on the Dock process. Literally using all available CPU processes and over 2-3GB of memory itself. This is not a usable or acceptable bug. I need to use Windows 7 for work and I cannot afford to spend time restarting things every 2 hours. It uses so many resources that time machine cannot back up and eventually the whole system becomes unusable - and not in the generlly thought of way but in th way I remember windows being when explorere and everything that goes with it was crashing. I have some theories and I am going to try to turn off the 3D aceleration and see if that makes a difference but I really hope this gets the attention of VMWare. I enjoy a lot of the feature the seperates Fusion from Parallels. I work in IT and need to be able to interchange and use different VM's on the fly before they go to our ESX server and/or other VMware workstation PC's. If it wasn't for that fact alone - I may very well already be downloading Parallels. I will update with how the 3D adjustment goes.



    UPDATE (over an hour later): After Shutting down the VM and going into the settings - to help you that dont know (Virtual Machine>Settings>Display) and turned off the 3D Acceleration (which I don't need for my work applications) the problem seems to have stopped. The dock is now not going over 32 MB of memory used and the CPU use is stable (generally arond 0.1% or lower) !!!!


    I hope VMWare fixes this soon, but for now this will be a decent workaround. Hope this helps more of you! I will repost this over at apple support.

  • cmeister Level 1 Level 1

    OK, I am still having the problem - worked fine all yesterday but Dock shot the CPU right up when I woke my MBP this morning. This is what I have done that HAS NOT worked:


    1. Disabled 3D Acceleration in side VM
    2. Deleted from \preferences under library and rebuilt dock
    3. Excluded my virtual machine file from spotlight searches


    Parallels had a similar problem a while ago. It appeared to be related to Dock not liking the Windows icons appearing in dock when in Parallels version of unity mode. Does anybody know how to prevent windows program icons from appearing in dock?

  • Jim Meinen Level 1 Level 1

    I am coming to the same conclusion. I suspect the Window's icons in the dock. This is what I tried this morning. I suspended VM Fusion. I removed the windows icons in the dock (right click, options, uncheck "keep in dock"). I then started VM Fusion in the single window mode. That way, it does not put any of the windows icons in the dock. The problem did not occur. After about an hour, I decided to see what happens when I switch to the Unity mode in VM Fusion (which puts the icons in the dock). Guess what... CPU shot up via the dock, as indicated in the activity monitor. mmm...?

  • cconsite1 Level 1 Level 1

    It is worth mentioning, I think, that in order for my fix to work you MUST shutdown the windows environment. not just SUSPEND but actually shutdown the VM.

  • CoolDixon Level 1 Level 1

       That's strange. I had no icons in the dock when the issue appeared, nor was ussing unity. Since I removed the VM folder from spotlight four days ago I havent suffered the problem again. By the way, cconsite1 explains the behavior exactly how I saw it, system became almost compleately unresponsible, 3.5 Gb ram consumed. The only contradiction is that I run Windows XP x86 ( 3D acceleration turned on). I did suspend it (and of course quit fusion compleately), then killed Dock and problem was gone.

  • 51HHMD Level 1 Level 1

    I've been struggling with this as well.  It seems to be linked to VMWare, and I've found it happens on both my Win 7 VM and my XP VM.  I have 3D Acceleration OFF but this still occurs.  I have deleted the,, and and it seems to solve the issue for a while, several hours in fact, but if I leave the VM running, it eventually comes back.


    I do NOT use Unity view either.


    2.4 Core 2 Duo White Macbook 4,1 Early 2008

    4G RAM

    256G SSD & 500G OptiBay HD

    OSX 10.7.2

    VMWare 4.0.2

  • USB_Connect Level 1 Level 1

    I posted in this thread earlier, but under a different user name.


    Update-- turned off 3D running in VM (V4.0.2) single window mode. After about 2 hours, fan is running and dock CPU at 150%.  Win 7, 2.66 2 Duo, 8 GB Ram. OSX 10.7.2. I just had my VM environment sitting idle I did not have any Windows application open.


    The folks at VMWare better get this fixed. The only solution I can think of now is to roll back to 3.X. At least that worked. Who says the early bird gets the worm?

  • oscheel Level 1 Level 1

    I had the same problem, but switching off 3D (and reboot anything) works for me. I have one VM with XP in full screen and simultaneously  one with W7 running in a window (separate screen). But I agree, VMWare should do further investigation.

  • oscheel Level 1 Level 1

    ...sorry: reboot everything... ;-)

  • GlennW Level 3 Level 3

    Folks, even if VMware is the trigger - and from other posts it is clear that it is not the only trigger - this is Apple's problem to solve because Dock is an Apple program. It needs to be robust in the face of apps that it launches failing.

  • USB_Connect Level 1 Level 1

    I have tried every remedy listed in the support forums to remedy the high cpu utilization apparently caused by Fusion to no avail. However, I did submit a support ticket to VMWare along with my log information. I will let the folks know if I receive any responses or updates.

  • USB_Connect Level 1 Level 1

    I received a response from VMWare. These suggestions are in another discussion group. I have tried teh steps to disable application sharing as well, but they did not fix the issue for me.  I also provided them a log.




    Thank you for contacting VMware Fusion Technical Support. My name is Ranjeet and I will be working with you on your Fusion technical query. As I understand, you're encountering an issue high CPU usage with your Dock process when a virtual machine is open.This is a known issue. It started happening recently with a few customers after the 10.7.2 update.It seems that the issue disappears if the Application sharing is disabled. Please follow these steps to do it:1) Shutdown any running VMs.2) Select Window > Virtual Machine Library from the top menu bar.3) Right click on a VM and select Settings4) Select "Applications Menu"5) Against "Show applications menu in menu bar", select Never6) Select show all7) Under "Default Applications", uncheck the 3 boxes8) Reboot the Mac see if the issue is still occurring.