Previous 1 2 3 4 Next 47 Replies Latest reply: Aug 25, 2014 12:25 PM by MzLortta Go to original post
  • jjshin Level 1 Level 1

    Looks like it's all kinds of crap.  VMware, dropbox, Outlook/Exchange and 1password seem to give it some issues.  It seems that anything that triggers the mds or has a database/indexing involved is freaking the crap out of the brave old cat - Lion...  native apple apps work ok but 3rd party is screwing the heck out of the Dock - hope there is a fix for this.  It seems very inconsistent as well.  My MacBook Pro does not have any of these Doc issues and it has the same programs as my Mac Pro which goes Doc crazy everyday.  i've reinstalled Lion fresh as well as with Snow Leopard but it seems to have the same issues.  I don't share apps in VMware or run 3d but still have high CPU. 

  • USB_Connect Level 1 Level 1

    I finally resolved  my issue with a two prong approach. Uninstalled VMWare and switched to Parallels. And spent 1.5 hours with Apple support changing file permissions and sharing. The file sharing and permissions may be a clue, but I am not an expert.  Good luck as this is a frustrating issue.

  • ereeves Level 1 Level 1

    Updating to the latest VMware fixes it by the way. At least if you're on Lion.

  • ereeves Level 1 Level 1

    Oh and dropbox can be a pain but if that happens, just use process monitor to kill it which resolve the overuse of cpu. Not ideal but VMware was really the real issue.

  • GuyHelmer Level 1 Level 1

    I'm running Fusion 4.1.1 and the problem still occurs.

  • sandyws2 Level 1 Level 1

    This is so frustrating.  I have been into the Apple store twice now.  All they can suggest is to not use Fusion.  This is not an acceptable solution for me as I need to be able to switch back and forth. 


    CPU is showing Doc low as 2 then spiking to 200 or better.  Applications are freezing up constantly (so much for being able to Multi-Task). 


    Apple suggested I get a cheap Acer to do my business work on! REALLY???

  • perkij Level 1 Level 1

    There is a fix for this that worked for me on Fusion 4.1.1:


    In Fusion:

    Go to <Virtual Machine><Settings><Default Applications> Uncheck all boxes.


    Go to <Virtual Machine><Settings><Applications Menu> set "Show applications in menu bar" to NEVER.


    Shutdown virtual machine.

    Restart virtual machine.


    If you want to try to reenable those features one at a time to find the problem one, you can try that.


    But this works for me.

  • orazzino Level 1 Level 1



    this post to let you know that no matter what, the problem comes from fusion (mine was 4.1.1 fully updated).


    I uninstalled it properly using appcleaner and rebooted the mac mini and dock is fine since then.


    I won't reinstll it because I have a MBP with parallels and I'm very satisfied whit it.

    I think vmware is a very good company for servers virtualisation but fusion is very bad vs parallels, sorry guys.


    That's it ! Good lock if you keep using fusion...

  • USB_Connect Level 1 Level 1

    Several weeks ago I also uninstalled VMware and switched to the latest version of Parallels. I am really glad I made the change. Not only did the problem go away, but I think Parallels is more stable and seems to agree with the Lion much better than VMware.

  • cmeister Level 1 Level 1

    After following this thread, I have to add my agreement that Parallels is the solution. I switched 4 months ago and the difference both in stability and functionality is night and day. For instance, all of the track pad gestures work in my windows programs - which wasn't the case with Fusion.


    Not to say that there aren't a few hiccups here and there with Parallels but it really is the superior product.

  • Macilias Level 1 Level 1

    This problem not only appears with VMware - it also comes each and every time during a maven build. Also git access startet to cause the problem. So there might be a connection to the Terminal App.

  • Macilias Level 1 Level 1

    Found the soulution to the maven build problem: just add your project folder to spotlights prive settings - so it want be scanned each time something changes

  • watski Level 1 Level 1

    I had the same problem with the Dock process running at 100%. In addition, it consumed memory like nothing I have ever seen. It would chew up 60GB of virtual memory in a matter of hours. Also, the Dock would be completely dead and cmd+tab did not work.


    I deleted ~/Library/Application Support/Dock/*.db and killed the Dock in Activity Viewer. Now it seems to behave.


    For the record I tried deleting the dock .plist, setting VMWare preferences and so on but in vein. Rebooting did not help either.


    If the Dock acts up on you, start Terminal and enter the following to see what the Dock is up to. The command will print the name of every file the Dock process accesses.


    sudo opensnoop -n Dock

    <type your password>


    In my case it was accessing a file in ~/Library/Application Support/Dock like crazy.

  • pixelcat3 Level 1 Level 1

    I think I found a potential issue..


    Dock maintains a couple of links to locations on disk (for example, /Users/username/Documents and /Users/username/Downloads) for quick access. It seems that certain applications which make changes to files in those locations cause the Dock's memory and CPU to peak while it tries to keep up.


    As an example, I had a VMWare guest stored in ~/Documents, and it would peg the CPU every time I ran a SOLR index. As soon as I removed the ~/Documents link from the Dock, the problem went away.


    For those using VMWare, I'd suggest either removing ~/Documents from Dock or moving your VMs to a directory that isn't indexed by the Dock.


    For those who aren't using VMWare, I guess it'll be an exercise to figure out which app (or apps) are writing to directories watched by Dock.  This script should do the trick to show you which processes are using Documents:


    for i in $(lsof -f | grep Documents | awk '{print $2}'); do ps aux | grep $i | grep -v grep ; done


    Hope this solves it for others.

  • seth204 Level 1 Level 1

    I was having this problem and deleting this db file just worked for me. Mine was not related to VM ware but to recently getting a new computer and doing a restore from Time Capsule.