Previous 1 2 3 4 Next 47 Replies Latest reply: Aug 25, 2014 12:25 PM by MzLortta Go to original post
  • Mark Thacker Level 1 Level 1 (0 points)

    This turned out to be the solution for me.

    For me, the Dock app was looking for a DefaultDesktop.jpg file and coulnd't find it. Chewed up to 75% CPU trying to locate it.

     

    Thanks for your handy tip, I was able to see what the Doc was looking for.

     

    To fix, for me, was to go into the System Preferences, launch the Desktop preferences and simply pick an image (any image) for the Desktop.

    Then, went into the Monitor application and did a Quit on the Dock app.

    Doc restarted and is back down to using ZERO % CPU.

    All fixed now.

     

    BTW : This particular system doesn't have Parallels or Fusion installed - so I knew those weren't the issue. Issuing the opensnoop command really helped!

  • pedrevans Level 1 Level 1 (0 points)

    I tried deactiving Dropbox, Google Drive, Evernote, Bluetooth, it all didn't help. I don't have VMware or Parallels.

     

    But deleting the db file ~/Library/Application Support/Dock/*.db seems to have worked for me too.

  • J.Kubi Level 1 Level 1 (0 points)

    Same basic solution here, but mine was just in an OU in AD which set a default desktop, which for some reason the Mac was refusing to access the share it was stored.

  • MzLortta Level 1 Level 1 (0 points)

    Update. Using 10.7.2 ….  I've done everything suggested in this and other posts about the dock using too much memory.  Deleting the plist, etc. worked twice, but periodically the dock ***** memory like crazy and the fan goes crazy.  Whats working since is then is to repair permissions and either logout or reboot.  Has worked every time so far after a month or so.

Previous 1 2 3 4 Next