Previous 1 2 3 Next 100 Replies Latest reply: Oct 9, 2013 11:24 AM by vinautomatic
zerohorn Level 1 (0 points)

After upgrading multiple iPhone 4 (CDMA versions) to IOS 5.0, I have not been able to get them to connect to our WPA/WPA2 Enterprise wirless network.  We use a Cisco Wireless LAN Controller.  The wireless network is capable of doing WPA or WPA2 Enterprise with PEAP.  These phones all connected to this network fine before the upgrade.


When connecteding to the network, it prompts me for the username and password and when I tap join it sits for about 10-15 seconds then says "Unable to join the network" with a Dismiss button.


It connects to non-Enterprise networks just fine.  I have tested it on WPA Personal and WPA2 Personal networks and it has worked on several without issue.


I have tried "forget this network" with no success.


Is anyone else having this problem?  I know of at least three Verizon iPhone 4's that have this exact same problem.  I haven't seen one working with this configuration yet.

iPhone 4, iOS 5
  • WillGonz Level 1 (0 points)

    Me too similar problem.  We can connect via LEAP and provide AD credentials. Works fine for a while but when the device locks and asks for a PIN or Password to unlock users are prompted for the WEP password.  It is like it isn't caching passwords correctly.

  • Bchow05 Level 1 (0 points)

    I have the exact same issue as WillGonz.  Apple need to address this issue as it is very annoying.  I need to create the profile manually every time I need to access the wifi..!

  • Alaine89 Level 1 (0 points)

    Users at my work are having the exact same issue after updating to iOS5.


    We use both WPA Enterprise, TKIP, PEAP for G networks and WPA2 Enterprise, AES, PEAP for N networks.


    I've tested on my first gen iPad and iPhone 4, and any other staff who have upgraded have the same issue. All connected fine prior to the upgrade.


    My iPhone 4 and iPad both still work perfectly at home using WPA2 Personal.


    Anyone have any ideas?


    -- Oh, still have the same issue when manually adding the profile

  • krzysztoffrompodkarpackie Level 1 (0 points)

    I have the same problem:


    Cisco WLC's -> WPA2 Enterprise AES + EAP-PEAP 802.1x with CCKM

    Pre 5.0 - all worked fine

    Post 5.0 - it tries to connect and after few moments i get error - couldn't connect.


    Info from controller:

    10/17/2011 12:16:37 CEST           INFO           172.16.16.X           Sending EAP request to client from radius server. 6.f. ..l

    10/17/2011 12:16:38 CEST           ERROR           172.16.16.X           Retransmitting EAP-ID request to client,retransmission timer expired. 5.y. ..l

    10/17/2011 12:16:39 CEST           ERROR           172.16.16.X           Retransmitting EAP-ID request to client,retransmission timer expired. 5.y. ..l

    10/17/2011 12:16:40 CEST           ERROR           172.16.16.X           Authentication failed for client as EAP ID request from AP reached maxmium retransmissions. 5.yp ..l

    10/17/2011 12:16:40 CEST           ERROR           172.16.16.X           De-authentication sent to client. 5.oP ..l

    10/17/2011 12:16:40 CEST           ERROR           172.16.16.X           5.yp ..l

    10/17/2011 12:16:40 CEST           ERROR           172.16.16.X           EAPOL-key is invalid, scheduling client for deletion. 5.yp ..l


    On the Radius server i don't see any activity regarding this device.


    I had this network configured on my iPhone - after upgrade and restore it remembered it. Every time i was in vicinity of my Enterprise WLAN it tried to connect - resulting int express battery drain - 6-7 hrs and battery was empty from 100%

  • stanlyliusu Level 1 (0 points)

    That is a bug. Hope Apple will release a hotfix ASAP!!!!!

  • peterfrombuggenhout Level 1 (0 points)

    The problem is only related to Cisco and iphone/ipad with IOS5. As we have also a trapeze network and there we don't have the problem.

  • zerohorn Level 1 (0 points)

    I'm glad I'm not the only one.  Does anyone know what we need to do to file bug with Apple?

  • stanlyliusu Level 1 (0 points)

    So have Apple already known this bug? When will they release the fix?

  • mrtechnical Level 1 (0 points)

    Funny thing with my Iphone 4 and 4s is that i am not having this issue with my Iphone 4 which is upgraded to IOS 5, but i am having this issue with the 4s out the box.  Makes me wonder if this is IOS 5 ralated or 4s related.

  • kramed Level 1 (0 points)

    I also am experiencing this issue. Would like to know if there is a solution available.

  • shannonfromshasta lake Level 1 (0 points)

    Same problem here. My 4 upgraded to ios5 worked on Friday at work as WPA Enterprise connection. Came in today with my new phone and it logs on but loses it's connection everytime the phone goes to sleep. I have to set up the connection from scratch every time. It's definitely the phone and not the ios. I can't believe this was not discovered before.

  • Alaine89 Level 1 (0 points)

    It looks like we are all having a similar problem - Except -


    The issues we are having ARE iOS5 specific, as there were no issues what so ever prior to upgrading, and we have now tested in the iPad, the iPad2, iPhone 3gs and iPhone 4. It is only when using 802.1x Authentication. We created a separate SSID for testing purposes with Open Authentication and had no problems. Also had no problems using WPA or WPA2 PSK authentication.


    After upgrade, if previously connected, the phone must retain the Wireless Certificate as they keep trying to connect to the wireless and sometimes look like they have connected (when in 'settings' rather than stating 'not connected' next to Wi-Fi is states the SSID of our network), yet if you try to do anything to use it, or even click on Wi-Fi to show surrounding networks it 'drops out'.


    This results in seriously poor battery life as it is constantly trying to connect. The phones also get quite warm due to the constant interaction with the Access Point. Once you choose 'forget network' the certificate is gone, so the phones stop trying to constantly connect. This means battery life etc. is back to normal. When attempting to re-connect we get 'Unable to join the network "Network SSID".


    I have not reported this bug to Apple, also not sure whether anyone else has (not too sure how, will look into it) but a bit of Google searching pointed me to this thread, and also another one on a separate website. Hopefully something comes up.

  • shannonfromshasta lake Level 1 (0 points)

    But my network connection was fine on my iphone 4 after upgrading to ios5. It wasn't until I tried with my 4s that I had this problem. Seems to differ to everyone.

  • zerohorn Level 1 (0 points)

    Alaine89, you are spot on with your description of the problem.  This is exactly the same problem we are having, you just explained it with much better detail than I did. Have you had any luck finding a way to report a bug without having a developer account?  From what I found it looks like need a developer account to report bugs.  I agree this is definately an IOS 5 bug rather than a device specific bug.


    Hopefully IOS 5.0.1 is right around the corner with a fix for this. 

Previous 1 2 3 Next