Previous 1 2 3 4 Next 100 Replies Latest reply: Oct 9, 2013 11:24 AM by vinautomatic Go to original post
  • JS Connelly Level 1 (0 points)

    My issue is with my iPhone 4s on ios5 connecting to our wpa2 enterprise.  I'm able to connect but if the phone sleeps and loses the connection, it prompts for a password.  Any password I try is incorrect.  I have to "forget network" and set it up again each time.

     

    My iPad and iPod Touch both running ios5 have no issues.

  • WillGonz Level 1 (0 points)

    I have submitted a bug report.

  • WillGonz Level 1 (0 points)

    All how do setup the Wireless on your iPhone?  Do you use a config file or do you setup manually?

  • shannonfromshasta lake Level 1 (0 points)

    I set it up manuall as Other/ WPA Enterprise.

  • WillGonz Level 1 (0 points)

    I have been doing tests.  Try using the iPhone Configuration Utility the latest version. Create a WiFi Profile using WEP Enterprise instead of WPA2 and see if it lets you connect using PEAP or LEAP.

  • Alaine89 Level 1 (0 points)

    Hi All,

    I have worked out a fix to our specific problem down here on our network. So far 3 x iPhone 4's with iOS5 are up and running on our wireless network - Without needing to change any settings on the RADIUS server / Network security.

     

    Hopefully this helps someone else who has been having trouble in this thread.

     

    I decided to download and use the iPhone configuration utility (which I previously did not know existed ), where I created a new 'Configuration Profile'.

     

    First I named this profile and filled out the General tab. Next under Credentials I then added the certificate(s) needed for our Wireless Authentication. Then under Wi-Fi  I added our specific network information including the SSID, Security Type (WPA / WPA 2 Enterprise), Accepted EAP types (which for us was purely PEAP). The 'Authentication' tab I entered the users' credentials. The 'Trust' tab I ticked the Trusted Certificates I added under the credentials tab. I also clicked the + under 'Trusted Server Certificate Names' which added 'Trusted Server Common Name' to the box. I have yet to see if this is required. 'Allow Trust Exceptions' is ticked.

     

    I then clicked 'Configuration Profiles' under the iPhone I had connected and clicked 'Install'. Nothing will happen on the computer - The installation has moved to the iPhone interface. Accept the 'Profile', and any certificates that require accepting. Next I went to Wireless, tapped onto the SSID (because I'm impatient, it probably would have connected itself), and it connected!!

     

    Unfortunately this does require connecting each iPhone to the computer which didn't need doing previously, but at least it works! One major thing that needs to be remembered is to change the authentication username & password in the profile for each iPhone set up.

     

    Why did this happen? I only have my assumptions after reading the release notes and a few articles. But imagine it is to do with the enhanced security on iOS5 regarding certificates.

     

    I apologise that this post is a bit of a jumble, and I do hope this does help someone else out there!

     

    Alaine

  • WillGonz Level 1 (0 points)

    You can export the mobileconfig file and email it to your users.  The mail application on your iOS devices will know that it is a Configuration Profile and prompt to install it after the user clicks on the attachment in an email.

  • Alaine89 Level 1 (0 points)

    That's great, thank you WillGonz - I just tested and it worked perfectly.

  • stanlyliusu Level 1 (0 points)

    Great! So Have Apple give you a reply? When will they fix this? That's really an annoying bug!

  • JoshFechtUHS Level 1 (0 points)

    We here at UHS are also experiencing this exact same issue with devices that upgraded to iOS 5

  • sandun Level 1 (0 points)

    @shannonfromshata lake and @mrtechnical:

     

    I am having the same issue as you. iOS5 + 4S does not work. iOS5+ 3GS/Ipad2 works.  Here is the related thread I started:

     

    https://discussions.apple.com/message/16441828

     


  • WillGonz Level 1 (0 points)

    Our problem is different because we are using Enterprise services like PEAP, LEAP, Radius,etc.  We get a connection at first and it works but when the iOS 5 device is in a sleep state or when you reconnect to the wireless it fails to reconnect without authenticating again.

  • JS Connelly Level 1 (0 points)

    @WillGonz

     

    This is exactly our issue except that iPad 2 and iPod Touch running iOS5 work fine.  It's just the iPhone 4S giving me problems.  I have no idea how to make certs and dread calling our IT dept.  They have very little experience with Apple products.

     

    ETA:  When the iPhone tries to authenticate after losing the connection, it asks for a password not a username and password as is required by WPA2 Ent.  Also, on first successful connections, the certificate I accept shows as not verified.

  • krzysztoffrompodkarpackie Level 1 (0 points)

    I had problem with both iPhone 4 and iPad 2 running iOS5 - i created configuration using iPhone Configuration Utility and then sent resulting file to my mail account - importing it on both devices resulted in working WiFi connection with our Enterprise WIFI.

     

    Thanks for this workaround Alaine89.

     

    Still - it's a bug that needs quick fix from apple.

     

    Chris

  • WillGonz Level 1 (0 points)

    @JS Connelly

     

    The reason it is failing to work correctly is because the old iPhone configuration utility didn't have a WEP Enterprise Option.  So everyone created a WPA2 Enterprise and added LEAP,PEAP, or certificates.  If you are using any 802.11x standards and you are using WEP and LEAP or PEAP or anything like that then in order for it to work correctly a new configuration profile should be created using WEP Enterprise.

     

    Let's say you bought a new iPhone 4S.  You used an older iPhone as your restore data, well the old iOS profile settings are going onto your new device and they aren't working correctly.

Previous 1 2 3 4 Next