Previous 1 3 4 5 6 7 Next 100 Replies Latest reply: Oct 9, 2013 11:24 AM by vinautomatic Go to original post
  • DarthHack Level 1 Level 1

    What you are saying is interesting as I have done all of my testing from either and iPhone 4 or an iPhone 4S.  I guess what I take away from your posting is that some of the code for accessing Wi-Fi may be separate for each device type in iOS and that the code for the iPhone 4 and iPhone 4S doesn't behave as well as that for the iPad 2.


    I have never used an iPad on my network before, but I assume that you must also configure it in the same way as an iPhone (i.e.: via the "Other..." menu).


    BTW, the network configuration that you are describing is 802.1x WEP not WPA2 Enterprise even though you have to manually connect to your network via the "Other..." menu using WPA2 Enterprise (or possibly WPA Enterprise).  This is a real hack on Apple's part.  I only found out about this hack years ago from a coworker who told me that it worked for them.  My assumption at that time was that iOS worked like every other OS that I knew and it didn't support 802.1x WEP because there was no menu item that allowed you to configure it.  I'm sure this violates the WPA standard in some way.  It may be that Apple seems to be dropping support for 802.1x WEP because it is truly just a hack on iOS.

  • Stuke00 Level 1 Level 1

    I am afraid that it works because it was working before the iOS update.  I haven't heard of anyone with an iPhone 4 having issues.  I am afraid to delete the connection on my ipad and recreate it in fear that it will have the same problem.

  • shannonfromshasta lake Level 1 Level 1

    I mentioned this from the very beginning, even though others insist it is an ios5 problem. I upgraded to ios5 on my iphone 4 and had no problem with my wpa wireless connection at work. I got my new 4s and have not been able to STAY connected since. It connects and then drops every time the phone goes to sleep. I have to set it up new each time, which has gotten to be more trouble than it's worth even though it eats up my data plan.


    I have always bragged that Apple did not roll out untested garbage like Microsoft. I hope this isn't a new trend. I did send in an iPhone bug report on this so we'll see. I was disappointed it was not fixed with this new seems like a pretty big deal to me but whatever....

  • DarthHack Level 1 Level 1

    Now you have heard of someone whose iPhone 4 (not 4S) stopped working when I upgraded to 5.  I then bought an iPhone 4S 2 weeks later and it was having the same problem.

  • DarthHack Level 1 Level 1

    Shannon, I would question whether your old phone had been connected to the network using different settings.  Perhaps you had selected WPA2 Enterprise instead of WPA Enterprise, when you setup the 4S (or vice versa).  I can tell you that my iPhone 4 stopped working when I upgraded to 5 and my 4S never worked, at least until I changed our access points from 802.1x WEP to WPA Enterprise.  Now it works like a charm and I don't have to use the "Other..." menu to manually setup the connection.


    Sorry about your trouble, but I would test the other enterprise configuration to make sure this isn't your problem.  If you have been using WPA2 Ent. then try WPA Ent. next time you need to connect (or vice versa).

  • DVT70 Level 1 Level 1

    Same problem here (k12 school district). I resolved the issue by exporting the cert from the RADIUS server and emailing it to the users running iOS5. They access their email (obviously from some other wireless network) and install the cert. After that they can succesfully authenticate to the network again.


    Now I just have to find a more efficient way to distibute the cert



  • wmorrison Level 1 Level 1

    I'm glad you were able to get your devices working that way. I'm still having issues with up/down singals on all our iOS5 devices (iPhone and iPad). The devices will connect but each time a new web page is opened the signal drops and reconnects or even when idle it will go up/down every minute or so.


    As for distributing certs it can be done if you are using a windows server setup as a certificate authority server. I'm using Windows Server 2008R2 configured as NPS and Cert Authority and each user gets prompted to accept the certificate when they first connect using their device.

  • dgrabo Level 1 Level 1

    This configuration was similar to ours...


    interface Dot11Radio0

    encryption mode ciphers tkip



    Enabling aes fixed it for us.


    int Dot11Radio0

      encryption mode ciphers tkip aes-ccm

  • wmorrison Level 1 Level 1

    I was able to work out a fix for my particular situation today. I have been experiencing up/down connectivity with all of our iOS5 devices on the corporate network.


    Windows Server 2008R2 configured as Network Policy Server Radius and Certificate Authority

    SHA-1 signed certificates with RSA encryption


    Cisco E4200 Wireless Access Points configured as bridge

    Guest Account turned on

    WPA2 Enterprise


    The Cisco E4200 routers we use have dual band so they broadcast with 2.4 and 5 GHz frequencies. I had to set the authentication mode to WPA2 Enterprise Mode on the 2.4 GHz band and disabled the 5 GHz band completely. When I tried to use only 5 GHz band, it seemed to work for iOS5 but other devices had connectivity issues. The 2.4 GHz band was the most stable for all devices.

  • uncas_ripley Level 1 Level 1

    Same problem here.


    IOS 5.0.1 on iPhone 4.


    Prior to upgrade to IOS 5, my wifi connection at work was rock solid. We use WPA2 Enterprise security.


    After upgrade, I can connect to WiFI by selecting "Other" type network, and entering all the details maually.  However, as soon as the phone goes to sleep, I loose the internent connection and cannot cannot reconnect.


    I keep getting promted for password.  Even if I type the correct password, same problem.

  • deanfromwallingford Level 1 Level 1

    doesnt fix it

  • Not an iPhan Level 1 Level 1

    Same issue, with a slight work around.



    We have plenty of other devices with no issues connecting and maintaning the connections. (WinXP, Win7, WinEmbedded, CE, WinMob, and Android) We already have between 60 and 80 iPads deployed and leveraging Citrix Receiver. We currently do not allow the users to sync with iTunes, thankfully. Since we are still technically in a "deployment" stage we can work throu some things. Eventually all physicians will have an iPad, way too many devices to have to touch with no real enterprise type support.


    We have 4 different SSIDs.

    1. Open (guest)

    2. Cisco LEAP (wpa/wpa2 Ent)

    3. WPA2 AES (different SSID for IP segment seperation)

    4. WPA2 AES (different SSID for IP segment seperation)


    All worked in iOS4, did not matter if it was iPhone, iPad, or iPod touch.


    Enter the iPhone 4S.... and iPad and iPad2 with new iOS 5.0.1 update epic wifi fail.

    (we have no older iPhone or iPod devices any longer)

    1. The Open guest network obviously still connects and stays.

    2. The LEAP is spotty, fails to connect several times and then will finally connect.

    3. Will not connect when entered into device and settings for SSID will vanish off device. Previously always worked with no issues on iOS4.

    4. Will connect, but the setting will vanish off device after a period of time.


    The only work around for SSID 2 and 3 was using the iPhone Config Utility.

    The random connection issues are still there (may fail to reconnect/reauthent several times and then connect), but the SSID settings will not vanish as they are delivered via the config profile. It is still annoying as we cannot use a config profile for personal devices.

  • Not an iPhan Level 1 Level 1



    Also, for Cisco controllers.

    There are a few setting for the Wireless profiles that are specific to the cisco client and can wreak havok with 3rd party wireless clients (such as atheros, intel, and iOS) We have checked ours, but the above seems to be what works the best thus far.

  • mheidem Level 1 Level 1

    Alaine, this is great information and it worked completely. A couple of notes... My Corporate Helpdesk was not willing to help or change any server configurations. It appears that they have added support for iPads and those devices don't seem to have problems, but they have not done anything special for iPhone access. It does seem that this "broke" with IOS 5 as mine had worked for several years previously. The triggering event however, seems to have been a mandatory password reset and at that time, the authentication failed as described throughout the thread, and required a complete rebuild every time the connection timed out.

    I also asked our Helpdesk for the names of the certificates used by the Radius server and was told that they had not implemented certificates. I built the profile according to your description and I chose a Cisco root certificate and a couple of others that seemed likely, but I don't think they were even used. Everything else was set up as you described except that I chose the LEAP and PEAP protocols and all of the possible EAP options.

    I added the profile and it looks like it accepted and installed a signed certificate presumably from the server. The first time I connected, I did have to click on the ssid in the wifi settings but it did not prompt for a password and it connected. It has since re-connected after leaving the building and returning. I also powered off the device (iPhone 4) and turned it back on and at first it didn't find any ssid's, so it didn't connect. I had to toggle wifi on and off and then it got the ssid list and did autoconnect, so I think it may have been an antenae problem or other hiccup.

    This solution is somewhat cumbersome for multiple users and I don't think most IT staffs would encourage users to download the Configuration Utility and build their own profiles, but I am happy with the solution and can share with others who are interested. Hopefully, Apple will fix this as everything does suggest this is an authentication failure on the IOS side and not specifically due to server configurations.


  • khylebrahh7 Level 1 Level 1

    heeyy there


    im having a similar issue with my iphone 3g[s].   it conects to the WiFi but wont conect to the internet with WPA2  i had no problem with WPA or WEP but i dont want to lower my network security as wep is to vonerable and WPA dosnt want to work on my pc.

    what do i do ????


    and also for people having trouble conecting with the credentials   just try to make sure the first leter isnt capitalised when typing in the pass and username as ios 5.0.x does this :/


    hope i helped a bit thanks

Previous 1 3 4 5 6 7 Next