Previous 1 2 Next 20 Replies Latest reply: Aug 19, 2013 4:49 PM by CaptainPerk
vnizzz Level 1 Level 1 (0 points)

Hi. I have MBP (2006) with broken ethernet port but working wifi. I never woried about it cause I've used wireless everywhere.I had the interface "Ethernet" in the list of interfaces for years but MBP has not seen any cable plugged into it.

But after update to 10.7.x (I didn't really noticed when it had happened) ethernet interface has been missed from the list of interfaces. And at the same time AppStore stoped to work with my apple id with the message "Your device or computer could not be verified. Contact support for assistance". And now after starting iCloud services it doesn't work too: "This Apple ID is valid but is not an iCloud account"

My apple id is ok, I've checked it 4 times, everything is verified, I can buy applications and music at iTunes Music Store, authorize and deauthorize computers use it for iMessage on my iPad etc. iCloud works too on my iPad and at the website icloud.com — I can sync everything, backup to iCloud etc. But neither purchases at AppStore nor iCloud features works on my MacBook Pro.

I think its some eth0/eth1 related things, cause most of solutions for broken Apple ID on Macs are: "Remove /Library/Preferences/SystemConfigurations/* then reboot". I did it thosands of times but nothing happens. I tried to reset SMC but it doesn't work too — ethernet interface is still missing, AppStore and iCloud give me strange error messages and doesn't work.


MacBook Pro, Mac OS X (10.7.2)
  • vnizzz Level 1 Level 1 (0 points)

    ok, as I found guys with Hackintoshs (hacked Mac OS X on PCs) has the same issues. But problems they has are EFI-emulator related ones. So I think it could be EFI related problem in my case too.

     

    < Edited By Host >

  • mrsheps Level 1 Level 1 (5 points)

    Hey vnizzz

     

    I have exactly the same problem as you ever since update to 10.6.8 into now Lion 10.7.2.

     

    Check my screen shots here >

     

    I've even gone as far as spoofing the MAC address of the USB Ethernet adapter i have bought to the original MAC address of the broken ethernet port - still iCloud, Face TIme and AppStore is not working.

  • jimjamyaha-uk Level 1 Level 1 (0 points)

    I'm in the same boat:

     

    I have a 2006 vintage MacMini Core2Duo which has been upgraded to Lion.

     

    Basically I cannot access the AppStore or iCloud due to the fact the the built-in ethernet port is dead and it seems that both these services use the ID of this to authenticate against.

     

    This also affected the AppStore in Snow Leopard.

     

    James.

  • Alan Cook2 Level 3 Level 3 (885 points)

    I guess I'm in the same boat. I just upgraded my Mac Pro to Lion so I could use iCloud, but find that it doesn't work because the original ethernet ports are dead and I'm using a PCI card for ethernet connection.

     

    It seems grossly unfair. I've been using Macs since 1985, have paid $99/year for MobileMe for years, and now that iCloud is finally free I'm locked out. I love Apple but I'm feeling pretty frustrated right now.

     

    Does anyone know if there is any hack to make this work?

  • Sjazbec Level 4 Level 4 (1,670 points)

    as I already told you in the other thread that you opened for no reasons :

     

    to you and the others here once again :

     

    No you can't use Lions AppStore,facetime or iCloud with defect logicboards. The authentification is bound to your very unique hardware UUID, the Ethernet's MAC adress being one critical part of it. A replacement will not work those issues out, and a PCI card will also fail, because the auth.agent service looks for BUILT-IN ethernet ports.

     

    Apple Logic boards tell their numbers,versions and hardware part IDs on each boot to the kernel of OSX, so there is no way of "spoofing" these numbers. The moment you log-in the first time into Facetime,icloud and Appstore this data is transmitted to Apple. If the data is not reporting in its whole because strings are missing - like when hardware is broken there is a missing string then - all and every login attempt will fail.

     

    And this can only be cured if you have your Logicboards repaired with official Apple parts. Only this way the missing numbers can be restored when booting into OS X.

     

    And for those that say that the dead ethernet in Snow was uncritical : the numbers in Snow used to calculate the Hashes were using a different method.

     

    The one and only models that are free from this hassle are the Macbook Airs, as these don't have ethernet-ports.

  • Alan Cook2 Level 3 Level 3 (885 points)

    You say that this can only be fixed if a person uses official Apple parts, but if that is the case, why am I finding posts on numerous internet messages boards and forums by people who have "hackintosh" machines (non-Apple computers running Lion) that are able to use iCloud and App Store just fine? That is why I came to the discussion boards here. If hackintosh computers can use iCloud, it only seems reasonable to me that there must be a way for a genuine Apple computer to do so, even without an ethernet port on the logic board.

  • jimjamyaha-uk Level 1 Level 1 (0 points)

    Thanks Sjazbec for your input and clearer statement of how the authentication uses kernel-reported elements of  hardware IDs to validate your Apple account.

     

    However, perhaps you could tone-down your approach - you are coming over as arrogant and pushy.  People are here for help, or to give help.  People have different levels of knowledge and also just because you know the intractate details this doesn't mean that others do not also know, or that there is one answer.

     

    As Alan points out there are tools available on the Hackintosh scene that allow all sorts of kernel-reported information to be spoofed, and therefore allow access to iCould, AppStore etc.

     

    I am currently working on getting one of these tools to fool the kernel into reporting the defunct mac address, which will be on any machine's label (along with the serial number, specs, etc).  This could be through EFI scripts, or by passing different variables to the kernel at boot-time.

     

    Another avenue is to re-generate the information now missing in the networkinterfaces.plist and preferences.plist files from /Library/Preferences/SystemConfiguration/ to reflect a working ethernet port - as certainly in my case this information has disappeared.

     

    Apple have also posted: http://support.apple.com/kb/TS3925.

  • Alan Cook2 Level 3 Level 3 (885 points)

    Sjazbec, do you happen to know if the iTunes store uses this same kind of authentication?

     

    I was on with iCloud support for about 90 minutes yesterday. The person I talked to was a "specialist" but was not aware that built-in ethernet was being used as an authentication method. She placed my account into troubleshooting mode, issued me a temporary password, and said that Apple engineers would be looking into the problem and get back with me.

     

    jimjamyaha-uk, I've done a lot of research over the last couple of days and one conclusion is that none of the tools that the Hackintosh community uses to make the OS think there is a built-in ethernet interface will work with a real Mac. The hackintoshes us a bootloader called Chameleon which can do all kinds of tricks, but you can't run Chameleon on a real Mac.

  • Alan Cook2 Level 3 Level 3 (885 points)

    Answered my own question regarding iTunes. I just successfully deauthorized my computer on iTunes and then authorized it. So iTunes is NOT using this new method of authentication.

     

    So what is iTunes using for authentication? My Mac's serial number?

  • Matthew Weinreb Level 1 Level 1 (0 points)

    Hi there Jim,

    did you manage to resolve this issue? I have exactly the same on a MacPro.. onboard ethernet was grilled by a very distant lightening strike. Apple told me to fit a third party card and the problem would resolve.. Well of course I have ethernet again but no access to the app store..

    If you have found a spoofing method I would be most grateful for it.. thanks so much

  • jimjamyaha-uk Level 1 Level 1 (0 points)

    Hi,

     

    No luck with spoofing methods yet.  I think the reality is that either Apple will have to change their processess to account for faulty ethernet ports or we'll have to get them fixed.

     

    Will keep trying, though.

  • jimjamyaha-uk Level 1 Level 1 (0 points)

    It might just simply be using your username and password to log-in and authenticate.  I think any DRM'd music you may have is identifiable by your e-mail address/appleID embedded within the music file.

  • not-a-happy-mac Level 1 Level 1 (0 points)

    Just wanted to add to your post that I am also having problems with this. My ethernet card is broken and I have not used it in several years. I really don't care about the App store (even though I was going to spend money there) but I really needed the iCloud. I have a paid family mobleme account that I transfered to icloud. I did this because I installed ios 5.0 on my iphone and figured I can make the switch (even though I will loose iDisk). Well, I lost more than just my iDisk. Now I can't sync my callener, I can't use my .me email in mac mail, I can't use facetime.

     

    Thanks for nothing apple.

  • jimjamyaha-uk Level 1 Level 1 (0 points)

    Right - I have tried booting the MacMini using Chameleon.  Using these instructions: http://forum.netkas.org/index.php/topic,1123.0.html it boots.

    Basically, Chameleon can be made to work if you re-format your HD to use a MBR boot sector.  Even the latest Chamelon (Chameleon_2.1svn_r1686_trunk_pkg) can be made to work by using a minimal org.chameleon.Boot config (i.e. not the one it installs by default - use the one in the first link/post as a basis).  You can also use Champlist to control your installation settings.

     

    This enables me to change the model number, serial number, bios/efi version etc reported by the system - and you can also do this by manually editing the smbios.plist file

     

    After booting I added relevant information into the settings to simulate a built-in ethernet port, after matching the specific settings for my macmini - but no luck.

     

    I also booted it as a MacBook Air to see if this would negate the need for an inbuilt ethernet port - however no luck either.

     

    Authentication failed in the same way. 

     

    Either the information reported by Apple System Profiler, and changed by Chamelon,  is surface-level and the 'true' information is still being read by the authentication process or there is something amiss with my 'hackintosh' settings.

     

    I have a few more things to try including:

     

    • Booting using Chamelon and then deleting network prefs and seeing if this resets the authentication process on the next boot
    • Reverting the MacMini to stock macmini1,1 firmware. (Has been updated to macmini2,1 using method at: http://forum.netkas.org/index.php/topic,874.0.html)
Previous 1 2 Next