5 Replies Latest reply: Mar 8, 2012 2:40 AM by Luiscpc
nmurray93 Level 1 Level 1 (5 points)

Please help . . Evry time i try to open the app store or itunes app on my ipad it opens but never displays anything its as if it just keeps loading but nothings happening, i already upgraded and restored my ipad twice as a new ipad but still the same problem . . ideas anybody??


iPad 2, iOS 5
  • 1. Re: Cant connect to app store or itunes on my ipad2
    Demo Level 9 Level 9 (76,345 points)

    Close the apps completely. From the home screen - double-click the home button to bring up the taskbar, then press and hold any of the apps on the taskbar for a couple of seconds or so until they start shaking, then press the minus sign () in the top left of any apps that you want to close, and touch any part of the screen above the taskbar so as to stop the shaking and close the taskbar.

     

    If that doesn't work - then reset the iPad.  Hold down on the sleep and home buttons at the same time for about 10 to 15 seconds (ignore the red slider), after which the Apple logo should appear - let go of the buttons and let the iPad restart.

  • 2. Re: Cant connect to app store or itunes on my ipad2
    nmurray93 Level 1 Level 1 (5 points)

    Thanks for the quick reply . . I've already reset it fully and still have the same problem and also already tried closing all apps before opening them but still no luck . . I also add that safari works fine so it's not my wifi

  • 3. Re: Cant connect to app store or itunes on my ipad2
    Demo Level 9 Level 9 (76,345 points)

    Maybe you could try downloading any app on your computer and then sync it to the iPad. Any free app will do. If you try this, I would sync it to the iPad by using the cable and not wirelessly. I know that sometimes downloading an app can reset things, but you can't open the App Store on the iPad and that is why I'm suggesting doing it on the computer and then sync it.

     

    The other thing that you could try is to tap on either icon to launch the app, and if it appears to open but not load anything, tap the home button and go back to the home screen, then double tap the home button to get to the task bar and then tap on the icon in the task bar and see if the content loads.

     

    Another thought, tap on all of the tabs at the bottom of the apps and see if you can get the content to load that way.

  • 4. Re: Cant connect to app store or itunes on my ipad2
    nmurray93 Level 1 Level 1 (5 points)

    Ok I tried downloading a free app and syncing it with the cable . . Unfortunately still no look , I can't get it load no matter what I try , I noticed other discussions about the same problem so I gues it's a bug I'll just have to wait for an update hopefully it comes soon . . Thanks again

  • 5. Re: Cant connect to app store or itunes on my ipad2
    Luiscpc Level 1 Level 1 (0 points)

    Hi nmurray93,

     

    I've just bought an ipad2 and I'm having the same problem you've mentioned in this post, can't connect with appsotre or itunes, my wifi looks fine since I'm using safari and accessing websites normallly. My guess is that there is something with my id or any firewall preventing me to get connect with appstore. How did you solve this issue? Your help will be appreciated, thankk you. Luiscpc