8 Replies Latest reply: Jun 22, 2012 4:32 PM by TJ the PK
Lazykins Level 1 (0 points)

Hi. I receive an error 11821 when attempting to convert my videos to iPod format. I sent one to a friend who converted on his Mac. I couldn't find an explanation for 11821, does anyone know of a fix? I went through the troubleshooting in apple support and was able to convert the sample qt movie, no problem. None of my movies will convert, though. They are all located on the same drive as the iTunes software. I don't believe there is a permissions issue but Windows permissions are so confusing now. Both iTunes and qt have been updated. Thanks for any insight you might offer.

Windows 7
  • Willis Ellison Level 1 (10 points)

    did you ever get a response on this? i'm having the same issues. i have uninstalled and reinstalled QT and iTunes, no help.

  • Lazykins Level 1 (0 points)

    Nope, I never did. Uninstalled and reinstalled, based on something I read here.


    I played with the permissions issue a little more but even when running as administrator, I get the error.


    My guess is that we don't have the right codecs on our computers and they don't come with QuickTime or iTunes. My next step was going to be to find and install the latest codecs manually.


    I ended up sending the files to a friend with a Mac, who converted them for me.

  • TJ the PK Level 1 (0 points)

    I'm having this too! I didn't have it all the other times I've converted movies, but I'm getting it today. Is it due to an update? That's all I can figure. I'm really sick of all the continued problems with iTunes! I wish there were something non-Mac that I could use instead. Most of the problems I have don't ever get answered properly here. Usually I get a "simple, standard" answer that tells me to do what I already stated I had tried. *sigh*

  • namaribara Level 1 (0 points)

    I'm having the same problem on my Mac...  I'm not sure if you'll be able to do this on a PC, but have you tried opening the file in QuickTime (I think you need the Pro version) then going to File > Export and choosing iPod?  Hope it works for you - good luck.  Annoying that it won't work from inside iTunes though: definitely does not do what it says on the tin!

  • Lazykins Level 1 (0 points)

    Nope, I don't have QT Pro. I saw a post somewhere in here from someone who had upgraded to QT Pro to defeat a conversion error but still got the error, so I was afraid to buy it. It was more economical to send them to a friend, especially since I only needed a handful of videos converted.


    Interesting that TJ only began experiencing the error after an update (Apple update, I am guessing?).


    If you are still following this post, how old are your videos and are they all from the same source? Mine are about 5 years old and are all from a Kodak Easyshare digital camera. Newer videos taken with my phone converted without an error. Just wondering, trying to make sense of it.


    Incidentally, I can't convert ANY videos to iPad format. Even the ones that did successfully convert to iPod format.

  • JessMore Level 1 (0 points)

    I'm having the same problem.  It just started today, AFTER I upgraded to MAC's new operating system.  I was able to convert no problem before hand (just a little slow), so I thought upgrading would help speed along the process... now the process doesn't work at all.


    All of my videos are recent -- range from one week ago to about 1.5 years ago.  All from the same source -- a Kodak's pocket video recorder.

  • 2Hearts Level 1 (0 points)

    I encounter the same problem recently when trying to convert a video clip from my camera to my ipod. I tried uninstalling and reinstalling itunes, still didnt help. What I did notice was I was still able to convert clips from my old camera, I had downloaded a program called Any Video Converter. It was free and I havent had any issues with it. From this program I converted my clip ot mp4 and was able to put on my ipod with no problems. Hope this helps.

  • TJ the PK Level 1 (0 points)

    I can now convert movies that I took with my iPod, but I still can't convert anything taken with my Kodak Easyshare camera (MOV files) - not even recent ones. And "naturally", since I can't convert them, I can't upload them to my iPod, even though they're in my iTunes library. So much for buying a camera that's "Apple friendly"! Sure do wish my iTunes would be Apple friendly!