Previous 1 2 3 Next 228 Replies Latest reply: Dec 20, 2015 8:25 PM by Kya18
epfenn29 Level 1 Level 1

I'm having similar problems with my iMessage update under iOS 5.  When I send text messages to other iPhone users, it appears as iMessage and from my email address rather than my phone number.  I went into Settings > Messages > Receive At, but there's no option to add my phone number.  It keeps showing my Apple Account, which I registered under for iMessage and iCloud with my email address.  It only allows me to add another email address.  From what I can tell, non-iPhone users are still receiving my text messages from my number like regular.  If I turn iMessage OFF, I'm sending regular text messages to all users.  Anyone have a fix yet?  I'm wondering if this was an Apple goof that won't be resolved until the next iPhone update. 


iPhone 4, iOS 5
Reply by epfenn29 on Oct 14, 2011 7:08 AM Helpful

Wait...I think I figured it out.  When you click Receive At, click Apple ID and Sign Out.  Once you've signed out, the Receive At turns to "Use your Apple ID for iMessage."  I think that fixes things!

Reply by Castans on Oct 14, 2011 11:26 AM Helpful

Turn iMessenger off then back on, works

Reply by frankfrommadera on Apr 25, 2012 7:34 PM Helpful

So here's the über answer for all this nonsense that is Apple iMessage

 

 

When you sign into iMessage (on an iphone) using your apple ID. It does 2 things.

 

It not only registers your phone number as an iMessage device but also the email address as well.

 

Good? Ok. 

 

So under Settings>Messages>Receive At

You should have your phone # AND your Apple ID email.   These are all of the address (so far) that iMessage will use as your device address (so to speak). So if your friend, neighbor, boyfriend, cousin, baby-mama or whoever uses an iDevice to send a message to this address "ding" you get a message. 

 

Settings>Messages>Receive At>Caller ID

Is where when you send an I message to an iDevice and they dont yet have you programmed into their phone as a contact THIS WILL BE YOUR CALLER ID. so change it accordingly. iPhone users will probably want to make this their phone number.  Other iDevice users will have a choice between different emails not a number if it's a pod or pad or Mac.

 

If you send an iMessage to a non iPhone iDevice your email will be used as caller ID instead (because they dont have a wireless number associated)

 

IF YOU LOSE DATA SERVICE EVERY NOW AND THEN, THEN THIS PART WILL MAKE LOTS OF SENSE

 

If you originally start an iMessage using an iPhone users email and not phone number, then for whatever reason if you don't have data at the time of your message it will send it as an email NOT A TEXT. It does not revert back to their default number even if it's stored into your contacts.

So if you are in the mountains or under a bridge and you have crap for service aka no data only cellular and you send an iMessage it will go to that persons email address that you originally used to start the conversation from something like 5595551234@mms.att.net NOT THEIR WIRELESS NUMBER AND WILL NOT SHOW UP IN IMESSAGE.

 

It's dumb but I figured it out this while AppleCare was scratching their head last night.

 

Settings>Messages>Send As SMS

This is the exact opposite of the conundrum from above and is more straight forward. If you don't have data when you send a message to an iMessage users phone number then it will send as a text message and cost u money if it isn't unlimited or whatever. So unclick if you are a text fiend with a low text plan.

 

hope that covers 99% of the questions about iMessage. 

 

GOOD LUCK!

All replies

Previous 1 2 3 Next