1 3 4 5 6 7 Previous Next 104 Replies Latest reply: Nov 22, 2013 11:14 AM by therealObiWan Go to original post
  • 75. Re: Problem with safari's cache in ios 5
    jpozuk Level 1 Level 1 (50 points)

    Reinstalling one of the myriad of solutions offered, that work for a short time then fail. 

     

    All I can say is if you are not on ios 5, you were wise.

  • 76. Re: Problem with safari's cache in ios 5
    Marcusj0015 Level 1 Level 1 (5 points)

    I found the solution to ALL iOS 5.x devices, go to Settings > Safari > and disable "Private Browsing"

     

     

    Note that Safari will go back to iOS 4.x blue, and more importantly, will fix the cookie and history issues we've been expierencing!!!

     

     

    I recomend backing up with iTunes or preferably iCloud, so when you need to Restore, or Update, you'll get your settings back.

  • 77. Re: Problem with safari's cache in ios 5
    Skaelight Level 1 Level 1 (0 points)

    I wish that was the case for me but on my iPad 1 (with iOS 5.x) I have never has private browsing enabled and the issue persists. Perhaps the technique works for later model iPads, here's hoping. I am keeping my fingers crossed for an eventual patch, in the mean time, I never use the back button now.

  • 78. Re: Problem with safari's cache in ios 5
    aesculus Level 1 Level 1 (0 points)

    Sorry but that does not work. If you load a web page where the author has changed the content (js, css or even images) Safari still caches it until it feel's differently regardless of the Private Browser setting.

     

    I have had some success with shutting down Safari for some content, but things like changed css generally don't get picked up doing this.

     

    Note this is with iPhone 4 and iPad 2 running 5.01

  • 79. Re: Problem with safari's cache in ios 5
    Fucho Level 1 Level 1 (0 points)

    Thanks. I did the same. The problen has dissappeared, for now at least!

  • 80. Re: Problem with safari's cache in ios 5
    Matthijs Strating Level 1 Level 1 (5 points)

    I'm also having this problem, I can't believe there's still no fix!

  • 81. Re: Problem with safari's cache in ios 5
    mike_gh Level 1 Level 1 (0 points)

    I am wondering if they finally fixed this bug?

    I just upgraded my iPad 2 to 5.1 and did not even surf yet.

    Wish me luck.

  • 82. Re: Problem with safari's cache in ios 5
    Skaelight Level 1 Level 1 (0 points)

    I've upgraded my iPad 1 to iOS 5.1 and the signs are promising that this has been resolved; but time will tell.

  • 83. Re: Problem with safari's cache in ios 5
    cittagocara Level 1 Level 1 (0 points)

    I bought the new iPad 3 yesterday to test my new web application and experienced the same bug. After playing around with the safari settings and clearing the cache multiple times without any effect, I think the problem could have something to do with the iCloud BackUp Service. Perhaps it prevents Safari to rewrite the browser cache...? A little trick helped me to get around this issue:

     

    1) Close all running web apps / safari.

    2) Clear cache and history

    3) Set the date manually to one month in the future.

    4) Switch of iCloud backup.

    5) Start Safari and reload your page and close it afterwards.

    6) Reset the date to correct date.

    7) Switch on iCloud backup again.

     

    After this everything works - in my case with iPad 3 and the latest version of iOS. I uploaded some changes to my server and Safari seems to do the caching now correctly. I don't have the time to figure out which of the steps above did the job. But the problem seems to remain solved. Perhaps this might be useful to some other people here.

  • 84. Re: Problem with safari's cache in ios 5
    jpozuk Level 1 Level 1 (50 points)

    Even ipad 3 is failing, that is scary.  Step 2 provides a temporary solution.  Would appreciate hearing if the issue returns.

  • 85. Re: Problem with safari's cache in ios 5
    Kayjey Level 1 Level 1 (0 points)

    Since the upgrade to 5.1 I haven't had the problem anymore. Doesn't mean it's solved - time will tell - but before the upgrade I had the problem on a daily basis, numerous times. Fact is (I found) you could actually 'feel' by the reaction time that it was taking it out of old cache without even comparing to the latest version, while at this moment I feel it actually thinks for just a fraction of a second and then decides to reload the page.

     

    For me - and as for now - 5.1 has fixed it... for me. It's been working well ever since I installed (I believe a week ago or so?).

  • 86. Re: Problem with safari's cache in ios 5
    MadDog956 Level 1 Level 1 (0 points)

    That's encouraging news. I've also upgraded to 5.1 but have been out of Wifi range and haven't had a chance to try it yet, so at least now I have a reason to be hopeful!

     

    Thanks for the feedback!

  • 87. Re: Problem with safari's cache in ios 5
    mike_gh Level 1 Level 1 (0 points)

    After the upgrade done on Mar, 10th, I have not faced this problem anymore.

    Hope the bug is solved.

  • 88. Re: Problem with safari's cache in ios 5
    Fucho Level 1 Level 1 (0 points)

    Upgrading to 5.1 solved my problem.

  • 89. Re: Problem with safari's cache in ios 5
    aesculus Level 1 Level 1 (0 points)

    I can confirm that its still not fully fixed in iOS 5.1.  Here is my scenario:

     

    Update some javascript code on the server and then reaccess the bookmark for a webapp bookmarked on the home screen on an iPhone 4.  The device will still use the javascript that was cached from an earlier time.  Same with CSS file updates.  iOS 5.1 still decides when it wants to refresh cashed content.

     

    Add to that iOS 5.1 now has a bigger problem.  It throws away HTML5 local storage randomly.

     

    See this post

    https://discussions.apple.com/message/17933100#17933100

1 3 4 5 6 7 Previous Next