8 Replies Latest reply: Dec 15, 2011 9:45 AM by kyriakos1988
zotteke Level 1 Level 1 (0 points)

I'm currently experiencing issues when trying to access iCloud Mail which is visible in two places:

 

  - on a iOS device (iPad and iPhone): when opening Mail.app and trying to check my iCloud Inbox:

      "Cannot Get Mail" "The user name or password for 'iCloud' is incorrect."

   - on http://www.icloud.com: when clicking the Mail icon:

     "Cannot Load Mail" "Help Apple improve iCloud by reporting this problem." [Reload] [Report to Apple] [Close Mail]

 

Oddly enough synching Contacts and Calendar items works fine on the iOS device (so username and password are obviously correct), and logging onto http://www.icloud.com using these credentials with use of all other application icons (Contacts, Calendar, Find my iPhone) seems to work also.

 

I created a "free" me.com account to enable "Find my iPhone" when iOS 4 was released (which doesn't include mail), and already had a Apple ID. Presumably these got merged now, maybe contributing to the issue?

 

iCloud is only available to me through the web or my iOS devices, I currently don't have Lion installed.

 

Suggestions?


iCloud, iOS 5
  • Bob Simpson 18 Level 1 Level 1 (0 points)

    I am in the exact same boat:

     

    • I was a MobileMe subsciber who migrated to iCloud
    • MobileMe ID was name@me.com; Apple ID name@gmail.com
    • All iCloud services work as intended EXCEPT mail

     

    I can access iCloud Mail by:

    • Mail.app in Lion

     

    When I access my iCloud mail on my iOS devices, I get "The user name or password for 'iCloud' is incorrect."  I know for a fact the password is correct, and all other services work.

     

    When I access iCloud online, again all services EXCEPT mail work.  Here, I get the "Cannot Load Mail." message

     

    Has anyone resolved this; or is this an Apple issue?  This is driving me crazy.

    Screen Shot 2011-10-14 at 10-14-11 - 5.17.55 PM .png

    Screen Shot 2011-10-14 at 10-14-11 - 5.20.18 PM .png

  • marcofromcolloredo Level 1 Level 1 (0 points)

    I did this:

     

    Disable "Mail" and "Notes" in your iCloud settings. (We are replacing these two functions with our manual account)

    Go to Settings > Mail, Contacts, Calendars > Add Account... > Other > Add Mail Account

    Fill in your name, Address (@me.com), password (for the iCloud mail account) and description.

    Under IMAP tab, fill in the following:

    Incoming Mail Server

    Host Name: p04-imap.mail.me.com

    User name: ("abc" if your email address is abc@me.com)

     

    Outgoing Mail Server

     

    Host Name: smtp.me.com

    User Name: (again, "abc" if your email address is abc@me.com)

    Password: (your email account password)

     

    Next then Save. If everything is done properly, you should have your emails coming in, and notes syncing with your Mac.

     

    If the incoming server host doesn't work for you, you can check the correct one in the Mail.app on your Mac, under "Preferences > Accounts".

     

    This is obviously a workaround and i guess will stop working sometime in the future.

    Seems clear the issue is about the username used.

  • macnolox Level 1 Level 1 (0 points)

    I have the same problem, but 1st day it worked all fine, until the 14th, then it was impossible send or receive any mail.

     

    This afternoon appeared a notification:

     

    MobileMail can't verify the identity of "p01-smtp.mail.me.com".

     

    FIndMyiPhone works right, and I can go into Mail at iCloud.com, but mail can't be send, and no new income.

    I've got a mail returned and it says that the domain is rejecting it because not a right user.

     

    I'ts a free me.com account.

     

    It's an iCloud internal problem.

  • macnolox Level 1 Level 1 (0 points)

    Well, I have just fixed it.

     

    As stated in point 10. of:

     

    http://support.apple.com/kb/TS4002

     

    I've just deleted the account, and set it up another time, and now all is right again.

     

    But I have been forced to change my password in accordance with the new template: at least 8 characters, at least one number, at least one uppercase letter and at least one lowercase...

  • hurlsp Level 1 Level 1 (0 points)

    I've done what macnolox suggests. Did not work for me, still cannot access icloud mail on either of my iOS 5 devices, nor from the web on any platform/browser combination you can think of.  Works fine from Mail app in lion, and all the other services work fine on my iOS devices.

     

    Now I'm stuck with a not-really-any-safer 8 character upper/lower case-letters and numbers password, and that annoying error message every few minutes!

  • jeremy158 Level 1 Level 1 (10 points)

    I experienced the same problem and was able to fix it with the help of senior tech advisor.

     

    https://discussions.apple.com/thread/3388288

  • darcyfromwinsted Level 1 Level 1 (0 points)

    That doesn't work. It won't let you do that. It says the account is not a mobile me account and that username is associated with an iCloud account. Apple effed up again. Not cool. Is this what we have to look forward too. Ow that Steve Jobs is gone? So not cool.

  • kyriakos1988 Level 1 Level 1 (0 points)

    found a solution that worked for me:

     

    1. delete your icloud mail account from your idevice.

    2. add a new mail account (choose "other").

    3. then fill in the details.. for the incoming & outgoing mail server use: http://support.apple.com/kb/HT4864

    4. remember to write your full email account as your username

    5. you might get some error for the outgoing server but never mind that for now.

    6. save your account and select it from the list inside the mail settings.

    7. go to "advanced" and make sure SSL is ON and the server port is 993 and authentification is set to password.

     

    that fixed it for me!