5 Replies Latest reply: Oct 14, 2011 10:17 AM by tool
tool Level 2 Level 2 (320 points)

I recently installed the lastest iTunes 10.5 for OS X 10.6.8. I don't quite have the guts to update to OS X Lion yet, i'm told from others that it's still pretty buggy, so i'm waiting until it gets up to at least 10.7.3 or later until they have some of these other bugs straightened out.

 

Anyways...i can't get the Wi-Fi sync to work on my iPhone 4. I have the latest Snow Leopard updates installed, iOS 5 on my iPhone 4, and it tells me that i have to be plugged in to power and connected to the same Wi-Fi network as the other in order for it to work....all in check, everything should work as advertised.

 

Is anyone else having issues with the Wi-Fi sync, or is it only a Lion specific thing that it will work? Thanks!

 

- Jason

  • igmackenzie Level 4 Level 4 (2,285 points)

    You don't have to be plugged in to sync OTA.  It will do it automatically when plugged in, but just select the device at any time in iTunes and click on Sync.  It'll do it.

    You do see your iOS devices in iTunes when they are unplugged, don't you?

  • tool Level 2 Level 2 (320 points)

    I do NOT see my iOS devices in iTunes when they are unplugged.

     

    On the iPhone - Settings>General>iTunes Wi-Fi Sync - the Sync Now button is gray.

     

    All i see is the following text:

     

    Automatically sync with iTunes on your computer when your iPhone is plugged in to power and connected to Wi-Fi.

     

    Sync will resume when my MacBook Pro is available.

     

    However, Both devices are set up to the same Wi-Fi Network, both devices have the latest software installed. OS X 10.6.8 for SL, iTunes 10.5, and an iPhone 4 with iOS 5.

     

    When i plugged it into the computer, the device showed up, and it synced. The "Sync Now" button then turned black and showed it as being connected at that point, but now it is unplugged again, and it is back to the gray button.

  • igmackenzie Level 4 Level 4 (2,285 points)

    Various people are having the same problem as you.

    I presume you are saying yes to 'accept incoming network connections' when prompted by iTunes?

    Sometimes, it seems to be a case of waiting some time for the device to appear.

  • Dan R16 Level 1 Level 1 (30 points)

    When you plug your iPhone into iTunes you need to select 'Sync over Wi-Fi' within the iTunes window

  • Jack Barry Level 1 Level 1 (0 points)

    I am having the same problem. 

  • tool Level 2 Level 2 (320 points)

    Wow thanks Dan! I totally should have found that on my own before i even posted this...but then again, Apple should have had this enabled by default too.

     

    - Jason