7 Replies Latest reply: Jan 3, 2012 4:00 PM by dcebik
ashleyaaron Level 1 Level 1 (0 points)

i just got the new iphone 4s. when i text people who have updated their phones, they say it come's from my email address. how do i make it come from only my phone number?


iPhone 4, iOS 5
  • grayalne Level 1 Level 1 (20 points)

    this is the way it is designed, it will default to iMessage if it can, hence you have and iMessage account and so does the recipient, it will send via iMessage.

     

    the only way around this it to turn off iMessage in the settings

  • AHal10 Level 1 Level 1 (0 points)

    grayalne wrote:

     

    this is the way it is designed, it will default to iMessage if it can, hence you have and iMessage account and so does the recipient, it will send via iMessage.

     

    the only way around this it to turn off iMessage in the settings

    This is incorrect.

     

    It's because he has iMessage set to send from his email address. On an iPhone, you can activate your phone number to be used with iMessage, so message will appear from your phone number.

     

    Simply set your iMessage "caller ID" to your phone number.

     

    Cheers

  • traceyfromoregon Level 1 Level 1 (0 points)

    How do I set my iMessage caller Id as my phone number? I don't have that option. It only shows my email address.

  • whee wah Level 1 Level 1 (15 points)

    Simply OFF and ON your Settings>Message>Imessage option.  Hope it works.

  • traceyfromoregon Level 1 Level 1 (0 points)

    Thank you!  It worked.

  • cheftony Level 1 Level 1 (5 points)

    I had this happen with my phone seding messages to my step son..after turning on imessage (we both have iphone 4)  he stopped getting my text...toggling imessage off fixed issue...his email wasn't even entered in his contact, very strange issue b/c I don't think it always did it, even after we updated our phones...

  • dcebik Level 1 Level 1 (0 points)

    The return/reply address can be easily configured on your iPhone to be your phone number or any email address that you have set to receive iMessages at.  Your iMessage email addresses are setup via SETTINGS ->  iMessage:

     

    To change the default from address (called id):  Go to SETTINGS -> iMessage - Caller ID:  From here you can select the email address or phone number that you would like to be the return address:  Normally just sent this as your Phone number.  (if your on an iPad or iTouch this will not be an option).   Normally you do want to also add all of your email addresses here so you can be found from users using iPads and iTouches without a phone number, but still keeping your phone number as the default.

     

    Remember the following:

    For messages to be sent as iMessage you must both have a data connection when you are composing the message (any data connection, WiFi,3G, Edge, etc).  The messaging App will alert you when your message will be sent as iMessage by displaying "iMessage" or "Text Message" in light grey in the backround of the box your typing in.  Also after your message is sent messages displayed in Blue were sent via iMessage and messages in Green were sent as text.

     

    Here is where confusion for some occurs:

     

    If your iMessage return address is an email address and you go offline (no data connection, phone off, etc.), then future messages (while you are offline), could be send to you as Text Messages (if the sending user), has Send as SMS enabled  (SETTINGS -> iMessage).  Remember texting to an email address is emailing via Texting.  So in this case going offline will have the unexpected conscequence of receiving these messages to your email address.     This situation can be avoided by 1) keeping your return address as a phone number above. 2) having the person who sent you the message turn off "SEND as SMS"   

     

    To avoid accidentially sending iMessages as texts (which could go to email), just disable "Send as SMS", under SETTINGS = iMessage.   This has no effect on texing people who do not have iMessage as those messages will always be sent as TEXT (in green).

     

    Hope this helps explain the workings of iMessage, and explain some of the sometime unexpected behaviour of iMessage.

     

    Doug