Previous 1 2 3 Next 109 Replies Latest reply: Jan 15, 2014 4:18 PM by Time Fades Away Branched to a new discussion.
Brian Christopher Level 1 Level 1 (0 points)

Just got an iPhone 4S today. Also switched from AT&T to Verizon. For some reason, I am only getting caller ID on contacts that have the country code added to their numbers. I turned off International Assist, and it didn't do anything. When I add the country code to the number in the Address Book, the caller ID works just fine.

 

Is there any way to fix this? Or is there any way to add all the country codes at once instead of doing it manually to 400+ phone numbers?

  • StevenHD Level 1 Level 1 (0 points)

    Having the same problem here. If I add "+1" to a phone number, it will show up in the caller ID. Otherwise the number is a 7-digit, unformatted string (ie. 4154445555) instead of a formatted number (415-444-5555). I am beginning to think this problem is widespread.

  • snoopygirl Level 1 Level 1 (0 points)

    Same problem here.  Also, if I try to enter a new phone number in contacts on the phone, it tries to format it as international number.  Looked for a setting to change, but couldn't find any.  Im wondering if this is something to do  with switching from ATT to Verizon???

  • Brian Christopher Level 1 Level 1 (0 points)

    I'm trying to add the country code to some contacts and for some contacts, it still doesn't reconize the caller.

  • epetti Level 1 Level 1 (15 points)

    Don't have an answer, but I am experiencing the same problem, and in the same set of experiences -- switching from AT&T to Verizon and bought iPhone 4S today.  It appears that somehow it thinks I'm not in the US or something, but my International->Region Formatting is set correctly.

  • cmungall Level 1 Level 1 (5 points)

    Same issue here. My wife and I both got new Verizon 4s's and all contacts are now formatted in the same way. Inserting the +1 in front of the phone number seems to fix the issue but that is a tedious solution. Anyone find an easy/elegant fix for this yet?

  • fszatko Level 1 Level 1 (0 points)

    same problem here for my phone and my wife's.  we both upgraded from AT&T 3GS to Verizon 4S.  All phone numbers in the iPhone are an unformatted string.  The same phone numbers in Outlook have retained their proper format.  The iPhone tries to put 2 digits in the parentheses only.  Very anxiously awaiting a fix for this one.

  • Fotografer Level 1 Level 1 (0 points)

    Same problem here. Unless I put a "+1" prefix on every single phone number, the format is "#######" instead of "###-###-####" as it should be. Seems that if you have the "+1" prefix on the phone number in your contacts list, the caller's/texter's name shows up for incoming calls, but not for texts. If you take the "+1" out, the name shows up for texts, but not for calls. Very frustrating. I also switched from AT&T to Verizon (woohoo! except for this issue).

  • markmoran Level 1 Level 1 (0 points)

    I did the same thing - switched from AT&T to Verizon with the iPhone 4S, and all of my caller IDs and thus SMS messages don't match contact names.

     

    Interestingly, calls from AT&T friends include the U.S. country code (presumably all GSM phones send international numbers), so they all look like +1 (415) 555-1212, meanwhile, calls from Verizon friends have the full 10-digit U.S. number with no formatting at all - i.e. 4155551212

     

    So even if I wrote an AppleScript to add a +1 to my 4,000 contacts in Address Book, that would only make the iPhone recognize them for the GSM users.  All of the Verizon and Sprint users would still not match since now the +1 would be throwing them off.

     

    Very curious how Apple can quickly fix this?

  • markmoran Level 1 Level 1 (0 points)

    I think the correct fix might be to add code on the iPhone so that it understands that American phone numbers sometimes include the +1 U.S. country code and sometimes don't, but to treat them as equivalent numbers either way.  Previous versions were all able to do this, although previous phones were always either CDMA or GSM, so maybe each phone just had to be aware of the other technology's format.  But now that the phone is a world phone with both radios, somehow this got left off. I wonder how this slipped through Beta testing?

     

    At the same time, it'd be nice if it applied consistent formatting when you say "Add Number to Existing Contact". Even on previous iPhones, if you just take an incoming number and add it to your address book, if it's from a GSM user, it includes the +1 and if not, it doesn't.

  • stephenpeterson Level 1 Level 1 (10 points)

    Just messaged with a friend who had the same problem. He reports: "Full delete and restore of software fixed all issues."

     

    Full details:

    I had the exact same issue. It's as if the regional setting isn't being effected. All my US numbers ended up as "4433482938", while if i did a "50" or other 2-digit codes, they would get the parens () around them. Seems to be a bug.

     

    I resolved the issue fully by attaching the phone to iTunes, and doing a restore. It wipes out all data & settings, so make sure you have a valid backup before you do it to import contacts / texts / etc.

     

    Once the restore was complete & settings applied, everything worked as expected.

     

    Note: previous texts sent during the "defective" mode of the phone will not show correct caller ID name even though the number matches your address book. Only future ones will.

     

    Message was edited by: stephenpeterson

  • msedward Level 1 Level 1 (0 points)

    I had the exact same issue. It's as if the regional setting isn't being effected. All my US numbers ended up as "4433482938", while if i did a "50" or other 2-digit codes, they would get the parens () around them. Seems to be a bug.

     

    I resolved the issue fully by attaching the phone to iTunes, and doing a restore. It wipes out all data & settings, so make sure you have a valid backup before you do it to import contacts / texts / etc.

     

    Once the restore was complete & settings applied, everything worked as expected.

     

    Note: previous texts sent during the "defective" mode of the phone will not show correct caller ID name even though the number matches your address book. Only future ones will.

     

    Hope this helps...

     

    matt

  • msedward Level 1 Level 1 (0 points)

    Also note, carriers send their numbers differently - some send with +1, some send as 1-xxx-xxxx, and some just show up as xxx-xxx-xxxx.

     

    I tried adding +1 - but it just ended in more frustration - as it was very inconsistent and simply didn't work.

     

    Do the restore from iTunes which re-installs iOS 5, and then apply data/settings from a backup (don't setup as new phone).

  • Brian Christopher Level 1 Level 1 (0 points)

    I backed up the phone, did a restore via iTunes, and it worked like a charm. Stinks that new Verizon users will have to do this extra step, but it beats manually adding "+1" to all your contacts.

  • cmungall Level 1 Level 1 (5 points)

    Thanks for the advice everyone. I won't be able to restore on the home computer until Sunday but I'm glad we seem to have a fix for this.

Previous 1 2 3 Next