Previous 1 2 3 4 Next 59 Replies Latest reply: Aug 7, 2012 1:44 PM by Terence Devlin
SFMacNewbie Level 1 Level 1 (10 points)

I've read a number of posts about the updated version of iPhoto crashing, but before I follow some suggestions (like uninstalling 3ivx) I'd like to be sure I'm in the same boat.

 

I'm totally current on Lion, iOS5, iPhoto, and everything else.  I'm awaiting my new iPhone 4S which should be delvered any moment.

 

I connected my iPhone 4 to sync, and there were two photos to import.  iPhoto seemed to open just fine after the update, said it needed to update the library, and all looked fine.

 

When I tried to import those two photos off the phone it crashed.  I sent the crash report to Apple, and tried again.  Same thing.  Tried once more, same thing.  Then I tried emailing the photos to myself and saving them to the desktop and importing them that way.  Again, a crash.

 

iPhoto did launch itself when I connected the iPhone 4.

 

What is the problem here, and will Apple likely release a fix for it.  I don't recall why I have 3ivx on my computer and if I'll miss it when it is gone but if not, I'm happy to uninstall it.  I'd rather not have to get into restoring my library from my last Time Machine backup (last night), or dumping iPhoto and having to reinstall it.  I'm not totally up on libraries and identities etc.

 

If you need the actual crash report I'm sure I can trigger another one and paste it in here.

  • Terence Devlin Level 10 Level 10 (131,445 points)

    As a Test:

     

     

    Hold down the option (or alt) key and launch iPhoto. From the resulting menu select 'Create Library'

     

     

    Import a few pics into this new, blank library. Is the Problem repeated there?

  • EagleDude Level 1 Level 1 (0 points)

    I'm having the exact same problem.  iphoto opens, shows all the iPhone photos and videos to import, then crashes as soon as I start the import. Happened over and over.

  • Kevin Guenther1 Level 1 Level 1 (5 points)

    I'm having the same problem, except I just upgraded my iPhoto from version 6.0 (always disliked iPhoto's file management but that's a different story).

     

    Anyway, I'm on a fresh install of Lion OS, have a brand new iPhone 4S on iOS 5 and any time I do anything that seems to tax the processor, iPhoto crashes. So in addition to the same issue everyone else is having while importing photos, iPhoto has crashed when I try to access my facebook account through the iPhoto interface, it crashed when I tried to add my Flickr account and it crashed when I looked at it wrong…

     

    I tried deleting the preferences, moving application support files and reciepts from the old install, then just unistalled iPhoto with Clean My Mac and reinstalled it from the App Store.

     

    I'm not going to reinstall my OS to get this working… There's got to be an update coming – right?

  • siednarb Level 1 Level 1 (0 points)

    I too am having the exact same problem - was told I had a software update to iPhoto for 9.2 - it took less then a minute to rebuild the library after the update which I thought was very slow compared to previous iPhoto updates - then I tried to import photos taken today with my new iPhone 4S - I could see the photos but when I went to hit the import button the application crashed with an error report. Thinking this was the new phone's fault I tried my old 3GS phone and then my SLR camera - same problem!

     

    One thing I noticed is that after I hit the import button and before it crashes, the button for "Stop this Import" appears and the button is oddly placed in the iPhoto window - overlapping into the desktop -

     

    I'm hoping this is a bug and Apple is going to release a fix soon before I resort to other options - I'm on vacation at the moment and don't want to rebuild my library until I get home and back up my computer - any other suggestions/ideas?

  • SFMacNewbie Level 1 Level 1 (10 points)

    Well, I was sure this was a bug that I'd discovered and that appears to be the case. I'm going to wait for Apple to fix it or for someone more experienced than I to reply here with something that likely works. While I'm no longer a MacNewbie (my ID here is nearly 4 years old now) I don't want to jump through major hoops to work this out.

     

    FWIW, it is also doing it with the new iPhone 4S that arrived yesterday. I'd love to take a bunch of photos with its new, stunning camera but I won't be able to import them until this gets fixed.

     

    Hard to imagine that someone at Apple didn't pick this up during beta testing.

     

    I'm sure they are swamped with questions about the new phone, the new iOS, iCloud (which I'm holding back on moving from Mobile Me to based on discussions of problems in that community), and all these updates to Lion etc but let's get this solved ASAP, please?

     

    Thanks!

    Kris

  • radiocafe Level 1 Level 1 (0 points)

    Just spent the last few hours troubleshooting this.  The problem seems to be isolated to the 3ivx install.  Try deleting (Your Hard Drive)/Library/Application Support/3ivx and I'm betting it will work.  I'm now a happy camper.

  • fnell Level 1 Level 1 (0 points)

    Thank you for the suggestion.  I tried but iPhoto crashed as before.  It was a good idea.

  • * Ron * Level 1 Level 1 (0 points)

    Hey...that was great!  It fixed it!     So...just what...I say WHAT is the 3ivx supposed to do anyway?  (Now that it's gone, just wondering.

  • Jose Blackorby Level 1 Level 1 (5 points)

    Me too!!

     

    3ivx is a video codec.

     

    But radio...how on earth did you figure this out?

     

    Many thanks to you.

  • Michael Benzman Level 1 Level 1 (0 points)

    Had the same problem after updating to iPhoto 9.2.  Initially it worked okay, then after I snapped a photo and tried to view it, iPhoto crashed immediately and repeatedly.  Before upgrading to 9.2, I read somewhere that 3ivx was causing problems with iPhoto, but don't recall what.  As a preemptive move, I went into System Preferences and removed the preference pane, since I didn't think it was a necessary element to my current needs and if it was, collateral damage would be minimal.  Apparently though, that wasn't enough, because it left behind the 3ivx folder (plist, etc.) in the Library/Application Support.  After finding this thread and following radiocafe's instructions, I was able to launch iPhoto and get Photo Stream working.  Sure is nice to see my photos on the iMac within seconds of taking them.  Makes life a whole lot easier.  Bugs aside, iCould will change computing as we know it.  Thus, a question is conjured; who will be the next innovator?  I miss SJ already.

  • Christine Hall Level 1 Level 1 (5 points)

    sorry to be dumb but what is 3ivx install?  My iPhoto was working fine until I tried the Photostream.  I have Lion and the latest iOS5 on iPhone 4 and iPad2, also the latest iPhoto version.  It crashed and crashed and I did the option/comand thing and restored.  It works unless I select Photostream and then it crashes.

  • Michael Benzman Level 1 Level 1 (0 points)

    If you have 3ivx on your system, remove it as instructed.  First remove the prefernce pane and then remove the 3ivx folder as described in previous posts.  If you don't have 3ivx, then I cannot help because that's what fixed it for me.  So, to remove 3ivx, go to System Preferences, then to Other where you'll see 3ivx.  Right click on it and remove it.  Then go to your HD, drill down into your Library/Application Support until you find the 3ivx folder and delete that.  Should work now!

  • SFMacNewbie Level 1 Level 1 (10 points)

    I don't understand "As a preemptive move, I went into System Preferences and removed the preference pane". Removed the preference pane to what? And System Preferences globally or the preference option within iPhoto itself?

     

    And what is the significance to getting rid of 3ivx-will I miss it it it need it for something? I noticed I have a 3ivx uninstaller. Will that be sufficient?

     

    Aside from eliminating any 3ivx files, anything else?

  • Jim Kohn Level 1 Level 1 (15 points)

    Thank you radiocafe, that was easy and seems to have worked. Will I miss 3ivx down the road?

Previous 1 2 3 4 Next