Previous 1 6 7 8 9 10 Next 169 Replies Latest reply: Mar 30, 2015 3:14 PM by ejn Go to original post
  • sillyvalley Level 1 Level 1 (95 points)

    In my case (iPhone 5, OSX 10.8, iOS 6, iTunes 11), I changed iMessage settings on the Mac during a sync and triggered the problem. (I had changed some other settings within iTunes during sync and never had a problem.)  I forced sync to stop and restarted sync.  Stuck.  I ejected iPhone, replug, and restarted sync.  Stuck.  I even rebooted iPhone.  Guess what happened?  The message recurred in iTunes immediately after I plugged iPhone back in, without asking for sync.  The syncing icon didn't appear on iPhone.  I couldn't bear to remove voice memos (or delete backups) as some had suggested - it is insane to lose data on this. (Besides, I can't convince myself that what good is removing voice memo for this problem.)

     

    The last thing I tried got sync to complete: Quit and restart iTunes.

  • MLVNYC Level 1 Level 1 (0 points)

    I had this problem going on for a week+.  A bunch of updated apps wouldn't install, saying "waiting" on the phone.  iTunes showed the same "waiting for changes..." message.  At the Apple store I was encouraged to restore the phone from a backup. Needless to say, I wanted to avoid that.

     

    After reading this and some other postings, I dragged all voice memos in my iTunes library to a new folder on my desktop, then deleted them from the iTunes library.  Next sync worked like a charm, everything is back to normal.  Haven't tried putting the memos back into the library, but if I do and there's a problem, at least I'll know how to fix it.  There's an obvious bug here, would be nice if Apple addressed it in an update.

  • Woody N La Level 1 Level 1 (0 points)

    I have been having this issue even before upgrading iTunes. Still had it after the upgrade and after many tries I did a search and found this thread. After reading the suggestion of not syncing notes (which I only do on cloud) I checked to sync notes, then unchecked it and hit apply. Sync worked like a champ after that without restoring or deleting anything.

  • Woody N La Level 1 Level 1 (0 points)

    Duplicate post deleted.

     

    Message was edited by: Woody N La

  • starjamgirl Level 1 Level 1 (0 points)

    I have tried several things mentioned in this thread and nothing has worked. I have an ipod touch 4th gen, i-tunes 10.5.1.7 and software 5.1.1, have not been able to sync itunes ever since I got this new laptop mid last year and had to import all of my songs into itunes again with 5958345 duplicates to sort through. When I run diagnostics: device sync test it says

     

    "2013-02-11 15:33:38.974 syncli.exe[5344:18d8] setting one shot sync group for cl

    ient com.apple.MobileSync.91177ace0f75b8f83d4851cf3e87b901f33f8a8b

    2013-02-11 15:33:41.677 syncli.exe[5344:18d8] 003A3B78 009CF9A0 (syncli.exe) win

    dows_msg - Error getting overlapped result for named pipe: 109"

     

    When trying to sync it always says: (step 1 of 3) waiting for sync to start then goes past step 2 of 3 very quickly (preparing to sync) then waiting for changes to be applied for awhile then is done and my music is still not updated on my ipod when I check if it has   what else can i try? without reinstalling/having to put my music all back into itunes

  • robrayjr Level 1 Level 1 (0 points)

    This worked for me.  Thanks.

  • jrwhip Level 1 Level 1 (0 points)

    Solution to this problem–DO A COMPLETE RESTALL AND RESET TO FACTOR SETTINGS.  Anyone who has used Microsoft and Google products can attest that this is SOP for subpar crap.

     

    Now that Steve Jobs is gone is my Mac, my iPhone, and my iPad going to suck just as much as Windows and Google always have.  Isn't there someone at Apple who cares about quality! Have we really entered the DARK AGES of computers because there is not a single person who cares about this company like Jobs.

     

    I miss you Steve. I have been an Apple user since 1984.  I morned the decline of Apple in your absence during the early years and celebrated your return, and reveled in all of the great products you gave us that JUST WORKED!

     

    I wish you had lived longer, not just for you and your family, but for the entire world. I wish you had been able to fine a sucessor.  I suppose my only option is to go with Microsoft and Google, not because they are better, but because Apple now ***** just as much as they do, and if I am going to have to deal with sub par products the rest of my life at least they are a little cheeper.

  • jeremyharcup Level 1 Level 1 (0 points)

    This is how I fixed mine.

     

    I went in to settings and iCloud - noticed that there was a message saying that the iPad was being restored (still.)  I stopped that service, there is a switch for this, and after that the problem went away.  Syncs properly again.

  • chichizzle Level 1 Level 1 (0 points)

    Totally worked for me. Just that easy. Thanks!!

  • millbank Level 1 Level 1 (0 points)

    I had the same issue on iPhone 5, Mac OSX 10.8.3 - I did a factory reset and a backup restore however, the problem persisted. I found that by looking in Summary - Options and removing the tick from "Automatically sync when this iPhone is connected". The problem resolved itself for me. 

  • DanVentresca Level 1 Level 1 (0 points)

    Make a phone call.

     

    I've had this problem off and on throughout the life of my Verizon iPhone 4S, but I only discovered this simple fix when I received a phone call during the "waiting for changes to be applied". Next time iTunes hung during "waiting...", I called a 1-800 number from the iPhone. When I ended the call, iTunes was done syncing. Sounds crazy, but it's worked everytime.

  • rob141 Level 1 Level 1 (0 points)

    I have tried EVERYTHING in this thread to fix this problem.

     

    Nothing has worked.

  • Arck27 Level 1 Level 1 (0 points)

    I am also having this issue after upgrading to IOS 7. Prior to the upgrade I was having syncing issues with apps, where two apps (Facebook and Soundhound) didn't sink. I unplugged and tried to sync again, then every time I attempted to sync, my other data would keep increasing. Once I upgraded, everything seemed to be normal until I hit sync. Now, when syncing "Waiting for changes to be applied" is stuck. I have reset my phone and my computer but nothing. Any suggestions?

  • Massimo Fiorentino Level 1 Level 1 (100 points)

    It is like the iPhone (in my case anyway), "drops" the connection in the final step where it says "Waiting for changes to be applied". The spinning arrows keep "running" in iTunes but stops on the iPhone at the exact time the sync enters this step. And then iTunes keeps on spinning until you drop the connection or cancel the synchronisation.

     

    Is that the same timing you guys have?

     

    :-m

  • Massimo Fiorentino Level 1 Level 1 (100 points)

    Strangely enough, I have problems signing in to FaceTime / iMessage on my iPad, which do *not* have the same problem with syncing. The Ipad "forgot" a lot of my passwords, while my iPhone did not. Any connection perhaps? An Apple ID issue since this also occurs on PC?

     

    Message was edited by: Massimo Fiorentino

Previous 1 6 7 8 9 10 Next