Skip navigation

waiting for changes to be applied

183884 Views 164 Replies Latest reply: Apr 12, 2014 2:39 PM by sarahc127 RSS
  • grzes_l Calculating status...
    Currently Being Moderated
    Oct 17, 2011 4:12 AM (in response to blackadder1999)

    Probably by your clean restore you just fixed error with voice memos.

     

    I did check what is not copying properly - what can be the reason that iPhone is stuck. It apeared these were voice memos - which never copied to my library.

    Delete them from your iPhone. I additionally unchecked sync notes (as I have them synced with iCloud).

     

    Issue solved. No restore, risking your data or wasting your time required.

  • Recto Bold Level 1 Level 1 (30 points)
    Currently Being Moderated
    Oct 17, 2011 8:05 AM (in response to grzes_l)

    Unfortunately that solution didn't work for me. I have over 400 memos (I use them to record riffs/ideas etc.) so manual deletion is a nightmare - Had to use PhoneView to delete them all physically off of the 'phone (you can't do that from within iTunes). Once I had done so it made no difference - Just got stuck on photos instead. So, I turned off Photo syncing - No difference. I've wasted a good few hours on this now - Plenty of people clearly having the same issue, and it's interesting to note that in the beta stages testers were reporting it (just Google the issue), so it's not just something that is recent.

     

    I suspect that the only thing that is going to work for me is Apple releasing a fix - I've tried pretty much everything else, short of a restore and manual reinstall of apps etc., which is just going to take way too long. So far iOS5 has been a bit of a pain in the hole for me on the iPhone, but oddly I had none of these issues with my iPad - No idea why that might be, since Identical things are being synced.

  • bryanlikestomtb Calculating status...
    Currently Being Moderated
    Oct 17, 2011 6:58 PM (in response to threeshoesva)

    I had the same problem, have a ipod touch on ios 4 and updated to ios 5, sync and that got stuck on waiting for changes to applied. before i restored it i closed itunes and relaunched it. works fine now.

  • Suthran Calculating status...
    Currently Being Moderated
    Oct 18, 2011 5:33 AM (in response to Recto Bold)

    You are right here. I only having problems with my iPhone 3GS. My iPad2 syncs perfectly.

  • Suthran Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 18, 2011 6:10 AM (in response to blackadder1999)

    A factory reset does fix the sync issue.

     

    Here are the steps i have carried out:

    1. Factory reset the iPhone. After the reset, I was asked whether to restore from backup. I said no and therefore setup the iPhone as a new unit.
    2. Synced apps.
    3. Synced Contacts, Notes, Calendars, and Bookmarks with Outlook.

     

    I will now try adding my music, photos and videos.

  • Markusm10 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 18, 2011 9:54 AM (in response to threeshoesva)

    I just had to close iTunes and restart it, then the phone synched as it should.

     

    - iPhone 4s

    - Windows 7 with the latest iTunes and iOS updates installed

  • SmokeyGADay Calculating status...
    Currently Being Moderated
    Oct 18, 2011 12:49 PM (in response to threeshoesva)

    I had the same problem (stuck on step 4) and, nervously, I tried the restore.  I'm pleased to report that it worked for me.  Thanks to those that tried it out before me to see if it would work  

  • af7962 Calculating status...
    Currently Being Moderated
    Oct 18, 2011 4:50 PM (in response to threeshoesva)

    Don't know if this helps but I was getting same error when connected with usb cord so tried to sync via wifi and it worked. Maybe having wifi on and usb connected causing issue?

  • just some guy who likes macs Calculating status...
    Currently Being Moderated
    Oct 19, 2011 3:16 AM (in response to threeshoesva)

    Try shuting off photo syncing.

     

    I had the same problem and it went away when I shut off photo syncing.

     

    It comes back if I turn photo syncing back on, but leaving it off seems to work.

  • furrywolf Calculating status...
    Currently Being Moderated
    Oct 19, 2011 8:53 PM (in response to threeshoesva)

    If a restore and then using the backup doesn't fix it, try not using the backup.

     

    Unfortunately, the data on the iPhone may be corrupt and you are just putting the bad data back on.

     

    I tried restoring and using a backup, but that didn't work. I had to set it up as a new device

     

    I then went through each section (Info, Music, Apps, Movies, etc) one at a time. I also only loaded about 20 apps at a time.

     

    I had to do my email accounts by hand though since all of them are (Google App) Exchange accounts and the iTunes synch wanted to move them over as Gmail (No Contacts)

     

    Anyway. It's all back up and runnong, but I think my olb backup os trash.

  • Tigon Calculating status...
    Currently Being Moderated
    Oct 20, 2011 3:12 AM (in response to threeshoesva)

    FINALLY!! Thanks for the tip that the problem might be with voice memos. WORKED for IPHONE4!

     

    I had probably tried everything, unchecking all the iTunes Sync boxes didn't help, deleting all the data (song, voice memos from iTunes libaries didn't do it either. I had got all the error messages like.

    "waiting for items to copy"

    "waiting for changes to be applied" etc.

    If I interupted the unfinished sync and ejected the iPhone4, iPhone sometimes showed message "Two items could not be synced. See iTunes for more information." But I couldn't find any info from iTunes as I just had ejected the phone.

     

    The problem was with my Voice Memos in iPhone4. For some reason it copied them in the iTunes libary but was unable to finish the sync. (Unchecking Sync voice memos didn't help). Since I had the files in iTunes I copied them from

    Users/Home/Music/iTunes/iTunes Media/Voice Memos/

    to a new folder. Then I deleted all voice memos in iTunes.

     

    after this I DELETED ALL THE VOICE MEMOS IN IPHONE4 and was finally able to complete the sync! Since I had copied the Voice memos for a new folder, I just copied these files back to iTunes media libary and now I can Sync without problems and listen old voice memos as music files.

    I hope this helps someone.

  • kaveh1353 Calculating status...
    Currently Being Moderated
    Oct 24, 2011 8:38 PM (in response to threeshoesva)

    Hi

    I had this problem, but it solved when I renamed some files in iBooks library, those files had filenames in other languages.

     

    Good Luck.

  • T.Hurst Calculating status...
    Currently Being Moderated
    Oct 27, 2011 8:27 AM (in response to threeshoesva)

    I am having the same problem with my iPhone 4 and iTunes for Windows 7.Untitled-1.jpg

     

     

    I have tried to restore, but its not fixing the problem. I am going to go to Apple this weekend if I cannot fix it.

  • T.Hurst Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 27, 2011 8:28 AM (in response to Tigon)

    I did that too, and it didn't work...

  • T.Hurst Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 27, 2011 8:30 AM (in response to blackadder1999)

    Restoring the iPhone, didn't work... Anymore ideas?

1 2 3 4 ... 11 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.