1 2 3 4 5 6 Previous Next 166 Replies Latest reply: May 7, 2014 2:30 PM by bobby522 Go to original post
  • 45. Re: waiting for changes to be applied
    McLagan Level 1 Level 1 (0 points)

    iPhone 4, up to date, iTunes up to date. Every time i try to sync I get the same message as everyone else: Waiting for changes to be applied. It doesn't stay there very long, only a few seconds then the display just goes blank. I've tried a factory restore which temporarily solved to problem but now it's back again. I don't have any voice memos on the phone and the only thing I'm syncing is music and apps. Would really appreciate some sort of solution for this, don't want to have to factory restore my phone every time i want to add music to it!

  • 46. Re: waiting for changes to be applied
    nerfTractor Level 1 Level 1 (0 points)

    Plus one from me. My iPhone 4S does not have the issue but iPad 2 does. Syncing with iMac running latest Lion and all devices are latest iOS 5

  • 47. Re: waiting for changes to be applied
    Nivaun Level 1 Level 1 (0 points)

    I was having the same issue. The lady at tech support wanted me to delete and reinstall my iTunes, something I was not going to do.

     

    What worked for me was moving all my voices memos from the iTunes Media folder located in the iTunes Finder of Music to a backup disk.

     

    Then I deleted all my voices memos from within iTunes.

     

    Then I deleted all my voice memos from my iPhone 4.

     

    Did a sync and it works now. No more "waiting for changes to be applied".

     

    Next I restored the voice memos back into iTunes.

  • 48. Re: waiting for changes to be applied
    TigersLSU Level 1 Level 1 (0 points)

    I did a complete restore and that did not work.  After the restore, I deleted the voice memos and that worked for me.

  • 49. Re: waiting for changes to be applied
    blckwngange Level 1 Level 1 (20 points)

    This is because you restored from backup, not as new. You put the issue back onto your device. They said to restore to factory settings, that means set up as a new device.

  • 50. Re: waiting for changes to be applied
    gerald-gt Level 1 Level 1 (0 points)

    ** If you are in a rush, scroll down to see the solution that worked for me **

     

    I started having this issue with my iPhone 3GS running iOS 5.0.1 after I enabled the option to sync photos. After reading the posts here and in another thread, I was convinced that it had something to do with the voice memos as I noticed that my voice memos were being duplicated in the voice memos app. However, even after deleting all of the voice memos from my iPhone, I still had this syncing problem. I then noticed that in iTunes on the left side under Devices -> <device name> -> Voice Memos, there were two voice memos showing up even though I had deleted these from my iPhone. Strangely, I could even play these back in iTunes. That told me that something was not right. In addition, there was a book showing up under Books even though I had deleted all books from the iBooks app.

     

    By enabling the "manually manage music and videos" option from the device summary page, I was able to delete the two voice memos and book. However, doing this did not fix the syncing problem.

     

    I tried various other workarounds mentioned in this thread, short of doing a restore, all without success. I was about to give up and do a restore when...

     

    ** Solution that worked for me **

     

    I came across this page http://apple.stackexchange.com/questions/8758/why-is-itunes-duplicating-my-voice -memos and it mentioned using Phone Disk (http://www.macroplant.com/phonedisk/) to remove voice memos from the iPhone file system.

     

    Using Phone Disk I browsed to the Recordings directory on my iPhone and I could see a bunch of .m4a files for the voice memos (including the duplicates), even though I had previously deleted these memos from the Voice Memos app. So I deleted everything under the Recordings directory. I also deleted everything under the Books directory for good measure. After doing this, my iPhone syncs normally again!

     

    Anyways, I hope this helps those of you who haven't been able to resolve this issue and who do not want to do a restore. Of course, it goes without saying that you should make backups (by copying files to your machine) before deleting anything.

  • 51. Re: waiting for changes to be applied
    outside.back Level 1 Level 1 (0 points)

    Brand new phone, a 4S, tried the factory restore and it did not work. What did work was deleting all voice memos.

  • 52. Re: waiting for changes to be applied
    Cheesed off Level 1 Level 1 (0 points)

    Hi,

     

    Sorry i'm a bit new to all this so i don't know if i'm in the right place, my iphone 3gs first had the 'waiting for items to be copied' message that wouldnt finish and now has the ''waiting for changes to be applied' message (since i tried to sync my contacts) I have just changed my hard drive and re-installed the latest itunes but didn't have this problem until i did an iphone update.....

     

    I have read that if i do a re-boot (hold the home button + the power button for 10 secs then release the power button whilst still holding the home button for another 10 sec) it SHOULD (in most cases it seems) cure the problem.....

     

    My problem is, i don't know if my phone has synced all my phone numbers etc, so i am a bit loathe to try this re-boot without finding out if it has or not.

     

    Does anyone know how to check this?

     

    Thanks

     

    Noob.

  • 53. Re: waiting for changes to be applied
    Cango_UK Level 1 Level 1 (0 points)

    Thank you gerald-gt, that worked perfectly.

     

    I used Disk-Aid to get rid of the recordings from the phone's disk and it seems OK now.

     

    This is 100% relevant - http://apple.stackexchange.com/questions/8758/why-is-itunes-duplicating-my-voice -memos

     

    I have not looked into it further but I would imagine that the voice memo's I recorded before going up to OS5 might have caused the problems.

  • 54. Re: waiting for changes to be applied
    sleser Level 1 Level 1 (0 points)

    Thanks grzes_l! Your tip worked for me.

     

    I have an "existing" iPad and a new iMac. I wanted to synch my iPad with my new iMac. I authorized my new iMac on the iTunes Store  (see http://support.apple.com/kb/ht1848) and clicked on "Transfer Purchases from xxxiPad". It got stuck on "waiting for changes to be applied". I realized it was stuck doing nothing because the Synch icon (the circle moving arrows) that appears on the iPad on the upper left and on iTunes next to Device disappeared. Also according to iMac iTunes was not responding anymore.

     

    I went to iTunes, under Device -> Books and deleted the 4 books that were in there, which indeed had a grey icon. The four books were also under "Purchases"? (it is below Books, my iTunes is in German, it is called Einkäufe). Then I restarted the process of "Transfering Purchases from iPad" and it worked! Only after synch it messed up all my apps visual organization. Data untouched, but Groups were gone and I had to organize it all again.

     

    To be on the safe side I also deleted one video I had on OPlay, but I think it was the books that were causing the problem.

     

    Very very annoying bug!! If it were not for this forum I would be going in circles until now!! Two Apple products should be able to talk to each other without this mess!

     

    Thanks a lot!

  • 55. Re: waiting for changes to be applied
    pelegfn Level 1 Level 1 (5 points)

    I haven't tried following all of your steps, but I wanted to thank you for recommending this software.

     

    http://www.macroplant.com/store2.php#

     

     

    While my initial problem of the endless "waiting for changes to be applied" brought me to this discussion board, the software you recommended recovered what I thought were lost voice memos of my children as babies (they disappeared after upgrading to iOS5).  You just made my day.  Thank you!!

  • 56. Re: waiting for changes to be applied
    gerald-gt Level 1 Level 1 (0 points)

    Wow, I don't think I can take all the credit for that. But I'm really glad to hear that you were able to recover your childrens' voice recordings. I know I would be very upset if I were to lose any photos/videos/etc. of my children. Anyways, thanks for telling me your happy story! All the best to you!

  • 57. Re: waiting for changes to be applied
    gerald-gt Level 1 Level 1 (0 points)

    Yes, it does seem that there is something funny/buggy going on with the voice recordings. Hopefully Apple finds a fix for this problem soon!

  • 58. Re: waiting for changes to be applied
    Vic Rattlehead Level 1 Level 1 (0 points)

    I have an iPhone 4S, using a Dell laptop circa 2008. 

     

    Encountered this problem, began to do a factory restore, but then saw that a simple hard reboot may work, and it did.  Thanks, Cheesed Off, for hitting me over the head with that. If I had not read your post, I would have simply forgotten to try that.

  • 59. Re: waiting for changes to be applied
    JGLF Level 1 Level 1 (0 points)

    First thing to do is shut off the cloud on your phone. Then you must do the same thing on your MAC/PC. For PC go to control panel and disable all cloud synching and go back to synching with a chord. Works for me!

1 2 3 4 5 6 Previous Next