6 Replies Latest reply: Dec 29, 2012 9:43 AM by Brian Brady
g1r2e3g Level 1 (0 points)

My partner has an iPhone 3GS but switched to Android recently and still uses the iPhone at home as in iPod. However now after upgrading the 3GS to iOS5 if I try to send an SMS to their number it will iMessage the 3GS and not SMS to the Android, so I have to disbale iMessage altogether to send an SMS to their actual phone.

 

Surely there is many people in various situations like this. There should be a way to disbale certain contacts from iMessage altogether or at least some way in the message composer to choose the transport method per message.


iOS 5
  • NickL-UK Level 1 (0 points)

    I have pretty much the same issue as you - but a slight variation therein.

     

    https://discussions.apple.com/thread/3397594?tstart=0

     

    I am hoping that the simple answer will be that you can access the list of numbers associated with iMessage through your AppleID, via iTunes or however, and deselect numbers. If that functionality isn't available yet - I hope it will be at some point in the future.

  • g1r2e3g Level 1 (0 points)

    Agreed Nick. Would seem wise that there be some option to choose the transport method per contact, but there definintel is'nt at this stage. Until then the best fix I have found is to buy a cheap pre-paid sim card to reactive the iPhone so the iMessage account will be attached to a differnet number.

  • Batman469 Level 1 (0 points)

    I had the same problem.  This is what I did and it took about 10 mins to take affect.  I removed the Sim card from the iPhone 3GS and put it in the Android phone.  A texted a few times and it automatically removed the iMessage from my phone and started send regular text messages.  However, remember to turn off iMessage on the iPhone ur not using anymore.  Hope this helps!

  • CommunityHelper Level 1 (0 points)

    There is no way to disable imessage for certain contacts.

  • socceryo3 Level 1 (0 points)

    You can make it send it as a text message. After you type the message and hit send, tap and hold on the blue message. Two options will pop up: copy and send as text message. I just figured this out myself.

  • Brian Brady Level 1 (5 points)

    This doesnt work for me, only option is to copy. Having issue where my sister had iphone and switched to droid. Now I cannot send her anything all show up as imessage. Weird thing is they show as delivered.