Previous 1 2 3 4 5 Next 74 Replies Latest reply: Jan 28, 2013 3:01 PM by jsphd Go to original post
  • code2medic Level 1 (0 points)

    I had the issue and I just closed out itunes and reopened it and poof it worked

  • sj04736 Level 1 (5 points)

    Try this, it worked for me after nothing else here would:

     

    Open the windows firewall settings, and look if "SyncServer.exe" is allowed. I'm gonna guess it isn't even listed

     

    Instructions (Windows 7 x64 - Vista is probably similar):

    Open "Control Panel"

    Select "Windows Firewall"

    Click "Allow a program or feature through Windows Firewall"

    Look for "SyncServer" in the list. It won't be there.

    Click "Change Settings" then "Allow another program"

    Click "Browse..."

    Find "C:\Program Files (x86)\Common Files\Apple\Mobile Device Support\SyncServer.exe"

     

    Restart iTunes and your iPod/Phone/Pad should appear in iTunes even when disconnected. If not, try rebooting to make sure everything is reloaded properly.

  • thomasfromfreeport Level 1 (0 points)

    Okay, I finally figured this out and it was so obvious.  I tried all of the tips mentioned below and nothing worked.  When I happened to stumble upon an option in iTunes. 
    1. Plug your device into the computer running iTunes.
    2. Click on the device name in the iTunes sidebar.
    3. On the Summary tab, scroll down.
    4. You should see an "Options" section and an option in the list named "Enable sync over wifi" or something like that.
    5. Check that box and click the Apply button in the bottom-right corner.
    6. Wait for your device to finish syncing.

    7. Eject (unplug) the device.
    8. Reboot your wifi router.  (I just unplugged it, waited a few seconds and plugged it back in.)
    9. Reboot your PC.
    10. Open iTunes.

    You should see the device show up in the sidebar.

  • Jeffannamd Level 1 (0 points)

    Apple, give Thomas 10 points.  His solution worked for me.  Both my ipad2 and iPhone 4S are syncing wirelessly after following Thomas' solution.

  • Pankajno1 Level 1 (0 points)

    Tried all of the previous posted steps... nothing works. I have Win 7 Home Prem 64bit, with iTunes 10.5.0.142 and IP4 with iOS 5.0, if anyone solved it with some other specific step, please share.

  • FstrThanYours Level 1 (0 points)

    Also tried everything with no luck.

     

    Windows 7 64 bit

    iPhone 4, iPhone 4s, and iPad 2 (none will wirelessly sync)

    AT&T Uverse Router

  • pushingtim Level 1 (0 points)

    My "Sync Now" button is also greyed out after trying all suggested steps.  I have another problem (Itunes store will not load.  Just shows a white window with a few blue hyperlinks at best, even after several re-installations of itunes 10.5) which forced me to download an album from itunes using my iphone 4.  After 15 minutes or so I went to sync my iphone to my PC using the cable but noticed itunes was in the final stages of syncing the new album to my PC.  Both my PC and iphone were using my home wifi, but "sync now" still grey, and my iphone was not listed in itunes left window!    Work that one out! 

     

    I really want to get this sorted.

     

     

    Tim.

     

    iphone 4 ios5

    Windows 7 32 bit

    itunes 10.5.

    BT homehub (the black one)

  • RB_Houston Level 1 (0 points)

    I had the same problem. WiFi sync started working after re-booting PC.

     

    iphone 3GS ios5

    Windows 7 64 bit

    itunes 10.5.

  • Esoqq Level 1 (0 points)

    Well, I finally was able to get this working by uninstalling and reinstalling iTunes. Was scared I would lose all the settings but that didn't happen. Went pretty smooth.

  • guitarnicky20 Level 1 (0 points)

    I have an idea for a solution because I ran into a problem once where I couldn't open any programs at all on my computer. For whatever reason I couldn't run anything unless I right clicked on the program and selected "run as administrator" from the list.

     

    To always run iTunes as administrator:

    1. Right click on the iTunes shortcut on your desktop or in your start menu

    2. Click properties

    3. Click the Compatibility tab

    4. At the bottom there should be a checkable box with the text "Run this program as an administrator", make sure it's checked

     

    I'm not saying this will work for everyone and I'm sure somebody will come up with a universal fix someday, but this is what worked for me.

  • nevaenuf Level 1 (0 points)

    A free wireless router firmware upgrade fixed this issue for me.

    (ASUS RT-N16 router upgraded to 1.0.2.3)

     

    Thanks Kevin e.

  • Renesis Level 1 (0 points)

    sj04736 wrote:

     

    Try this, it worked for me after nothing else here would:

     

    Open the windows firewall settings, and look if "SyncServer.exe" is allowed. I'm gonna guess it isn't even listed

     

    Instructions (Windows 7 x64 - Vista is probably similar):

    Open "Control Panel"

    Select "Windows Firewall"

    Click "Allow a program or feature through Windows Firewall"

    Look for "SyncServer" in the list. It won't be there.

    Click "Change Settings" then "Allow another program"

    Click "Browse..."

    Find "C:\Program Files (x86)\Common Files\Apple\Mobile Device Support\SyncServer.exe"

     

    Restart iTunes and your iPod/Phone/Pad should appear in iTunes even when disconnected. If not, try rebooting to make sure everything is reloaded properly.

    Thanks sj04736 this one worked for me

  • angjfong Level 1 (0 points)

    "On your phone go to Settings>Wi-Fi and then press the little blue/white arrow on the far right of your network name, scroll down and then press renew lease. I tried it once and it didn't work, but I then spammed it over over over again and after about 4 or 5 times i tried the Wi-Fi sync again, and it worked!"

     

    The above worked for me!  THANKS!!

  • Zac@Apple Level 1 (0 points)

    This is the correct answer troubleshooting steps are outlined in TS4062 http://support.apple.com/kb/TS4062?viewlocale=en_US

  • jtinsocal Level 1 (0 points)

    sj04736 wrote:

     

    Try this, it worked for me after nothing else here would:

     

    Open the windows firewall settings, and look if "SyncServer.exe" is allowed. I'm gonna guess it isn't even listed

     

    Instructions (Windows 7 x64 - Vista is probably similar):

    Open "Control Panel"

    Select "Windows Firewall"

    Click "Allow a program or feature through Windows Firewall"

    Look for "SyncServer" in the list. It won't be there.

    Click "Change Settings" then "Allow another program"

    Click "Browse..."

    Find "C:\Program Files (x86)\Common Files\Apple\Mobile Device Support\SyncServer.exe"

     

    Restart iTunes and your iPod/Phone/Pad should appear in iTunes even when disconnected. If not, try rebooting to make sure everything is reloaded properly.

     

    This worked instantly for me.  Restarted iTunes and my 4S finally started to show up.  Thanks sj04736!!